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Chapter 1  
Introduction to LogCheck 

 

By the end of this chapter you will be able to: 

 

▪ Understand what LogCheck does. 

▪ Understand the LogCheck user interface philosophy. 

▪ Understand the features of LogCheck. 
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1.1  What does LogCheck do? 

LogCheck is a Windows-based system for the management of coal exploration downhole data. It has 

been designed and written by experienced coal geologists who understand their colleagues' needs. It 

includes facilities for: 

• data entry, validation, plotting and reporting of hole header (location information), drilling, 

water flow, downhole geological and geotechnical (rock mass unit, defect and point load) data, 

• plotting of downhole geophysical data, 

• import and export of dictionaries and data to and from geological databases and modelling 

packages, such as Acquire, Geobank, MineScape (GDB), Vulcan and Minex, 

• production of various audits and summaries, including summaries of: data currently stored for 

each hole; dictionary code usage; drilling meterage; seams, horizons and samples in each hole; 

contents of downhole geophysical (LAS) files; rock mass unit characteristics and point load 

indices. 

It complements geological database and modelling packages such as Acquire, Geobank, MineScape 

(GDB), Vulcan and Minex by providing a system which: 

• has comprehensive validation facilities, 

• is easy to learn with a user interface similar to other Windows programs such as Excel and 

thus easily picked up by short term geological contractors employed during drilling programs, 

• does not tie up an expensive mining package licence for data entry, 

• enables the plotting, in numerous different formats, of any of the data variables stored in it. 

1.2 History of LogCheck 

LogCheck evolved from a DOS-based system called LogBase. This was first developed in 1995 to 

facilitate the entry and validation of lithology data by coal geologists. It then expanded into generating 

graphics and providing entry and validation of geotechnical data. 

In 2002, the system was rewritten into the Microsoft Windows environment and renamed LogCheck. It 

currently has over 300 users at over 100 sites, chiefly in Australia, but also in Indonesia, Russia and 

Mongolia. 

1.3 LogCheck’s User Interface Philosophy 

LogCheck has a relatively simple user interface, making it appropriate for use by short-term 

contracting staff who are not on site long enough to warrant lengthy tuition.  

The simplicity of LogCheck’s user interface is based on an “object oriented approach”. This is one of 

the current buzz words in computing. In LogCheck’s case, it means that there is always a particular set 

of data open (the “object” in computer jargon) and LogCheck’s menus change according to the current 

data to reflect the actions (the “methods” in computer jargon) that can be performed on that data. 

Apart from offering options for all these actions, the menus also provide options to create a new data 

table for a new hole or open another data set. 
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1.4 LogCheck Data Types 

LogCheck data types fall into seven general categories: 

1. Dictionary data: valid codes and their meanings. A dictionary is required for each hole data 

type (see below). Dictionaries can be imported, entered, modified, printed, 

exported and plotted as a legend. 

2. Project data:  including the project title to appear on reports and plots; company logo for 

reports, survey coordinate grid type, rectangular coordinate limits for the 

project. 

3. Drill Site data: including proposed hole purpose and location, landholder, environmental 

authority, conduct & compensation agreement, cultural heritage, site 

preparation and rehabilitation. 

4. Hole data: a separate file is created for each data type for each hole. Current available 

data types include: 

 Headers Rock Mass Units (RMU) 

 Cementing Defects 

 Casing Acoustic Scanner Analysis 

 Geologists Point Loads 

 Drilling Geotechnical Laboratory Tests 

 Geology  

 Water Flows Coal Quality Results 

 Downhole Geophysics (Las) Composite Constituents 

 Sample Dispatch  

 Rehabilitation 

 

Hole data can be imported, entered, modified, printed, plotted and 

exported. The only exception is that downhole geophysical data cannot be 

entered or modified, only imported from Las files. 

 

5. Daily Activities data: a record for the day of sites rehabilitated, safety procedures implemented, 

general comments and planned operations for the next day. 

 

6. Audit, Summary and  includes Project Audits, Hole Audits, Hole Summaries, 

 Statistical data:  Drilling Summaries, Seam Summaries, Sample Summaries etc.  

This data is generated from the hole data and can be viewed, exported and 

printed. It can only be modified by editing the original hole data. 

7. Program Control data: used by the program when opening or plotting data. It includes definitions 

for: 

Hole Sets Hole Plans Clean Composites   

Hole Intervals Downhole Plots CQ Test Specifications 

Graphical Editor Plot Colour Scales 

Las Formula Plot Legends 

 Histograms 

 

This data can only be entered and modified. 
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1.4.1 Data Audits  

LogCheck generates a number of data audits that are useful for checking your data. These include the 

following audits: 

• Dictionary listing for each code in the dictionary, the number of times it has been used in the 

data and the names of the first and last holes in which it has been used; 

• Codes listing every instance in the data where a specified code has been used; 

• Projects listing for each project, the number of holes stored in LogCheck for each data type; 

• Holes listing the final depth (or blank if no data present) for each data type for each hole; 

• Uncorrelated Coals listing for each hole, every seam in the hole and between these any 

occurrences of coal not yet assigned a seam name; 

• Unsampled Coals listing for each hole, any coals that do not have sample numbers assigned to 

them; 

• Unsampled Seams listing for each hole, any intervals within seams that do not have a sample 

number assigned to them. 

• Horizons showing for each hole, the depth of each horizon, such as base of weathering; 

• Strats listing for each hole, the thickness of each stratigraphic unit encountered in it; 

• Seams listing for each hole, the thickness of each seam encountered in it; 

• Plies listing for each hole, the thickness of each ply encountered in it; 

• Coal Quality listing for each hole, for each of Ply and Composite sample types, for each of 

Raw, Sized/Washed and Clean Coal Composites the number of samples whose results have 

been entered into LogCheck for each of the following tests: 

Mass HGI  Dilatometer 

Density Ultimates  Gray-King 

Moisture Sulphurs  Sapozhnikov 

Proximates Ash Analysis  Rheology 

Energy Ash Fusability  Trace Elements 

Impurities Physical Properties  Petrography 

CSN Gieseler  Carbonisation 

   Reflectance 

• Clean Coal Composite Types listing for each hole, for each of Ply and Composite sample 

types, how many samples of each defined Clean Coal Composite Type have results in the 

database;  

• Las Files listing for each Las file its: hole name (WELL), top (STRT) and bottom (STOP) 

depths, reading spacing (STEP), logging company (SRVC), logging date (DATE) and 

recorded geophysical variables. 

1.4.2 Data Summaries 

LogCheck generates data summaries that are useful for checking data, passing information to other 

people or computer packages such as modelling systems. These summaries include: 

• Holes displaying for each selected hole, its: 

Site Id Casing Las Files received 

Hole Type and Purposes Logging Geologists Standing Water Level 

Survey Data Horizons and Seams Cementing 

Drilling Summary Geophysical Tools Run Rehabilitation 
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• Drilling listing for each Drilling Company, Rig No and Rig Type in each selected hole: the 

start and end date of drilling and the number of metres of each drilling type; 

• Seam/Horizon Picks listing for each horizon, stratigraphic, seam and/or ply in each selected 

hole its from and to depths and thicknesses; 

• Seams/Plies listing for each seam or ply in each selected hole, its: 

From Depth  Coal Mass 

To Depth  Over/Interburden Thickness 

Total Thickness  Stripping Ratio 

Coal Thickness  Cumulative Coal Thickness 

Parting Thickness  Cumulative Coal Mass 

Core Loss Thickness  Cumulative Over/Interburden Thickness 

Linear Recovery  Cumulative Stripping Ratio 

Average Coal Density  Lithology Summary 

• Samples listing for each Individual or Composite sample in each selected hole, its: 

Purpose  Ply at top 

Sample Number  Ply at base 

From Depth  Drilling Date 

To Depth  Core Size 

Thickness  Sample Density 

Coal Thickness  Theoretical Mass 

Core Loss Thickness  Dispatch Mass 

Linear Recovery  Volumetric Recovery 

Seam at top  Lithology Summary 

Seam at base 

• Seam/Ply Composites listing for each seam or ply in each selected hole, its: 

Seam/Ply Name  Linear Recovery  

From Depth  Sample Number at top  

To Depth  Sample Number at bottom 

Thickness  Basis 

Core Loss Thickness 

and whatever test results the user has selected to list. The user can also select to generate the 

composite values by calculating them from Individual Ply results, Composite results or from 

Composite results plus Individual results where no Composite Results exist; 

• Rock Mass Units listing for each geologist defined Rock Mass Unit (RMU) in each selected 

hole, its RMU data: 

RMU Type  Bed Spacing 

Weathering  Bedding Dip Angle 

Alteration  Moisture Sensitivity 

Estimated Strength  Plasticity 

and the following values calculated directly from the recorded data for each RMU:  

Rock Quality Designator (RQD) Average UCS from Average Axial Index 

Average Fracture Spacing Average UCS from Sonic Log 

Fracture Frequency  Average UCS from Lab Tests 

Average Diametral Index Unit Rating Component Ratings 

Average Axial Index  Unit Rating 

• Drill Run RQDs listing for each core run in each selected hole: its Rock Quality Designator 

(RQD) calculated directly from the Defect data stored in the database; 

• Defect Spacings listing for each defect in each selected hole: the thickness between it and the 

previous defect; 
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• Fracture Frequency listing for each defect in each selected hole: the fracture frequency value 

for halfway between it and the previous defect to halfway between it and the following defect; 

• Point Load Indices listing for each test sample in each selected hole: the calculated point load 

index. 

1.4.3 Statistics 

LogCheck generates statistical reports for the following: 

• Coded Data Frequencies listing for each specified dictionary variable for each selected hole, 

its frequency of occurrence or total thickness. For example, the number of times each lithology 

occurs in the hole or its total thickness for the hole; 

• Interval Thickness Statistics listing for each selected hole: the mean, standard deviation, 

minimum and maximum thickness of the coal intervals in the hole; 

• Las Variable Statistics, listing for each selected geophysical variable in each selected hole, its: 

units, no of values, no of missing values, minimum, maximum, mean, standard deviation and 

various percentile values. 
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1.5 LogCheck facilities 

LogCheck includes facilities for: 

• data entry and editing, 

• data listings, 

• graphical editing, 

• data plotting, 

1.5.1 Data Entry & Editing 

LogCheck supports a number of widely used data sheet formats or can be tailored to match the client’s 

specific needs. Data can be imported from CoalLog Data Transfer, Geobank, Acquire, MineScape 

(GDB), Vulcan, Minex or Excel .csv files or entered directly. No matter which method is chosen to 

enter data, it is fully validated before it is accepted into the system. This includes checking that depths 

are in sequence, compulsory fields such as lithotype are entered, percentages of lithologies add up to 

100% and mnemonic codes are contained in the dictionary.  

The data editor includes facilities to: 

• display the data in grid (like a spreadsheet) or forms (single page per record) format, 

• hide certain fields when not required, 

• display the core photo covering the current record,  

• select codes from a menu of valid codes, 

• edit English comments using a word processing style editor, 

• automatically copy down values of user specified fields onto new lines, 

• insert, delete and undelete records, 

• copy a field from the last previous row where it has been entered 

• search and replace fields, 

• add or subtract a constant value to a set of depths, 

• expand or contract a set of depths to account for core loss/expansion, 

• calculate statistics for any selected column. 

 

For Geology data, it also includes facilities to: 

• split a lithological unit into two units, 

• copy to the current row, all the values from the row with the same LithoType as the current 

row. 

 

For audits, summaries and statistics it also includes facilities to: 

• filter the results 

• sort the results 
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An example of Geology data displayed in the LogCheck editor: 

 

 

1.5.2 Data Listings 

Site and Hole data can be listed in its original format or as reports with codes converted to full English 

descriptions. In either case, the listings can be produced as PDF, text or CSV files for importing to 

other software such as Excel or Word. They can be generated for part of a hole, a single hole, a set of 

holes or all holes in the project. 

An example of a coded data report that has been generated as a PDF file: 
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An example of a geology report that has been listed as a PDF file: 

 

 
 

 

Daily Activities can only be exported by printing either directly to a printer or a PDF file generator. 

Hole Summaries can only be exported by printing either directly to a printer or a PDF file generator. 

All other data summaries can be listed as either text or csv files. 
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1.5.3 Graphical Editing 

The Graphical Editor (GeoEdit) is used for graphically displaying hole data and aligning depths of 

lithologies with the downhole geophysics. GeoEdit reads data from a hole log generated from 

LogCheck, and displays the lithology, seam, ply, sample number, mechanical state and geophysics in a 

graphical format. The main editing operations are: 

• Moving the From depth of an interval(s) either further up or down the hole,  

• Inserting a new interval at the top, bottom or within existing units, 

• Expanding or contracting units, either by a single group or a set of tielines, 

• Renaming a lithology, seam, ply or sample number. 

 

It maintains a history of edits done during the current session and allows edits to be undone back to the 

start of the session. Also, the first time that the geology data for a given hole is modified and saved in 

GeoEdit, a raw copy of the data is saved in the folder RawGeology. An example of a hole displayed in 

GeoEdit is: 
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1.5.4 Data Plotting 

Plots are generated as industry standard DXF files which can be displayed, edited and/or plotted from 

most CAD packages, such as AutoCAD’s TrueView, which is available for free. TrueView can be 

used to view or output plots, however, it does not have the ability to edit them. LogCheck produces 

four types of plots:  

• drill hole location plans which can also show seam information such as coal thickness, parting 

thickness and strip ratios; 

• downhole plots of any combination of geological, geotechnical and/or geophysical data for 

part of a hole, a single hole or a set of holes along a section; 

• histograms that graph the frequency of occurrence of a variable; 

• box and whisker plots showing the ranges and average values of geophysical data within each 

hole. 

In the case of downhole plots, lithological data can be displayed as patterns using the supplied symbol 

set or you can design your own. Defects can be displayed as planar, stepped or curvy angled lines. 

Their dip and orientation can be also be displayed as tadpole plots. Coded data can be displayed as 

codes (optionally staggered horizontally based on their value), English descriptions or histograms (say, 

for rock strength). Numeric data can be displayed as traces (lines joining point to point), histograms or 

numbers. You can either use one of LogCheck’s standard sheet layouts for plotting downhole data or 

design your own. 

An example of a plot generated by LogCheck and displayed in TrueView is shown below: 
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1.6 Glossary of Computer Terms 

The following chapters assume that you are familiar with database terminology, including: 

• ASCII Text: ASCII is a code for representing English characters as numbers, with each 

letter assigned a number from 0 to 127. For example, the ASCII code for 

upper case A is 65. 

• Column: A column on the screen showing the value of a field over a number of 

records. 

• CSV File: A CSV (comma separated values) file consists of a text file where data 

values are separated by commas; it is used for transferring data between 

applications. 

• Database: A set of inter-related tables that is held in persistent storage. For example, 

the LogCheck database of drill hole data. 

• DBMS: A database management system is the software that maintains the data in a 

database. 

• Field:  A discrete value in a record, for example the lithology for an individual 

interval of a particular hole.  

• File: A container for storing data on a computer’s disk drive, for example, the 

geology data for a drill hole is held in a single file. 

• File Type:  The extension on the end of a file name that indicates to the computer’s 

operating system the kind of data stored in the file. For example, a file 

extension of .dbf indicates that it is a dBase database file. 

• Folder/ A file structure that stores other files, for example, C:\Logdata. 

Directory  The terms folder and directory are interchangeable. 

• Index:  An ancillary data structure to a table that sorts the record in the table, for 

example, each dictionary has an index file attached to it so that it can be 

displayed in order. 

• Primary key:  A field in a table that uniquely identifies each record, for example, the 

sample number on a set of proximate analysis results. 

• Query:  A subset of a table that satisfies a set of criteria. 

• Record:  Composed of a related group of fields. For example, all the proximate 

analysis results for a single sample. 

• Row:  A record as displayed on the screen. 

• Tab delimited A text file where data values are separated by tabs.  

file:  

• Table:  Stores information about an entity, such as a drill hole, in a structure that is 

composed of records containing fields. 

• Validation rules:  Specify the criteria that are acceptable before data is entered in a field. 

• Variable: A cell in computer memory that can store a single value. 
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1.7 Acronyms 

AMG Australian Mapping Grid 

ASCII American Standard Code for Information Interchange 

LAS Log ASCII Standard 

MGA Mapping Grid of Australia 

RMR Rock Mass Rating 

RMU Rock Mass Unit 

RQD Rock Quality Designator 

UCS Uniaxial Compressive Strength. 
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Chapter 2  
Getting Started with LogCheck 

 

By the end of this chapter you will be able to: 

 

▪ Install and start LogCheck. 

▪ Install Multiple Versions of LogCheck on a single computer. 

▪ Install optional components. 

▪ Set up the LogCheck data directory. 

▪ Install a dictionary. 

▪ Set up a new project. 

▪ Set the project details data. 

▪ Enter hole data. 
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2.1 Introduction 

This chapter explains how to install LogCheck software and commence using it. The steps involved 

are: 

• install the LogCheck software, and optionally the graphical editor (GeoEdit), which requires 

the Java runtime, 

• start LogCheck, 

• setup the LogCheck data directory, 

• setup a project, 

• setup a dictionary, 

• enter hole data. 

2.2 Installing and Starting LogCheck 

LogCheck installation file is around 26MB and is distributed over the internet using file distribution 

software such as HighTail. This sends the receiver an email that has a link to a web address from 

which the LogCheck install file can be downloaded. 

The installation file for LogCheck has a name in the form lcn.nnndataformat.exe where n.nnn is the 

release number and dataformat is the particular format used for recording geological data in that copy 

of LogCheck. For example, the installation file lc6.002CoalLog.exe will install release 6.002 of 

LogCheck and uses a CoalLog format for the data. 

To install LogCheck double click on the 

installation file and the window at right will 

appear:  

 

 

 

 

 

 

 

 

 

Windows will then appear prompting for: 

• where to store the program,  

• where to include it on the start menu and  

• if you would like an icon for it on the desktop.  

 

It is preferable but not necessary to choose the defaults when prompted for this 

information. Once installed, to start LogCheck, double click on the icon (as shown on 

right) on your desktop. 
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2.3 Installing Multiple Versions of LogCheck 

 on a Single Computer 

Users such as consultants with a number of clients with different data formats may need to have 

multiple versions of LogCheck installed on their computer. To install a second copy of LogCheck, first 

determine the directory where the current version is installed. If the default was chosen during the 

installation process this will be c:\Program Files (x86)\LogCheck for the 64-bit version of Windows, 

and C:\Program Files\LogCheck for the 32-bit version of Windows. 

Now when installing the second version of 

LogCheck and the window to the right 

appears:  

Enter a different directory name to the first, 

for example, if the first is called: 

 
  C:\Program Files (x86)\LogCheck 
 

the second could be called: 

 
  C:\Program Files (x86)\LogCheck CoalLog 
 

 

 

 

If this new directory name does not exist, the installation program will create it. Then progress through 

the installation windows by selecting the Next buttons.  

On installing the second version of LogCheck, the desktop icon for the first version will be overwritten 

by the icon for the second version. To recreate a desktop icon for the first, perform the following steps: 

1) go to the desktop and single click with the right-hand mouse button on the LogCheck icon, 

2) select Copy from the popup menu, 

3) point the cursor to the place on the desktop where you want to place the second icon and 

then single click with the right-hand mouse button, 

4) select Paste from the popup menu. 
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There will now be two LogCheck icons on the screen and both will start the second version of 

LogCheck. To set one to start the first version: 

1) Select which icon should be modified to start the 

first version of LogCheck and single click on it 

with the right-hand mouse button,  

2) Select Properties from the popup menu. An icon 

properties window like the one on the right will 

appear, 

3) Select the General tab from the properties 

window and change the icon name in the top box 

to whatever is appropriate, for example 

LogCheck Geodas: 

 

 

 

 

 

 

 

 

 

 

 

4) Select the Shortcut tab from the properties 

window and set the Target to the initial version 

of LogCheck including its full path name. If there 

are any blanks in the path or file name then the 

full path and file name need to be enclosed in 

double quotation marks:  
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5) The icon can be changed by selecting the “Change Icon…” 

button. After which the window to the right appears:  

 

 

 

 

 

 

 

 

A range of standard icons can be found by clicking the Browse 

button and then selecting Shell32.dll:  

Select an appropriate icon from the displayed list and then 

click OK. Further icons can be found in the files moricons.dll 

and pifmgr.dll in the C:\Windows\System32 folder. If the 

name of the file in which icons can be found is changed the 

new ones are not displayed until clicking on the box 

containing the actual icons; 

 

 

 

 

6) Once satisfied with the icon, its name and its target, click on the OK button on the LogCheck 

Properties window. 

 

After making the appropriate changes to the icon for the first version, any changes to the icon type and 

name for the second version can be made using the same steps as described above. 
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2.4 Installation of Optional Components 

2.4.1 Java Runtime Environment 

If your licence includes the Graphical Editor which is called GeoEdit, you will need to have the Java 

runtime environment installed – this is often already installed on most computers. 

To determine if Java is installed, open Windows Explorer and navigate to C:\Program Files. If there is 

a folder there named Java, then it has already been installed. If Java is not installed, a free download is 

available from: 

https://www.java.com/en/download/ 

2.4.2 TrueView DXF file Viewer 

LogCheck generates its plots in AutoCAD Release 12 DXF format. These can be viewed and plotted 

to hard-copy or PDF files with AutoCAD’s TrueView program. This can be downloaded for free from: 

 https://www.autodesk.com.au/viewers 

 

 

 

 

 

 

 

 

 

 

  

https://www.java.com/en/download/
https://www.autodesk.com.au/viewers
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2.5 Setting up the LogCheck Data Directory 

The first time that LogCheck starts after installation, the window to the right prompts for the name of 

the drive and directory where data is to be stored: 

To accept the default, click the OK button. 

However, if the data is to be stored in another 

location, either type in the path, or click the 

Browse button to navigate to the required folder.  

 

 

 

 

If the directory does not exist, it will be created:  

 

 

 

 

It can later be changed to another directory by selecting Settings > Options from LogCheck’s menu. It 

is possible to have more than one such data directory but LogCheck will only see data in whichever 

one is the current one. Even when running multiple versions of LogCheck for different clients it is not 

necessary to set up multiple data directories as all projects can be stored in the one data directory. 

LogCheck though only sees those projects that were created using the currently running version. 

Multiple data directories can be useful for setting up a folder for working data on one’s local hard 

drive and one for finalised data one’s server.  

 

 

 

 

 

 

 

 



CHAPTER 2. GETTING STARTED WITH LOGCHECK 

 32  LogCheck Manual 

2.6 Setting up a New Project 

Each project has a single directory that sits in the LogCheck Data Directory. All the data for a project 

sits in this project directory except for Las data which can optionally sit elsewhere.  

Each project directory contains a subdirectory for each type of data stored for the project. These are 

created automatically by LogCheck as required. For example, when the first hole of Water Flow data is 

entered into LogCheck for a project, LogCheck automatically creates a subdirectory called WaterFlows 

in which the data is stored.  

New project directories can only be created by LogCheck but once created can be renamed or deleted 

using Windows Explorer. To copy the data for a project to another computer running LogCheck, 

simply copy the project directory and all its subdirectories to the LogCheck Data Directory on the 

other computer. Be aware that within each project directory there is a file called project.mem. This file 

contains the details for the project. If it is renamed or deleted LogCheck no longer recognizes the 

directory as a LogCheck project directory. 

If no projects exist in the LogCheck data directory when LogCheck is 

started then the user is prompted for a name for the initial project:  

 

 

 

The name for a project directory is restricted to a maximum of eight characters and cannot contain 

blanks. Once the project has been created LogCheck displays its Project Details for editing. 

Further new projects can be created at any time by selecting File > New > Project from LogCheck’s 

menu. 
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2.7 Project Details Data 

Once a project is created the Project Details for the project becomes the current data set. An example 

of the Project Details for a project named AVOCALOG is:  

 

The following is a brief description of the project data (seen Chapter 4 of the LogCheck User Manual 

for more details): 

• Project Title: The title for printing on reports, plots etc.  

• LAS File Directory: Unlike all the other LogCheck data, LAS data can reside anywhere on 

the user’s computer or attached network. If this field is blank, LogCheck 

looks for the LAS data in the folder named LAS within the project. 

• Company Logo: The name of an image file for including in the top left corner of reports. 

• Geodetic Datum: Geodetic Datum for displaying coordinates for this project. 

• Survey Format: Specifies the survey coordinate format using the currently selected 

geodetic datum. 

• Depth Units: Specifies the unit of measurement that is used for editing hole data. 

Even though it may be displayed and edited in Imperial units, all data is 

stored, reported, plotted and exported in metres.  

• Project Limits: A rectangular set of limits against which survey coordinates are 

validated.  

• UCS: Parameters specific to the project for converting sonic values for this 

project to UCS (Uniaxial Compressive Strength). 
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2.8 LogCheck Dictionaries 

If a LogCheck data type includes coded data, that is all data types except Activities, Geologists, Rehab 

and UCS, then a dictionary of the codes is required before any data of that type can be entered into 

LogCheck. In addition, Geology data also needs a local seam dictionary. Each dictionary consists of 

two files with names of the form: 

• Data Type Dictionary.dbf   

• Data Type Dictionary.mdx.  

For example, the geology dictionary files will be called: 

• Geology Dictionary.dbf a dictionary of the categories, their codes and descriptions; 

• Geology Dictionary.mdx an index into the dictionary of code names. 

The following example shows the first few lines of the LithoType category of a Geology dictionary: 

 

LogCheck dictionaries contain the following columns (these are described in detail in Chapter 3 of the 

LogCheck User Manual): 

• Code  An abbreviation used by the geologist when entering data; 

• Desc  The full description that the code represents. This is what appears for the code in 

reports, and in plots where descriptions are being displayed; 

• Historical A flag used with CoalLog data, a Y indicates an item that may only be used in 

historical data not current data; 

• Group  Groups certain dictionary entries. It is used for various purposes by various parts 

of LogCheck. For most dictionary categories it is not required but in the case of 

the Seam category in a Seam Dictionary, the group is required and can only have 

the values of SEAM or STRAT where SEAM a coal seam and STRAT a 

stratigraphic marker; 

• Before  A Y indicates that when the entry appears in a full English description, a comma 

should be included before the word, otherwise it is not included; 

• After  A Y indicates that when the entry appears in a full English description, a comma 

should be included after the word, otherwise it is not included; 
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• Pattern The name of the primary pattern that will be used for plotting; 

• Pattern2 The name of the secondary pattern for plotting – if specified, it is combined with 

the primary pattern; 

• Colour An AutoCAD colour number – a number between 1 and 255 (see Appendix A of 

the LogCheck User Manual); 

• Fill The name of the fill that will be used for plotting; 

• FillColour  An AutoCAD colour number that will be used for drawing the fill; 

• BgColour  An AutoCAD colour number that will be used for drawing the background; 

• Comments  Provided so that the user can enter reminder notes that they may need when doing 

dictionary housekeeping. This field is not used by LogCheck. 

 

2.8.1 Where are Dictionaries Stored? 

The CoalLog version of LogCheck includes the Standard CoalLog Dictionary as part of the program 

and this will be used automatically by the program unless the user has set up their own dictionary. 

These dictionaries are stored in the folder C:\Program Files (x86)\LogCheck\Dictionaries. 

 When LogCheck is searching for a dictionary for a particular data type it first looks in the directory 

for that data type within the current project. If it does not exist there, it then searches the directory 

called Dictionaries sitting in the LogCheck data directory. If it does not exist there it then looks for a 

system dictionary in C:\Program Files (x86)\LogCheck\Dictionaries. 

For example, when looking for the geology dictionary for the project AVOCALOG it would look for: 

  C:\LogData\AVOCA\Geology\Geology Dictionary.dbf 
 

and if the file does not exist there, it would look for: 

  C:\LogData\Dictionaries\Geology Dictionary.dbf. 

and if the file does not exist there, it would look for: 

  C:\ Program Files (x86)\LogCheck\Dictionaries\Geology Dictionary 

This search procedure enables the user to have a single Geology (or any other data type) dictionary 

covering most projects but have a special dictionary for a particular project. 

2.8.2 Setting up a Dictionary 

If not using CoalLog and thus not having a default system CoalLog dictionary, the simplest way to get 

started is to copy a LogCheck dictionary from somewhere else – for example, another project, or 

obtain one from GeoCheck Pty Ltd. Other ways to create a dictionary are described in Chapter 3 of the 

LogCheck User Manual. 

 

2.8.3 Setting up a local Seams Dictionary 

Whether using CoalLog or not, a local Seams Dictionary needs to be setup before being Horizons, 

Seams and Stratigraphic markers can be entered into Geology data. If none has been provided by your 

system administrator, the easiest way to do this is to copy the file: 

C:\Program Files (x86)\LogCheck\Dictionaries\Example Seams Dictionary.csv 
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to the Imports folder in the project and then edit it in Excel. Note that for the SEAM category, units 

must be in entered in stratigraphic order. Next the edited dictionary CSV file needs to be imported into 

LogCheck, however, one has to be set to Manager to import or modify a dictionary. To set oneself to 

Manager, select Settings > Manager from the LogCheck menu: 

 

 

 

Next you will be prompted for the Manager password:  

Unless, the Database Administrator has changed this, it will be 

logcheck (not case-sensitive). 

 

 

Next, import the edited Seams Dictionary by selecting File > Import > Dictionary: 
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Next, the following window prompts for the Dictionary’s details: 

 

Select the options as shown above, except select your project name instead of AVOCALOG. 

Next select your edited CSV file: 
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Next select the which columns in the CSV file match which fields in the dictionary: 

 

 

 

After which it will read the dictionary into LogCheck and then 

display the message: 

 

 

 

 

Lastly, LogCheck displays the following indicating that currently all the Seam Dictionary and All its 

Categories is now open: 
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To see the Seams that have been entered, open just the Seam Category of the Seams Dictionary by 

selecting File > Open > Dictionary: 

 

 

Next select the following options: 
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And the current available Seams and Stratigraphic markers are displayed: 
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2.9 Creating New Data for a Hole 

Once a dictionary has been created for a particular data type, such data can be entered into LogCheck. 

The first step in this process is to create a new table of this data type for the hole by selecting File > 

New > Hole Data from the LogCheck menu: 

 

 

Then the window shown on the right will prompt for the 

Project, Data Type and the Hole Name for the new hole 

data.  

 

 

 

 

On clicking OK, LogCheck will create the new table in the directory named after the data type and 

sitting in the project directory. It uses the hole name as its filename with a .DBF extension. Hole 

names in LogCheck are always upper case and cannot contain blanks. Hole names are generally 

restricted to a maximum of eight characters but can be up to sixteen characters if specifically 

requested. 

In the above example, LogCheck creates two files named DDH001.dbf and DDH001.dbt in the folder 

Geology in the project AVOCALOG. The DBF file will contain the coded data for the hole and the 

DBT file the comments. If the data type directory Geology does not exist, LogCheck creates it. 

 

 

 

 

 

 



CHAPTER 2. GETTING STARTED WITH LOGCHECK 

 42  LogCheck Manual 

Following creation of the table, it will then be opened in the LogCheck editor, as shown below: 

 

In the above figure, the first depth of 2.00 m has been entered, and the cursor is currently in the Li 

(Lithotype) column. The Tab key moves the cursor to the next field, or the mouse can be used to select 

a column.  For those data values that have an associated dictionary, the dictionary entries are displayed 

on the right-hand side of the editor – in this example, Lithotype entries are displayed. Pressing the 

down-arrow key commences a new row. The LogCheck editor is described in more detail in Chapter 7 

of the LogCheck User Manual. 

Hole data can be deleted, renamed or moved to another project or computer by using Windows 

Explorer. The filenames for a particular hole is the same for all data types, therefore care must be 

taken when moving files to ensure that they are placed in the correct directory for that data type in the 

destination project. For example, the geology data for hole DDH001 will be stored in a file named 

DDH001.dbf, in the Geology folder – the full path is as follows: 

    C:\LogData\AVOCALOG\Geology\DDH001.dbf 

 

The header data for the same hole has the same name, DDH001.dbf and is stored in a file named 

DDH001.dbf, in the Headers folder – the full path is as follows: 

    C:\LogData\AVOCALOG\Headers\DDH001.dbf 

 

It is essential that when deleting, renaming or moving files and whatever action that is performed on a 

DBF is also performed on the corresponding DBT file else the comments for the hole will be 

permanently lost.  
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Chapter 3  
Management Tools 

 

By the end of this chapter you will be able to: 

 

▪ Switch from general user to Manager mode. 

▪ Set the Manager password. 

▪ Understand the three levels at which LogCheck validates data. 

▪ Setup optional validations for geologist, drilling, geology, defect and point 
load data. 

▪ Create a new dictionary from scratch. 

▪ Copy a dictionary into a project. 

▪ Import a dictionary into a project. 

▪ Open a LogCheck dictionary in the Editor form. 

▪ Understand the structure of a LogCheck dictionary. 

▪ Understand the use of the Group column of a LogCheck dictionary. 
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3.1  Introduction  

This chapter describes management tools such as setting validation levels and options, and 

maintaining the dictionaries for a project. To set validation levels and modify dictionaries, the user 

needs to first switch to Manager mode. 

3.2 Manager Option 

The Manager option of the Settings menu allows you to switch mode from General User mode to 

Manager mode.  When in Manager mode you have privileges that allow the importing or modification 

of the dictionary, importing patterns and fills, customising data validations and changing the Manager 

password. 

3.2.1 Switching to Manager Mode 

Each time LogCheck starts it is in User mode. To change to 

Manager mode, select Settings > Manager from the LogCheck 

menu. A prompt for the manager password will then appear:  

 

The default manager password is logcheck and is not case 

sensitive. 

 

3.2.2  Changing the Manager Password 

When in Manager mode the Settings menu displays an additional item, Change Password, that allows 

you to set a different Manager password. 

The Change Password dialog is displayed on the right:  

Enter the old password, enter the new password, then re-enter 

it to confirm that it is the same as in the previous field. 
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3.3 LogCheck Validation 

Validation is a process that verifies that the data and procedures of a system adhere to its rules. 

Prevention of errors is better than curing them. Validation plays a crucial role in ensuring the accuracy 

and integrity of all LogCheck data.  

Data entered into LogCheck is undergoes the same validation checks whether the data is imported 

from files or entered directly via the keyboard. There are three broad categories of validation in 

LogCheck: 

1. Validations performed when a cell is modified: 

• Check data satisfies its fundamental type, such as validating that a number has the 

correct format for a number and that a date has a day, month and year in the correct 

order. 

• Enforce a minimum or maximum number of characters or digits in a text field. For 

example, the number of characters in a hole name is up to 8 characters. 

• Check the range of numeric values, for example, that dips are between 0 and 90 

degrees. 

• Checking that coded data, such as LithoType, is valid by checking it against a 

dictionary. 

2. Validations performed when the user moves between rows. These include checks that 

mandatory fields are all specified and checks on fields where the field’s valid values depend 

on the values in one or more other fields on the same row. For example, in headers data that 

the hole completion date is not before the start date, or for drilling data that the core size is less 

than the hole size. 

3. Validations performed when the user attempts to save their data. These include checks which 

require comparing fields between rows. For example, checking that each successive base 

depth is not less than the previous base depth or where two or more lithotypes are specified for 

a unit, each has a percentage and these add up to 100%. 

Most validation checks in LogCheck are embedded in the software and cannot be turned off, however, 

there are a number of checks in categories 2 and 3 above which can be set by the manager. 
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3.4 User Specified Validation Settings 

LogCheck is distributed with a default set of user specified validations settings but if required, a 

specific set of validations can be setup for each client and included with all copies sent to them.  

User specified validation settings can be accessed from the menu by going to Settings > Validations. 

In order for this menu item to appear, you need to have changed to Manager mode, as it is not 

available for the General User. There are three levels of validation: 

• Ignore: No action is taken; 

• Warning: A warning message is posted – the user can ignore it; 

• Fatal: An error message is displayed and the current data item cannot be saved; 

 

User-specified validation settings are sub-divided into the categories: 

• CoalLog (only included in CoalLog versions of LogCheck) 

• Headers 

• Drilling 

• Geology 

• Defects 

• Point Loads 
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3.4.1 CoalLog Validation Settings 

The user specified validation settings for CoalLog data are: 

 

 

User specified CoalLog validations include checking for: 

• Historical codes in the data. CoalLog has a number of valid codes called Historical Codes that 

may be used in historical data but should be avoided in currently collected data. These codes 

are shown in grey in the CoalLog dictionary. For example, for Lith Qualifiers for Coal: 
 

 
 

In this example, going forward cannel coal should be described as sapropelic (SP) and inferior 

coal should be described as one of Weathered Coal (CW), heat affected (HA) or stony (SY).  

 

• Lithological Qualifier missing on coals, sandstones and conglomerates. It is preferable for all 

coals, sandstones and conglomerates to have a Lithological Qualifier but this may not be 

possible on historical data or logs of chips. 

 

• Interrelationship missing on multi-lithology unit. It is preferable that wherever a unit in the 

Geology data includes more than one LithoType, the relationship between the LithoTypes 

should be specified but this may not be possible on historical data or logs of chips. 
 

• Defect Length missing on a Defect. It is preferable that the length of core affected by a defect, 

that is defect length, be recorded for every defect but this may not be possible for historical 

data. 
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3.4.2 Header Validation Settings 

The user specified validation settings for Headers are: 

 
 

User specified header validations include checking that: 

• Header must exist before data can be entered for a hole: for example, header data must be 

entered for a hole before a Geology table can be created for the hole. 

• Data Total Depths must match Header Total Depth: For drilling, geologists, geology and 

RMU’s in the defect data, the last base depth must be equal to the total depth entered in the 

header. For point load data, the last base depth must be less than or equal to the total depth 

entered in the header. 
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3.4.3 Drilling Validation Settings 

The user specified validation settings for Drilling are: 

 

 

User specified drilling validations include checks for: 

• Core Recovery Greater than 100%. Generally, this will be set as a warning as setting it to Fatal 

would not allow for stick-up from the previous run. So that minor stick-up does not generate 

warnings, it is also possible to specify a Maximum allowable recovery over 100% in cms. 

• Core Run greater than maximum Core Run Length. The user also specifies the maximum core 

run length to be used for the check. This is a useful check to ensure that the user has entered 

each separate core run. 
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3.4.4 Geology Validation Settings 

The user specified validation settings for Geology are: 

 

 

User specified geology validations include checks for: 

• Horizon occurs more than once in hole: generally you would expect horizons such as Base of 

Weathering or Base of Tertiary to only occur once in a hole; 

• Seam occurs more than once in hole: a seam should only occur once in a hole, but it should 

generally be a warning rather than fatal, as seams may be repeated if there is reverse faulting 

in a hole; 

• Seam not in stratigraphic order: to perform this validation, LogCheck looks at the sequence of 

seams as they exist in the Seam dictionary. Again, this should generally be a warning rather than 

fatal, as seams may be out of order if there is reverse faulting in the hole; 

• Sample Number used for more than one sample in hole: a sample number should be only used 

for one contiguous set of units in a hole.  

Examples of this type of error are: 

a) It appears that 1001 has been used for more than one sample but is 

probably the result of mis-keying 1001 as 101. 

 

 

 

b) In this example, there are gaps in the sampling, but non-contiguous 

samples are given the same sample number. This situation may exist 

in historical data but is usually an error. 

 

• Sample Number out of order: normally this will not be an error, but at some sites 

where sample books are used, this could denote a mis-keying. 

1001 
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1001 

CO 

CO 

CO 

1001 

 

1001 

CO 

CO 

XM 
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• Sample Number on Core Loss: there are two approaches here: 

a) some companies specify that a core loss should indicate a 

boundary between samples and thus does not have a sample 

number, in which case this should be set to Fatal. 

 

 

b) whereas companies continue a sample number across a core loss 

in which case this test should be set to Ignore.  

 

 

  

 

CoalLog does not allow zero thickness units but for all other version of LogCheck zero thickness units 

are used for horizons. However, various modelling packages have different conventions for 

LithoTypes on zero thickness units. In particular, Minescape does not accept data with LithoTypes on 

zero thickness units whereas Vulcan does not accept data without LithoTypes on zero thickness units. 

Therefore, in non-CoalLog versions of LogCheck there is an additional validation setting that is 

whether for zero thickness units whether LithoType must be blank or non-blank. Data not meeting this 

set criteria is not accepted into LogCheck.   

3.4.5 Defects Validation Settings 

The user specified validation settings for Defects are: 

 

Rock Mass Unit boundary not on a Lithological Unit boundary. A rock mass unit (RMU) is not the 

same as a lithological unit. A RMU is a unit or set of units with a common set of geotechnical 

characteristics (strength, weathering, degree of fractures, plasticity, etc). The general convention is that 

1001 

 

1002 

CO 

CO 

KL 

1001 

1001 

1001 

CO 

CO 

KL 



CHAPTER 3. MANAGEMENT TOOLS 

 52  LogCheck Manual 

an RMU may contain multiple lithologies but a lithology may not contain multiple RMUs. In the rare 

case where a lithology unit does contain multiple RMUs then it should be broken up into separate 

lithology units. Therefore, all RMU boundaries should align to Lithology Unit Boundaries. 

This check can also be used to try and ascertain if when the geology data for a hole was adjusted to the 

geophysics whether the defects data was also adjusted. If it has not been there will generally be 

numerous mismatches between the boundary depths. These will be indicated if this check is set to 

Warning or Fatal and the defect data rechecked b y selecting Tools > Validate from the LogCheck 

menu. 

3.4.6 Point Load Validation Settings 

The user specified validation settings for Point Loads are: 

 

 

Point Loads are generally collected in order to calculate a Point Load Index for each sample. However, 

there only measurements where the Platen Separation to Width ratio lies within a specified range. This 

validation checks that the Point Load data be entered will be able to be used for calculating a Point 

Load Index. 
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3.5 LogCheck Dictionaries 

A dictionary consists of a set of user-defined codes and their descriptions that are used to validate 

entry of drill hole data into LogCheck. This chapter describes three ways to create a dictionary, the 

data format used in a dictionary and the dictionary file structure. Editing a dictionary is briefly 

described here and in more detail in Chapter 7. 

A dictionary is required for each hole data type that contains coded data, that is all data types except 

Activities, Geologists, Rehab and UCS which do not have any coded fields. 

CoalLog versions of LogCheck already have the standard CoalLog dictionaries embedded in the 

program. Other versions will require the user to create or obtain dictionaries before they can enter data 

into LogCheck. 

However, whether using a CoalLog version or not, it is necessary to set up a Seams Dictionary with 

codes for local Horizons, Seams, Stratigraphic markers and Plies before these can be entered into 

Geology data. Instructions for setting this up can be found in Chapter 2 in the section 2.8.2 Setting up 

a local Seams Dictionary. 
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3.6 Dictionary Structure 

Each dictionary consists of two files with names of the form: 

• Data Type Dictionary.dbf   

• Data Type Dictionary.mdx.  

For example, the geology dictionary files will be called: 

• Geology Dictionary.dbf a dictionary of the categories, their codes and descriptions; 

• Geology Dictionary.mdx an index into the dictionary of code names. 

The following example shows the first few lines of the LithoType category of a Geology dictionary: 

 

 

LogCheck dictionaries contain the following columns: 

• Code: Used by the geologist when entering data; 

• Desc: The full description that the code represents. This is what will appear for the code 

in reports, and in plots where descriptions are being displayed; 

• Historical A flag used with CoalLog data, a Y indicates an item that may only be used in 

historical data not current data; 

• Group: Is used to group certain dictionary entries. It is used in various parts of LogCheck, 

and is discussed in more detail in the following section; 

• Before: A Y in this field indicates that when the entry appears in a full English 

description a comma should be included before the word. For example, as shown  

in the Lithological Adjectives dictionary on the next page, there is an N instead of 

a Y in the Before column of entries for blebs and bands as, in general, the words 

blebs and bands will probably be proceeded by another adjective such as sandy; 
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• After: A Y in this field indicates that when the entry appears in a full English 

description a comma should be included after the word. For example, in the 

Lithological Adjectives dictionary above there is an N instead of a Y in the After 

column of abundant and as, because generally the words abundant and as will 

probably be followed by other qualifiers such as fractures. 

 

When there are two qualifiers together, if the value for After for the first is 

different to the Before value of the second, then the N takes precedence. 

• Pattern: The primary pattern that will be used for plotting (see Appendix B for a full list 

of standard patterns).  

• Pattern2: The secondary pattern for plotting – if specified, it is combined with the primary 

pattern (see Appendix B for a full list); 

• Colour: This can contain a number between 1 and 255 which represents an AutoCAD colour 

number (see Appendix A for a full list of AutoCAD colours). For example, in the 

LithoType dictionary shown on the previous page Acid/Felsic Intrusive has its 

Colour set to 241 (dull purple) and can be plotted in this colour when it appears in a 

LogCheck downhole plot;  

• Fill: The type of fill that will be used for plotting (see Appendix C for a full list of 

standard fills); 

• FillColour:  An AutoCAD colour number for colouring the fill (see Appendix A); 

• BgColour:  An AutoCAD colour number for colouring the background (see Appendix A); 

• Comments: This is not used by LogCheck. It is provided so that the user can enter reminder 

notes that they may need when doing dictionary housekeeping. 
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3.7 The Dictionary Group Column 

The Group column is used by LogCheck’s audits, summaries and statistical tools. For most dictionary 

categories it is not required, however it is required in the following circumstances: 

3.7.1 Geology Dictionary - LithoType Category Groups 

The Group column of the LithoType dictionary category in the Geology dictionary needs COAL against 

any LithoTypes that are to be considered as coal in summaries: 

 

and CORE LOSS against any core losses: 

 

 

These groupings enable LogCheck to calculate in its summaries amount of coal in a sample or seam and 

the percentage recovery within a sample or seam.  
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3.7.2 Seams Dictionary - Seam Category Groups 

Group is required for all items in the Seam Category of the Seams Dictionary so that seam summaries 

and audits can distinguish Seams from Stratigraphic markers. The Group column must have a value of 

SEAM or STRAT.   

 

 

In LogCheck versions other than the CoalLog and Anglo Coal versions, horizons are also stored in the 

Seam column and these need to have their Group set to HORIZ: 
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3.7.3 Drilling Dictionary – Bit Type Category Groups 

The Bit Type category of the Drilling Dictionary needs CORED against any Bit Types that produce 

core rather than chips. This enables LogCheck to know which parts of a hole have been cored and 

which have not for calculating Percentage Recovery for seam and sample summaries. An example of 

Groups in the Bit Type Category: 
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3.8 Creating a Dictionary 

In LogCheck, a dictionary is a list of codes and their descriptions. The location of dictionaries is 

described in Chapter 11. 

A dictionary can be generated in three ways: 

• Creating from scratch 

• Copying dictionary files from another project 

• Importing a dictionary from a CSV file 

 

You need to be in Manager mode to create or edit dictionaries – see Section 3.2.1 of this chapter for 

how to set to Manager mode. 

LogCheck also automatically creates a dictionary for LAS files in the folder LasWork. This dictionary 

contains a list of all the variable names and units used in the project’s LAS files. This dictionary can 

be viewed but not modified. 

3.8.1 Creating a Dictionary from Scratch 

Dictionaries are rarely created from scratch 

but to create one from scratch select File > 

New > Dictionary from the LogCheck menu. 

The prompt to the right will then appear. 

Note that the Dictionary menu item only 

appears on the File > New menu if the user is 

in Manager mode.  

 

 

 

In this window, you choose between a User Default dictionary, or one that is specific to a project. User 

Default dictionaries are available for many projects whereas dictionary specific to project should be 

used for codes that will only be used in one project, for example a Seam Dictionary.  

On selecting the Project and Data Type, and then clicking OK, the new current data set in LogCheck 

will be the entire dictionary for the selected data type, that is all categories. However, being a new 

dictionary, there will be nothing in any of the categories. To enter dictionary data, open each category 

in turn by selecting File > Open > Dictionary… from the LogCheck menu.  

Be aware, it has been known for users to have a default dictionary and then to accidentally create a 

new project dictionary with nothing in it. They are then mystified as to why their dictionary, that is the 

default dictionary, has “disappeared”. 

3.8.2 Copying Dictionary Files 

A dictionary file can be created by copying the dictionary files Data Type Dictionary.dbf and Data 

Type Dictionary.mdx from another computer or project. Copying dictionaries is the most common way 

to obtain dictionaries.  

Project-specific dictionary files must be copied to their corresponding data folder for the project. For 

example, a Geology dictionary must be copied to the Geology folder. The file locations for 

Choose between a 

default dictionary, or one 

specific to a project 
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dictionaries are described in detail in Chapter 11. An example Geology dictionary specific to the 

AVOCALOG project would consist of the following two files: 

 C:\LogData\AVOCALOG\Geology\Geology Dictionary.dbf 

 C:\LogData\AVOCALOG\Geology\Geology Dictionary.mdx 
 

Default dictionaries should be copied to the Dictionaries folder in the LogCheck data folder, usually 

C:\LogData\Dictionaries. 

3.8.3 Importing a Dictionary from a text File 

The most common way of creating dictionaries is from CSV files. There are a number of other text 

formats than can be used to create dictionaries, such as from a TXT file or a Minescape/GDB 

dictionary. For further information regarding using these other text formats contact the LogCheck 

distributors. 

A dictionary in CSV format that is to be imported must contain the columns Category, Code and 

Description. The category column contains a set six-character name for each category in the 

dictionary. A list of these category names for each data type for each data format can be obtained from 

the LogCheck distributors.  

The Seams Dictionary is the most common dictionary that users need to import. The steps for 

importing a Seams Dictionary CSV file can be found in Section 2.8.3: Setting up a local Seams 

Dictionary in Chapter 2 of this manual. The steps for importing dictionaries for other data types are 

similar.  
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3.9 Viewing or Modifying a Dictionary 

To open a dictionary to view or modify, select File > Open > Dictionary from the LogCheck menu. 

The following window will then be displayed: 

 

To edit rather than just view the dictionary, you need to be in Manager mode, see Section 3.2.1 Setting 

to Manager Mode. If in General User mode the dictionary is displayed in ReadOnly mode which is 

indicated by all the entries being shown in grey rather than black. 

The first panel in the above window offers the following options: 

• Standard CoalLog Dictionary: the standard dictionary that comes with LogCheck. Once open 

this dictionary can be modified but cannot be saved back over the Standard Dictionary, instead 

use Save As to save it as a User’s Default Dictionary or a Dictionary specific to a Project. 

 

• User’s Default Dictionary: the default dictionary to be used by any of a User’s projects that do 

not have a Dictionary specific to Project for the selected Data Type. 

 

• Dictionary specific to Project: dictionary for use just by a specific project. 

 

The Data Type whose dictionary is required is selected from the Data Type drop-down box. This box 

will only contain Data Types for dictionaries that currently exist on the user’s computer at the level 

selected in the previous panel. For example, if User’s Default Dictionary has been selected and no 

Geology Dictionary exists amongst the User’s Default Dictionaries then Geology will not appear as an 

option even though there is a Geology dictionary amongst the Standard CoalLog Dictionaries and also 

in some projects.    

In the final panel, usually Specific category will be chosen. However, All categories should be selected 

when one wants to export or print a copy of the entire dictionary.  

After selecting All Categories, then names of all the categories in the dictionary will be displayed on 

the screen: 
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If Specific Category is selected then one must then select the category and the order to display the 

dictionary entries. There are three choices for order: 

1) Unsorted: the items will be displayed in the order that they were entered into the dictionary. 

For some categories this may well just be a random order but for the Seams category in the 

Seams Dictionary it will be stratigraphic order and for the Weathering category in the Geology 

Dictionary it is in the order of decreasing weathering. 

 

2) Sorted on Code: the items will be displayed in alphabetic order of their codes.  

 

3) Sorted on Description: the items will be displayed in alphabetic order of the descriptions. 

The following example shows the Weathering Category in the Geology Dictionary: 

 Unsorted       Sorted on Code   

 

 

 

 

 

 

If the category is opened in sorted mode then one can enter additional entries at the bottom of the list and 

then when one moves to the next row they will be moved to their correct position in the list. 
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3.10 CoalLog Geology Dictionary – Lithological 

Qualifiers 

In the CoalLog version of LogCheck, there are Lithotype and Lithology Qualifier categories. Lithotype 

is a broader term, for example, coal. Its detailed characteristics are specified by Lithology Qualifier 

codes. According to CoalLog, each Lithology Qualifiers can only be used for particular Lithotypes, for 

example, brightnesses can only be used for coals and clast sizes to conglomerates and alluvium. To 

cater for this, the Geology Dictionary for the CoalLog version of LogCheck has an additional category 

called Lithotype + Qualifier Combination which specifies all the valid combinations: 

 
 

The patterns and fills for the combinations are also defined in this dictionary category: 
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Chapter 4  
Project Details 

 

By the end of this chapter you will be able to: 

 

▪ Enter the project details data. 

▪ Specify the LAS file directory for a project. 

▪ Specify the datum and format of survey coordinates for a project. 

▪ Specify the project limits. 

▪ Specify the depth units for a project. 

▪ Specify the UCS calculation parameters for a project. 
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4.1 Introduction 

Once a project is created the Project Details for the project becomes the current data set. The project 

data consists of the following entities: 

• Project Title 

• Optional LAS (geophysical logs) File Directory 

• Optional Company Logo 

• Current Geodetic Datum 

• Survey Coordinates Format 

• Depth Units for editing Data 

• Project Limits 

• UCS (Uniaxial Compressive Strength) formula for the project. 

 

An example of the Project Details for an example project named Avoca:  

 

4.2 Project Title 

The title for printing on reports, plots etc. The Project Title can contain blanks and can be of any 

length. The Project Title is provided because the Project Name as used by LogCheck can only be a 
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maximum of eight characters and cannot contain any blanks. This field enables the user to provide a 

more meaningful title than that provided by the Project Name. 

4.3 LAS File Directory 

LogCheck requires all downhole geophysical logs to be in LAS V1.2 or LAS V2.0 format. The LAS 

format was developed by the Canadian Well Logging Society. More information regarding the LAS 

format can be found on its website at https://www.cwls.org/products/#products-las. 

LogCheck enforces a strict discipline on the location and naming of all its data files except LAS files 

which may reside anywhere on the user’s computer or network. As LAS data tends to occupy large 

amounts of disk space and may be accessed by a number of applications, the user is able to specify a 

separate location for it so as to reduce the need for multiple copies of the data, copying the data and/or 

holding it permanently on their hard drive.  

When LogCheck is looking for LAS data it searches the directory specified in the Project Details and 

all lower directories off this directory. This field can be left blank, in which case LogCheck will search 

the LAS directory under the project folder and again all lower directories off this directory. The only 

restriction is that the chain of lower directories and the filename must not contain more than 100 

characters. Be aware though, that the directories should not contain more than one set of readings for 

any particular geophysical variable at a particular reading interval, over the same depth interval for 

each hole. 

4.4 Project Company Logo 

LogCheck includes a company logo in the top left-hand corner of all printed reports including those 

printed to a PDF file generator. The logo used is whatever image file is specified in this field. 

Specified image files can be a BMP, ICO, GIF, JPG, PNG, TIF or WMF file. If no image file is 

specified then the GeoCheck logo will appear in top left-hand corner of all printed reports. 

4.5 Geodetic Datum 

All coordinates are stored in LogCheck both in their original geodetic datum along with the name of 

that datum plus in the current geodetic datum as set in the Geodetic Datum panel of the Project 

Details. Whenever, the current geodetic datum is changed, LogCheck recalculates the current 

coordinates for the current geodetic datum from the original coordinates for all the holes in the project.   

Whenever importing coordinates into LogCheck their geodetic must be included. The coordinates, 

though, are displayed, edited and reported in whatever geodetic datum is the current one for the 

project. When coordinates are actually keyed into LogCheck rather than imported, their values are 

saved as both the coordinates for the original geodetic datum and the coordinates for the current 

geodetic datum, and the current geodetic datum is stored as the name of the original geodetic datum. 

The currently available Geodetic Datums in LogCheck are: 

• Australian Geodetic Datum (AGD84) as used for Australian Mapping Grid (AMG84) 

coordinates 

https://www.cwls.org/products/#products-las
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• Geocentric Datum of Australia (GDA94) as used for Mapping Grid of Australia (MGA94) 

coordinates 

• Geocentric Datum of Australia 2020 (GDA2020) as used for Mapping Grid of Australia 2020 

(MGA202) coordinates 

• World Geodetic System (WGS84) as used in Indonesia 

 

LogCheck uses the GCalc software from the Queensland Department of Natural Resources and Mines, 

to convert between datums. 

4.6 Format for Survey Coordinates  

The format for the display of survey coordinates in LogCheck is specified with one of the following 

options: 

• Grid, such as MGA, 

• Longitude/Latitude as decimal degrees, 

• Longitude/Latitude as degrees/minutes/seconds. 

 

Historically, most coal exploration data in Australia has been recorded in AMG’s and most petroleum 

exploration data in Longitude/Latitude with decimal degrees.  

The Survey Coordinates Format option sets what system is used when the coordinates are entered, 

displayed, printed and exported. For example, often in coal bed methane work some of the historical 

data will come from coal exploration and some from petroleum exploration. When entering old 

petroleum data in Longitude/Latitude with decimal degrees change the option to Longitude/Latitude 

(decimal degrees). All the current data in the system for the project will then be displayed in 

Longitude/Latitude though it will still be stored in grid.  

The latitude and longitude of a survey point will change depending on which geodetic datum was used 

for calculating it. Therefore, when entering latitudes and longitudes, it is essential to determine which 

geodetic datum was used and that the appropriate one has been selected in the Project Details. 

4.7 Depth Units 

Depth Units specifies the unit of measurement that is used for editing hole data. Often historical data 

will be in feet and inches or decimal feet. By selecting the appropriate Depth Units option the format 

used for entering and viewing the data can be modified. Upon entering, the data is stored in metres and 

all reporting, plotting and exporting of the data is in metres. This option can be changed at any time so 

that the Hole Data stored on the machine can be edited/displayed in the required format. 

4.8 Project Limits 

Project Limits are a rectangular set of coordinate limits, and a minimum and maximum elevation for 

all hole collars. The horizontal limits are set by specifying a minimum and maximum 

Easting/Northing coordinate pair.  Survey coordinates are validated against the project limits 

whenever they entered at the keyboard or imported from file.  The coordinates limits are displayed in 

the Project Details in whatever is the current geodetic datum. 
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Where the user’s Header format does not contain a field for recording the Zone then the maximum 

Zone is automatically set to the same as the minimum zone. This zone will be applied to all 

coordinates when transforming the coordinates to Longitude/Latitude. 

4.9 UCS Calculation Parameters 

UCS (Uniaxial Compressive Strength) can be estimated from Sonic Transit Time or Velocity data. It is 

common practice within the Australian coal industry to determine a relationship between the UCS and 

sonic data for each project based on lab results of UCS and Sonic values for a number of samples from 

preliminary holes. Once a relationship has been established it can be used to generate UCS values for 

hole intervals where no laboratory UCS tests have been performed but downhole sonic values have 

been recorded. More information about this procedure can be found in “Geotechnical applications and 

interpretations of downhole geophysical logs” by G.H. McNally published by Australian Coal Industry 

Research Laboratories, Sydney. 

When opening LAS files containing sonic data, LogCheck will optionally calculate the UCS from a 

selected sonic transit time using the formula parameters set in the Project Details. The calculated UCS 

is then displayed as an additional variable within the LAS data. 
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Chapter 5  
Data Formats 

 

By the end of this chapter you will be able to understand: 

 

▪ The types of LogCheck data formats. 

▪ The format of drill hole site planning data. 

▪ The format of drill hole header data. 

▪ The format of geologists who logged each drill hole data.   

▪ The format of drilling data. 

▪ The format of casing and cementing data. 

▪ The format of geology data. 

▪ The format of water flow data. 

▪ The format of LAS data. 

▪ The format of sample dispatch and coal quality data. 

▪ The format of daily activities data. 

▪ The format of rehabilitation data. 
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5.1 Introduction  

This chapter describes the data format for each of the data types that are available in the standard version 

of LogCheck.  

• Drill Hole Site Planning 

• Headers 

• Geologists 

• Drilling 

• Casing 

• Cementing 

• Geology 

• Water Flows 

• Downhole Geophysics (LAS) 

• Sample Dispatch 

• Basic Coal Quality 

• Daily Activities 

• Rehabilitation 

Further data types are available in the LogCheck Geotechnical and Coal Quality extensions (see 

Chapters 11 and 12) 

 

The LogCheck data types generally follow the Australian CoalLog standard. More information about 

this standard can be found at: 

 

https://www.ausimm.com/insights-and-resources/resources/codes-and-standards/coallog/ 

 

The exceptions to this are: 
 

• Drill hole site planning, rehabilitation and daily activities as these are not covered by CoalLog 

and so LogCheck uses its own standard formats for these; 

 

• Downhole geophysics which uses the Canadian Well Logging Society Log ASCII (LAS) 

standard, further information regarding this standard can be found at: 

https://www.cwls.org/products/#products-las 

 

• Basic Coal Quality as the CoalLog standard includes the entire suite of possible Coal Quality 

sample preparations and tests whereas the LogCheck Basic Coal Quality only includes raw 

samples and those tests generally performed during exploration programs; 

 

• Headers, Geology, Drilling and/or Water Flow data has user specific formats for some users. 

 

5.2 Drill Hole Site Planning Data 

Drill hole site planning data enables the storage, editing and display of the information compiled for 

each drillhole site when planning a drilling program. Generally, drill hole site names will be different 

to that of the final name of the drill hole or drill holes that are drilled on the site. 

The Drill Hole Site Planning Data variables are: 

• SiteId Site Identification code 

• Lease  The mining or exploration lease number on which the site is located 

• HT Hole type – fully cored (FC), open (OC), etc. 

• HP1 - HP4 Hole purposes 

• GDatum Geodetic Datum 

• UTMZone Map zone 

• Easting Intended Easting coordinate of the hole collar 

• Northing Intended Northing coordinate of the hole collar 

• HDatum Height datum - Australian Height Datum (AHD), Local Datum (LOD), etc. 

• Elevation Intended Elevation of the hole collar 

https://www.ausimm.com/insights-and-resources/resources/codes-and-standards/coallog/
https://www.cwls.org/products/#products-las
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• Ic Intended Inclination of the hole at its collar. Negative indicates down and 

positive up 

• Azi Intended Azimuth of the hole at its collar 

• Property Name of property on which site is located 

• Landholder Name of landholder of property on which site is located 

• EA Environmental Authority for site – Buffer (BUFF), Endangered Regional 

Ecosystem (ERE), etc.  

• CCA_Date Conduct & Compensation Agreement Date 

• CH_Date Cultural Heritage Date 

• Access Flag indicating that site is currently accessible 

• Prep_Date Date preparation for drilling was completed for the site 

• Rehab_Date Date rehabilitation of site was completed 

The hole coordinates and elevation are integers as planned coordinates as this is the limit of precision 

for planned coordinates. 

The LogCheck system includes a Sites Dictionary which includes the CoalLog dictionary entries for: 

• Hole Type 

• Hole Purposes 

• Geodetic Datum 

• Height Datum 

• Location Accuracy 

 
 

However, before entering Site data the system Sites Dictionary needs to be edited to create appropriate 

entries for the following categories. After editing any LogCheck system dictionary, it needs to be saved 

either as a User Default Dictionary or a project specific Dictionary, using Save As rather than Save, as 

system dictionaries cannot be overwritten. 

• Lease Number 

• Property Name 

• Landholder’s Name 

• Environmental Authority 
 

An example of drill hole site planning data: 
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5.3 Header Data 

Header data consists of data for which there is only a single value for the entire hole.  

The Header Data variables in the standard version of LogCheck are: 

• Basin Sedimentary basin for the project 

• Lease  The mining or exploration lease number on which the hole is located 

• SiteId  The site identification code 

• HT Hole type – fully cored (FC), open (OC), etc. 

• DS  Data Status – raw (R), final (F), etc. 

• HP1 - HP4 Hole purposes 

• Redrill Name of previous drill hole of which this hole is a redrill 

• Acc Survey accuracy – GPS (G), surveyed (S), etc. 

• UTMZone Map zone 

• Easting Easting coordinate of the hole collar 

• Northing Northing coordinate of the hole collar 

• HDatum Height datum - Australian Height Datum (AHD), Local Datum (LOC), etc. 

• Elevation Elevation of the hole collar 

• Ic Inclination of the hole at its collar. Negative indicates down and positive up 

• Azi Azimuth of the hole at its collar 

• SurvCo Survey company 

• SurvDate Survey date 

• Start Date drilling was started 

• Complete Date drilling was completed 

• TotDep Total depth of the hole 

• GeoOrg Geological logging organisation 

• GT Flag indicating if the hole has a geotechnical log  

• Ph Flag indicating if core photos have been taken for the hole 

• GphCo Geophysical logging company 

• L1 – L12 Codes indicating which geophysical logs were recorded on the hole 

• GphLog Geophysical logger’s name 

• SWL Standing water level 

• SWLDate Standing water level measurement date 

• RehabDate Date hole rehabilitated 

• HS1 – HS2 Current status of the hole – completed (C), backfilled (B), plugged (G), etc. 

 

LogCheck includes a Headers Dictionary which includes the CoalLog dictionary entries for: 

• Sedimentary Basin 

• Hole Type 

• Data Status 

• Hole Purposes 

• Geodetic Datum 

• Height Datum 

• Location Accuracy 

 

• Survey Accuracy 

• Survey Organization 

• Geological Logging Organization 

• Geophysical Logging Organization 

• Geophysical Variables 

• Hole Status 

 

This dictionary contains hundreds of entries for Sedimentary Basin, Geological Logging Organization 

and Geophysical Logging Organization that are probably not required and so before entering Header 

data, it is probably prudent to edit it to remove the unnecessary entries. Also, before any Lease numbers 

can be entered into LogCheck, appropriate entries need to be added to the dictionary. After editing any 

LogCheck system dictionary, it needs to be saved either as a User Default Dictionary or a project specific 

Dictionary, using Save As rather than Save, as system dictionaries cannot be overwritten. 

An example of hole header data: 
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When opening header data, if more than one hole is selected, the data is displayed in Grid layout as 

shown below: 

 

You can switch to Form layout from the View menu. With more than one hole selected, the First, 

Previous, Next and Last buttons are available to navigate between the holes. 

When editing the Header data for a new hole and its SiteId is entered, LogCheck automatically 

updates the values for: 

• Lease 

• Hole Type 

• Hole Purposes 

• UTM Zone & Coordinates 

• Height Datum 

• Collar Elevation 

• Hole Inclination at Collar 

• Hole Azimuth at Collar 

where they are currently blank, with the corresponding values saved in the Site data for the SiteId.  

The First, Previous, Next 

and Last buttons are 

disabled, because only 

one hole was selected. 
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5.4 Geologists Data 

The Geologist data records the names of 

the geologist(s) who logged the hole, and 

what depth ranges they logged. The fields 

are Base Depth and Logging Geologist. An 

example of the Geologist data for a hole in 

grid format is shown at right: 

 

Whenever Geology data is opened in the editor, then LogCheck adds, as a read-only field, the 

geologist’s initials derived from the Geologist’s data against each interval that they logged: 
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5.5 Drilling Data 

The Drilling Data variables are: 

• CalcThick Thickness of the interval, that is the difference as calculated by LogCheck, 

between the base depths of this interval and the previous one  (read-only) 

• Depth Driller’s depth to the base of the interval. The top of an interval is assumed to 

be the base depth of the previous interval. 

• CalcDepth Base depth as calculated by LogCheck using the formula: 

CalcDepth = KellyLen + RodsLen + BarLen + BtSubLen + OthLen 

– TblHgt – StUpLen   (read-only) 

• KellyLen Kelly Length 

• RodsLen Total Length of rods 

• BarLen Barrel Length 

• BtSubLen Length of Bits and Subs 

• OthLen Other Lengths 

• TblHgt Table Height 

• StUpLen Stickup Length  

• DrC Drilling Contractor 

• RigNo Rig Number 

• RT Rig Type 

• Driller Name of the driller 

• Date Date the interval was drilled 

• TStrt Time when interval was started in hhmm format, for example 1:15pm would 

be 1315 

• TComp Time when interval was completed in hhmm format, for example 4:45pm 

would be 1645 

• BT Bit type – hammer (HA), diamond core (DW), etc. 

• DF Drilling fluid – bentonitic mud (M), water (W), etc 

• DrSz Drill size name - HQ, NQ, etc 

• CoSz Core size in mm’s 

• HSz Hole size in mm’s 

• Reamed Flag indicating if interval has been reamed 

• RunNo Run number. A row should be entered into the data for each individual core 

run in the hole 

• RecThk Recovered thickness. The overall length of the material recovered in the core 

run 

• GeoDepth Base depth of interval as determined by the geologist 

• Ph Flag indicating if core run has been photographed 

• RecPerc Percentage recovery of core run as calculated by LogCheck    (read-only) 

• ThkDiff Difference between the recovered thickness and the true thickness of the 

interval as calculated in CalcThick     (read-only) 

• CumThkDiff Cumulative thickness difference over a sequence of consecutive core runs as 

calculated by LogCheck. The core loss in one run may be made up by stick-up 

from the next run. For example, in the drilling data shown below, core run 1 

had a loss of 0.27 m but core run 2 had a gain of 0.05 m due to stick-up from 

the previous run, thus generating a cumulative thickness difference of 0.22 m 

by the end of run 2.      (read-only) 

 

The only mandatory fields in Drilling Data are Base Depth, Bit Type and for cored intervals, the Core 

Size.  

LogCheck includes a Drilling Dictionary which includes the CoalLog dictionary entries for: 
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• Drilling Contractor 

• Drilling Rig Type 

• Bit Type 

• Drilling Fluid 

• Drilling Bit Size 

 

This dictionary contains hundreds of entries for Drilling Company and Rig Type that are probably not 

required and so before entering Drilling data, it is probably prudent to edit the system Drilling Dictionary 

to remove the unnecessary entries. After editing any LogCheck system dictionary, it needs to be saved 

either as a User Default Dictionary or a project specific Dictionary, using Save As rather than Save, as 

system dictionaries cannot be overwritten. 

 

For cored intervals, additional validations can be set by the database manager to check that: 

• CalcThick is less than a specified maximum core run length 

• Core recovery in not greater than 100% plus a specified additional amount for stick-up 

 

For information on setting these validations, see Section 3.4.3 Drilling Tab in Chapter 3. 

 

An example of drilling data: 

 

The fields shown in grey above are read-only fields whose values are calculated by LogCheck.  

Whenever Geology data is opened in the editor, then LogCheck adds, as a read-only field, the bit type 

(BT) codes from the Drilling data against each interval: 
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5.6 Casing Data 

Casing data can be recorded for each hole. The Casing data variables are: 

• CalcThick Thickness of the interval, that is the difference as calculated by LogCheck, 

between the base depths of this interval and the previous one  (read-only) 

• Depth Depth of end of particular casing 

• CM Casing Material – pvc (PV), steel (ST), etc 

• CT Casing Type – perforated (P), slotted (S), etc 

• CN Casing Name - HWT thread (HWT), Ozcon (OZCO), etc 

• OD Outside Diameter in millimetres 

• ID Inside Diameter in millimetres 

• CG Casing Grout – bentonite (BE), gypsum (GY), etc 

• Retrieved Casing Retrieved in metres 

An example of casing data: 

 

 

5.7 Cementing Data 

Cementing data can be recorded for each hole. The Casing data variables are: 

• CalcThick Thickness of the interval, that is the difference as calculated by LogCheck 

between the From and To depths      (read-only) 

• From Depth at top of cementing 

• To Depth at bottom of cementing 

• Date Date interval cemented 

• Volume Volume of Cement in cubic metres 

An example of cementing data: 

 

Unlike all other data types, Cementing starts at the bottom of the hole and so unlike all other data 

types, the From and To Depths descend going down the table. 
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5.8 Geology Data 

The Geology data variables in the CoalLog version of LogCheck are: 

• CalcThick Thickness of the interval, that is the difference as calculated by LogCheck, 

between the base depths of this interval and the previous one  (read-only) 

• Depth Base depth of each lithological unit. The interval top is assumed to be the base 

depth of the previous unit. Interval base depth must be greater than the base 

depth of the previous unit. Blank Depth values are used in LogCheck to indicate 

that the row in the table is a continuation of the data for the lithological unit on 

the previous row. 

• Seam Seam name. Despite its name, this field can contain both Seam names and the 

names of Stratigraphic Markers such as Yarrabee Tuff. This should appear on at 

least the first record of every lithological unit which is to be includes in a Seam 

or Stratigraphic Marker unit. 

• Ply Ply name 

• Horiz Horizon name – Base of Weathering (BHWE), Base of Tertiary (BHTE), etc. 

• SP Sample purpose – coal quality(QP), geotechnical (GT), water quality (WT), etc. 

• FieldNumb Sample Number as allocated originally in the field. The first time that a Sample 

Number is allocated in the SampNumb field for a row, LogCheck automatically 

copies the new SampNumb to this field as a permanent record of the original 

sample number. This is useful where the Samples are later combined before 

sending to the laboratory,      (read-only) 

• SampNumb Sample Number. This should appear on at least the first row of every 

lithological unit that is part of a sample. Despite its name it can contain both 

numbers and letters. 

• Geo Geologists’ Initials automatically derived from the Geologists data each time 

the Geology data is opened      (read-only) 

• BT Bit Type obtained from the Drilling data each time the Geology data is opened

         (read-only) 

• IS Interval Status – raw (R), adjusted to geophysics (A), etc. 

• PC Percent Lithotype. Where a lithological unit consists of more than one lithotype 

the user must specify what percentage of the lithological unit consists of this 

lithotype.  

• Li Lithotype – coal (CO), sandstone (SS), etc. 

• LQ Lithology Qualifier – silty (SI), fine grained (FF), bright (BR), stony (SY), etc. 

Note that according to CoalLog, each Qualifier in the dictionary can only be 

used for particular LithoTypes, for example fine grained can only be used for 

sandstones, sands and gravels. 

• Sh Shade – light (L), dark (D), etc. 

• Hu Hue – brownish (B), reddish (R), etc. 

• Co Colour – brown (B), green (E), etc. 

• A1 - A4 Adjectives – siliceous (SC), oxidised (OX), bands (BN), etc. 

• IR Lithotype interrelationship between Lithotypes for lithological units containing 

more than one Lithotype – interbedded with (IB), with clasts of (CT), etc. 

• We Weathering – extremely weathered (E), slightly weathered (S), etc. 

• St Estimated Strength – firm (C3), high strength rock (R5), etc. 

• BS Bed Spacing – thinly bedded (TB), thickly bedded (CB), etc. 

• DT Defect Type – fault (FT), vein (VN), etc.  

• DI Defect Intact Flag – intact or not 

• DS Defect Spacing – wide (WI), narrow (NA), etc.  

• DD Defect Dip Angle 

• CS Core State – broken (B), solid (S), etc. 

• MS Mechanical State – fissile (FS), powdery (PO), etc. 

• Tx Texture – soapy (SO), crystalline (XL), etc. 



CHAPTER 5. DATA FORMATS 

LogCheck Manual 81 

• BC Basal Contact – gradational (G), sharp and planar (P), etc. 

• S1 & S2 Sedimentary Features – cross bedded (XB), flasar bedding (FL), etc. 

• BD Bedding Dip Angle 

• Ab Mineral or Fossil Abundance – common (C), minor (M), etc. 

• MF Mineral or Fossil Type – chalcopyrite (CC), rootlets (RO), etc. 

• As Mineral or Fossil Association – clasts (CT), in veins (VN), etc. 

• Ga Gas – low (L), high (H), etc. 

Non-CoalLog versions of LogCheck have most of these fields but they may have slightly different 

names. 

An example of Geology data in LogCheck: 

 
 

A lithological single unit may consist of multiple rows, for example, where all the description does not 

fit onto a single row, as with the basalt unit between 126 and 136 metres above or lithological units 

consists of multiple lithologies, for example the sandstone and siltstone between 142 and 145 metres 

above which consists of 60% siltstone and 40% sandstone.  

 

For lithological units consisting of multiple lithotypes, an interval base depth must be entered on the 

first row of the unit and then subsequent rows must have their base depth blank. Each new lithology 

within the unit is included by a code in the Lithotype column and a percentage in the % Lithotype 

column. The percentages for all lithotypes in a lithological unit must add up to 100%. The user can 

extend the description of each lithotype over a number of lines but must leave the lithotype blank on 

these subsequent lines. 

Before any Seams, Stratigraphic Markers or Plies can be entered for Geology Data, a Seams 

Dictionary needs to be created for project. For more information on creating this dictionary see 

Section 2.8.1 Setting up a local Seams Dictionary in Chapter 2. 

 

Items with just a depth and no thickness are referred to as horizons, for example, base of weathering, 

water level, top of formation. Depending on the user’s data format, there are two different ways to 

enter horizon codes: 

 

• For data formats with a Horiz column, such as CoalLog, the horizon is entered in the Horiz 

column of the unit whose base depth is at the horizon depth, for example, at the base depths of 

139 and 142 metres in the example on the previous page. If the horizon occurs mid-way along 

a unit, the unit has to be split into two at the horizon depth. 
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• For data formats without a Horiz column, a zero-thickness unit must be entered at the horizon 

depth and the horizon code entered in the Seam column. A zero-thickness unit is one with the 

same base depth as the previous unit. Such units must have a horizon entered. If using Vulcan, 

it must have lithology entered, usually NL for not logged. For all other systems, the lithotype 

must be left blank.  

The geotechnical variables Defect Type, Defect Intact, Defect Spacing and Defect Dip Angle describe 

overall defects in a unit. They cannot be used to record the detailed information that is required by 

Geotechnical Engineers to calculate numerical values such as Rock Quality Designator (RQD), 

Fracture Frequency, Defect Spacing and Unit Rating. To calculate these items, it is necessary to 

undertake a detailed Defect log as described in the Chapter xx, Geotechnical Extension. If a detailed 

log it is merely superfluous to record anything in the geotechnical variables of the Geology data. 

LogCheck only checks that: 

• depths increase down the hole,  

• lithotype percentages add up to 100% and  

• that zero thickness units only contain horizons and no other data  

when the user attempts to save their data as these restrictions may temporarily not be satisfied while 

the user is editing their data. 

5.9 Water Flow Data 

The Water Flow data variables in LogCheck are: 

• Depth Depth at which the water flow test was taken. Note that this is one of the few 

instances in LogCheck where the Depth refers to a single depth rather than the 

base depth of an interval 

• Date Date the test was performed 

• SampNumb Unique identifier for the sample 

• TestType  Test Type – V-notch, 305mm board (3), estimate (E), etc 

• FlowHeight  Flow Height across weir in mm’s; when entered, LogCheck automatically 

calculates the flow rate 

• Rate  Rate of Flow in litres/second 

• pH  pH of the sample 

• TDS Total Dissolved Solids for the sample 

• EC Electrical Conductivity for the sample in µS/cm 

• Temp Water Temperature in Celsius 

 

The only mandatory field is Depth. 

An example of Water Flow data: 
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5.10 LAS Data 

LAS files record downhole geophysical data, such as natural gamma, density, caliper and sonic. LAS 

stands for Log ASCII standard and the layout was developed by the Canadian Well Logging Society 

and can be found on its website at:  

www.cwls.org/las_info.php  

LAS data being an ASCII file, can be opened in a text editor such as NotePad.  

When a LAS file is first opened in LogCheck, its data is read into a dBase file which is stored in a 

folder called LasWork in the user’s project folder. Unless the LAS file is modified, subsequent times 

that it is opened are far quicker than the first time as the data has already been converted into a dBase 

file. The LAS data as displayed in LogCheck is read-only. To modify the LAS data,  

When opened in LogCheck, LAS data is read-only. To modify the data, the original LAS file must be 

edited in a text editor.   

An example of LAS data in LogCheck:  

 
 

 

 

 

 

 

 

 

 

 

http://www.cwls.org/las_info.php
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5.11 Sample Dispatch Data 

LogCheck defines a sample throughout its system by the sample’s hole name and sample number 

rather than just its sample number. It does not use a sample’s From and To depths to define the 

sample but instead every time data is opened for a sample, its From and To depths are updated from 

their current values in the Geology data. 

The variables in Sample Dispatch data are: 

• SP Sample Purpose  

• SampNumb Sample Number, despite its name this can include alphabetic and other non-

numeric characters as well as numbers. Before a Sample Number can be entered 

into the Coal Quality data it must have been entered into the Geology data for 

the hole. 

• From From Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• To To Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• Thickness Sample thickness as automatically calculated from the difference between its 

From and To depths.      (read-only)  

• FromSeam Seam at the start of the sample as determined from the drillhole’s Geology data. 

If the start of the sample sits in a seam’s roof then FromSeam will display the 

seam name followed by the suffix “_RF”.     (read-only)  

• ToSeam Seam at the end of the sample as determined from the drillhole’s Geology data. 

If the end of the sample sits in a seam’s floor then ToSeam will display the 

seam name followed by the suffix “_FLR”.   (read-only)  

• Mass Sample Mass (kg) 

• LabName Laboratory Name 

• DispDate Dispatch Date 

• DispNumb Dispatch Number 

 

The only mandatory field is SampNumb. 

 

An example of Sample Dispatch data: 
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5.12 Basic Coal Quality Data 

LogCheck has an optional Coal Quality extension, see Chapter 11 – Coal Quality Extension which is a 

full Coal Quality database including various sample preparations, composite samples, reporting and 

exporting data on various bases and provision for the results of over 200 different tests. However, the 

standard version of LogCheck includes a basic coal quality system that handles the results for 15 

different tests for raw individual ply samples. 

LogCheck defines a sample by its hole name and sample number rather than just its sample number. 

Therefore, there is no need to include the hole name in the sample number. It does not use a sample’s 

From and To depths to define the sample but instead every time data is opened for a sample, its From 

and To depths are updated from their current values in the Geology data. 

Coal Quality data opens in read-only mode unless the user in is Manager mode (Settings > Manager) 

though it can be imported from CSV files in user mode. 

The variable in Coal Quality data in the standard version of LogCheck are: 

• SampType Sample Type, automatically set to PLY in the standard version of LogCheck.

         (read-only) 

• SampNumb Sample Number, despite its name this can include alphabetic and other non-

numeric characters as well as numbers. Before a Sample Number can be entered 

into the Coal Quality data it must have been entered into the Geology data for 

the hole. 

• From From Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• To To Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• Thickness Sample thickness as automatically calculated from the difference between its 

From and To depths.      (read-only)  

• FromSeam Seam at the start of the sample as determined from the drillhole’s Geology data. 

If the start of the sample sits in a seam’s roof then FromSeam will display the 

seam name followed by the suffix “_RF”.     (read-only)  

• ToSeam Seam at the end of the sample as determined from the drillhole’s Geology data. 

If the end of the sample sits in a seam’s floor then ToSeam will display the 

seam name followed by the suffix “_FLR”.   (read-only)  

• FromPly  Ply at the start of the sample as determined from the drillhole’s Geology data.

         (read-only) 

• ToPly  Ply at the end of the sample as determined from the drillhole’s Geology data.

         (read-only) 

• LR Linear Recovery as automatically determined by LogCheck from the drillhole’s 

Geology data based on the amount of Core Loss recorded for the sample 

interval.        (read-only) 

• VR Volume Recovery 

• LabName Laboratory Name 

• ReportNo Laboratory Report Number 

• Basis Basis for samples, automatically set to ARP for As Reported in the standard 

version of LogCheck. As Reported is means the results are to the standard basis 

for the variable as specified in the CoalLog standard. For all variables in the 

Basic Coal Quality system this is Air Dried except for Total Moisture which is 

As Received.       (read-only) 

• MassAD Sample Mass (kg) 

• RD Relative Density 

• TM Total Moisture (%) 

• MIAS Moisture in Analysis Sample (%), historically often called Inherent Moisture. 
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• Ash Ash (%) 

• VM Volatile Matter (%) 

• FC Fixed Carbon (%) 

• SE Specific Energy (MJ/kg) 

• CV Gross Calorific Value (kCal/kg) 

• TS Total Sulphur (%) 

• Cl Chlorine (%) 

• P Phosphorus (%) 

• F Fluorine (ppm) 

• CSN Crucible Swell Number 

• GiesMF Gieseler Maximum Fluidity (dd/min)  

 

The mandatory fields are SampNumb, LabName and ReportNo. 

For test results, as well as be able to enter numeric values, the following values can also be entered: 

• a numeric value preceded with a < to indicate that it is below the lower detection limit that 

follows the < sign 

• a numeric value preceded with a > to indicate that it is above the upper detection limit that 

follows the > sign 

• IS for insufficient sample 

• NS for not sampled 

• NR for not reported 

• TBA for to be advised 

• NF for no fluidity (only used for Gieseler measurements) 

If only one of specific energy or calorific values is supplied, LogCheck automatically calculates the 

other from the supplied value.  

An example of Basic Coal Quality data: 
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5.13 Daily Activity Data 

Unlike nearly all other LogCheck data where a data table refers to an individual hole, daily activity 

data refers to a particular date. Daily activity data are all full verbal descriptions. 

 

The variables in Daily Activity data are: 

• Safety Safety procedures executed on the day  

• General General description of the activities of the day 

• Planned Planned activities for the following day 

 

An example of Daily Activity data: 

 
 

5.14 Rehabilitation Data 

This enables the capturing of the rehabilitation that has been performed for a hole. 

 

The variables in Rehabilitation data are: 

• Date Date the action was performed  

• Action The rehabilitation undertaken as a verbal description 

 

An example of Rehabilitation data: 

 

 



CHAPTER 5. DATA FORMATS 

 88  LogCheck Manual 

  



CHAPTER 6. CREATING, IMPORTING & OPENING DATA 

LogCheck Manual 89 

Chapter 6  
Creating, Importing and Opening Data  

 

 

By the end of this chapter you will be able to: 

 

▪ Create new data for a hole. 

▪ Import data from a CSV file. 

▪ Open holes for editing. 

▪ Create and edit a group of holes known as a hole set. 

▪ Create and edit a set of hole data intervals. 
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6.1 Introduction  

This chapter describes how to create, import or open drill holes. Once completed, the drill holes can be 

viewed, edited, revalidated, plotted, exported and/or reports generated.  

When opening drill holes, you can select a single hole, all holes, or a group of holes, known as a hole 

set. Holes in a hole set can be selected from a list, by specifying a section, such as north-south or 

oblique section, and/or by creating a query or by importing a list from a text file. 

For the selected hole or holes, you can also select a predefined interval, known as an interval 

definition. This is usually used for plotting or reporting on just part of a drill hole, for example, from 

the roof of a specified seam to the floor of a specified seam. 

6.2 Creating New Data for a Hole 

The first step in this process is to create a new table of this data type for the hole by selecting File > 

New > Hole Data from the LogCheck menu: 

 

 

Then the window shown on the right will prompt for the 

Project, Data Type and the Hole Name for the new hole 

data.  

 

 

 

 

On clicking OK, LogCheck will create the new table in the directory named after the data type and 

sitting in the project directory. It uses the hole name as its filename with a .DBF extension. Hole 

names in LogCheck are always upper case and cannot contain blanks. Hole names are generally 

restricted to a maximum of eight characters but can be up to sixteen characters if specifically 

requested. 
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In the above example, LogCheck creates two files named DDH001.dbf and DDH001.dbt in the folder 

Geology in the project AVOCALOG. The DBF file will contain the coded data for the hole and the 

DBT file the comments. If the data type directory Geology does not exist, LogCheck creates it. 

Following creation of the table, it will then be opened in the LogCheck editor, as shown below: 

 

In the above figure, the first depth of 2.00 m has been entered, and the cursor is currently in the Li 

(Lithotype) column. The Tab key moves the cursor to the next field, or the mouse can be used to select 

a column.  For those data values that have an associated dictionary, the dictionary entries are displayed 

on the right-hand side of the editor – in this example, Lithotype entries are displayed. Pressing the 

down-arrow key commences a new row. The LogCheck editor is described in more detail in Chapter 7 

of the LogCheck User Manual. 

Hole data can be deleted, renamed or moved to another project or computer by using Windows 

Explorer. The filenames for a particular hole is the same for all data types, therefore care must be 

taken when moving files to ensure that they are placed in the correct directory for that data type in the 

destination project. For example, the geology data for hole DDH001 will be stored in a file named 

DDH001.dbf, in the Geology folder – the full path is as follows: 

    C:\LogData\AVOCALOG\Geology\DDH001.dbf 

 

The header data for the same hole has the same name, DDH001.dbf and is stored in a file named 

DDH001.dbf, in the Headers folder – the full path is as follows: 

    C:\LogData\AVOCALOG\Headers\DDH001.dbf 
 

It is essential that when deleting, renaming or moving files and whatever action that is performed on a 

DBF is also performed on the corresponding DBT file else the comments for the hole will be 

permanently lost.  
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6.3  Importing Data from a .CSV File 

Data within .CSV being imported into LogCheck can be one of a number of different Data Layouts. 

For Geology data, the main difference between the various Data Layouts is how continuation lines for 

a single lithological unit are indicated. 

The most common Data Layout is the LogCheck Data Layout. For CoalLog versions of LogCheck, 

CoalLog Data Transfer format is also widely used. There are a number of other possible Data Layouts 

for .CSV being imported into LogCheck. These include: 

• MineScape / GDB 

• Minex 

• Vulcan 

• Geobank 

• Prolog 

• EngLog 

  

These Data Layouts are rarely used now. Please contact the LogCheck distributor for further 

information regarding them if your .CSV data is in one of these layouts. 

The main advantage of the LogCheck Data Layout compared to the CoalLog Data Transfer layout is 

that it is more flexible but this comes at the cost of requiring more set up by the user. In particular, 

with LogCheck Data Layout, the user can have whatever column headings they wish in their data but 

before importing the data they must first set up a mapping between the .CSV columns and the names 

of the corresponding LogCheck variable. LogCheck, though does save the supplied mappings for use 

as the default mappings when the same type of data is next imported.  

Unlike most other Data Layouts for Geology Data, the LogCheck Data Layout does not use a 

Continuation Flag column to indicate continuation lines for a single lithological unit. Instead, 

continuation lines are indicated by leaving the unit Base Depth blank.  

For downhole data in LogCheck Data Layout, the location of the interval or point being described is 

recorded in a number of different ways: 

• For most down hole data just the Base Depth needs to be provided as the From depth is 

assumed to be the previous Base Depth.  

• For point depth information such as Defect Mid-Point Depth is recorded in the LogCheck 

variable named Defect. 

• For Point Load and Geotechnical Laboratory Tests both the Base Depth and the Sample 

Thickness must be provided and when the software requires a From depth it calculated this 

from the Base Depth and sample Thickness. 

• For Coal Quality and Sample Dispatch data, no From and To Depths or Sample Thickness are 

required, only a Sample Number. The From and To Depths and Sample Thickness are 

automatically generated for the data whenever it is opened. However, all Sample Numbers 

used in the data must have been entered into the Geology data for the drill hole before the data 

can be imported.  

The advantage of CoalLog Data Transfer is that no setup is required from the user before importing 

the data as the LogCheck already contains the mappings between the LogCheck variables and the 

columns in the CoalLog Data Transfer file. For more information on the layout of CoalLog Data 

Transfer see Chapter 7 of the CoalLog Manual available for free download from: 

https://www.ausimm.com/insights-and-resources/resources/codes-and-standards/coallog/ 

https://www.ausimm.com/insights-and-resources/resources/codes-and-standards/coallog/
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To import Hole Data into LogCheck, select: 

 

 

 

 

 

 

 

 

6.3.1 Importing Data in LogCheck Data Layout 

For LogCheck Data Layout, select 

Data Layout of LogCheck and the 

Data Type of the in the .CSV file: 

 

 

 

 

 

 

 

 

Then enter the location and name of 

the import file: 
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Next set the column name in the import .CSV file for each LogCheck variable: 

 
 

Pressing the drop-down arrow will display the list of column names in the import file: 
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LogCheck warns the user if any of the 

columns in the import file has not been 

assigned to a LogCheck variable: 

 

 

 

 

 

LogCheck also warns the user if any files are 

going to be overwritten by the imported data: 
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6.4 Opening Hole Data 

To open already existing data the data for 

a drill hole, go to the File menu, select 

Open, then select Hole Data (or 

alternatively, press Ctrl+O): 

 

 

 

 

 

 

 

Next select the required: Project, Data Type, Hole(s) and Interval to open: 

 

6.4.1 Selecting Project 

Select the Project containing the data to be opened. The drop-down list of possible projects includes 

all projects in the current LogCheck Data Directory that contain Hole Data.  

6.4.2 Selecting Data Type 

Select the Data Type of the data to be opened. The drop-down list contains of possible data types 

includes only contains the data types for which there is hole data in the currently selected project. 
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6.4.3 Selecting Holes 

There are three options when selecting holes: 

• All Holes All holes for the project are selected. 

• Hole Set Only those holes in a specified Hole Set are available (see following section). 

• Single Hole Only the hole specified is selected. Choose the required hole from the drop-

down list. This list only contains the holes within the current project that have 

the currently selected data type. 

 

To edit data for a hole, the Single Hole option must be selected. If multiple holes are opened, using the 

All Holes or Hole Set options, they can all be exported, printed and/or plotted, however, editing is 

limited to the Find or Find and Replace functions.  

After selecting multiple holes, the screen will show the project, data type and a list of the holes that are 

currently open: 

 

6.4.4 Selecting Intervals 

The interval selection option allows you to specify which part(s) of the hole(s) are to be opened. The 

options are: 

• Entire hole: Open entire. 

• Specify top and bottom depths: Specify a top and bottom depth in metres. 

• Use interval definition: Select an interval or intervals – see the Section below in this 

chapter for instructions on how to create an interval definition. 

 

Interval selection is not available for header data as all its data applies to the entire hole.  

If selecting less than the entire hole then the data opens in read-only mode. Generally, opening less 

than the entire hole is used for plotting or reporting. 
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6.4.5 Opening LAS Data 

Downhole geophysical data (LAS) is opened in LogCheck in the same manner as other Hole Data as 

shown above but with the selected Data Type being LAS: 

 

There are though a number of differences between opening LAS data and other Hole Data: 

• For all other Hole Data, LogCheck always searches for it in that Data Type’s folder in the 

Project’s folder, whereas with LAS data, it only searches for it in a folder named LAS in the 

Project’s folder if no other folder has been specified for the LAS File Directory in the Project 

Details: 

   

If one has been specifed as shown above then LogCheck searches for the LAS data in this 

folder. If LAS data has been copied onto the user’s computer but LAS is not shown as an 

option for Data Type, it is usually because the LAS File Directory in the Project Details is 

incorrect. 

• For all other Hole Data, LogCheck only searches for the data in the Data Type’s folder in the 

Project’s folder but does not search for data in subfolders in this folder, whereas with LAS 

data, it not only searches the LAS data folder but also all the subfolders in the folder and all 

the subfolders in the subfolders etc. This thus enables the user to setup separate subfolders in 

the LAS data folder for each borehole and to store all the LAS files foe each borehole in the 

subfolder named after the borehole. 
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• For all other Hole Data Types, LogCheck identifies the data’s hole by the data file’s file name, 

whereas with LAS data, LogCheck identifies the hole by the name specified in the WELL line 

in the Well Information Block of the LAS data’s header: 

 

 

If when opening LAS data, the required hole does not appear in the Single Hole drop-down 

list even though its LAS data has been copied into the project’s LAS Data Directory, it is 

generally because the hole name been incorrectly entered into the WELL line of its Las files. 

• For all other Hole Data Types, if the user opens all the data for the entire hole then they can 

modify the data within LogCheck, whereas LAS data cannot be modifed in LogCheck. To 

modify LAS data the user must open the LAS file in a text editor such as NotePad. 

• For all other Hole Data Types, LogCheck converts the data into dBASE binary files when it is 

originally imported or when it is entered via the keyboard, whereas with LAS data, it is only 

converted into dBASE binary files the first time LogCheck requires the particular LAS file or 

after the LAS file has been modified by the user. Therefore, subsequent times the LAS file is 

opened by LogCheck are considerably faster than the first time it is opened or the first time it 

is opened again after being modified. 

• For all other Hole Data Types, all the data for the particular Data Type for each hole is stored 

in a single file whereas with LAS data it may be spread across a number of LAS files. These 

files may differ in the hole intervals that they include, the curves that they include and/or their 

reading intervals. Therefore, when opening LAS data LogCheck creates a temporary file 

including just the data for the required interval, required curves and the required reading 

interval.  

As with all other Hole Data Types, the required interval is specified by the user in the Hole 

opening window. For LAS data, following selction of the required holes and intervals, the user 

is prompted for the curves that they require: 
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This list of possible curves includes all the curves in all the LAS files for all the holes whose 

LAS data is to be opened. Occasionally, the curve names displayed will look slightly different 

to how they are shown in the actual LAS files as the curve names used in LogCheck must be 

valid dBASE field names. Where curve names include characters that are not allowed in 

dBASE field names, these characters are replaced by underscore characters. For example, the 

curve name DEN(SS) is changed to DEN_SS. 

After selecting the required curves, the user is prompted for the required reading interval: 

 

This list of possible reading intervals includes all the reading intervals that occur in the LAS 

files containing the required curves for the required holes. Where the user selects Lowest 

Available, then the reading interval used for creating the temporary file for each hole is the 

lowest reading interval for all the LAS files for that hole containing any required curves. 

Where some of the required curves only have reading intervals different to that selected by the 

user, these curves will be resampled at the required reading interval for the temporary file. 

Be warned that if there is more than one LAS file in the LAS File Directory, with different 

values for a required curve over the required interval at the required reading interval then 

LogCheck will merge the two sets of values with possibly unpredictable resulting values.  

• For all other Hole Data Types, it is not possible on opening the data to adjust the data depths, 

whereas with LAS data, the user can specify an adjustment to all the depths in the file: 

 

This is useful where the LAS data is to be displayed next to data collected on the hole by the 

geologist and the zero depth point used by the geophysical logger differed to the one used by 

the geologist. 

• For all other Hole Data Types, no optional calculated fields are generated when opening data, 

whereas with LAS data, the user is provided with the option to include a number of fields that 

are calculated during the generation of the temporary file. 

The first optional calculated field is: 

 

Selecting this enables the user to calculate UniaxialCompressive Strength (UCS) from one of 

the sonic transit time curves that have been included. If no transit time curves have been 

selected then this option will be disabled. 

The user can specify a name for the new curve and the transit time curve to use. In the above 

example, these are UCSCALC and MC2A respectively. 
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The UCS is calculated based on the parameters that the user has setup in the Project Details 

for the project: 

 

The parameters for this relationship will vary from project to project and so must first be 

determined based on lab results of UCS and Sonic Transit Time values for a number of 

samples from preliminary holes. More information about this procedure can be found in 

“Geotechnical applications and interpretations of downhole geophysical logs” by G.H. 

McNally published by Australian Coal Industry Research Laboratories, Sydney. 

The second optional calcualted field is: 

 

Selecting this enables the user to calculate Unaxial Compressive Strength (UCS) from curves 

that have been included and a LAS Formula. The LAS Formulae are defined by a LogCheck 

definition called LAS Formula. If no LAS Formulae have been selected then this option will 

not be enabled. 

The user can specify a name for the new curve and the LASFormula to use. In the above 

example, these are UCSCALC and GeoscienceUcs respectively. 

To create a LAS Formula Definition, select File > New > Definitions > Las Formula: 
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An example of a Las Formula for calculating UCS: 

 

The formula is expressed in dBASE’s query language (see Appendix B). In the above 

example, the formula essentially uses sonic velocity rather than transit time and uses a 

different calculation for UCS depending on whether the readings were taken in coal (den_ss < 

1.8) or non-coal.  

The third optional calculated field is: 

 

Selecting this enables the user to calculate Roof Strength Indices (RSI) using a density curve 

and UCS curve. RSI is calculated for each reading by calculating the insitu pressure above the 

reading by summing the density times the reading interval of all the readings above the 

reading and then dividing this pressure by the readings UCS. If no density curves have been 

selected or if no UCS curves has been either selected or calculated then this option will be 

disabled. 

The user can specify a name for the new curve, the density and UCS curves to use. In the 

above example, these are RSI, ADEN and UCSCALC respectively. The user can also specify 

whether when calculating pressures to replace any missing densities with either the Average 

rock density for the hole or by a specified density value. 
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6.5 Creating/Editing Hole Set Definitions 

A Hole Set Definition is a group of holes that can be operated on simultaneously, for example to: 

• Revalidate all the data for a group of holes, 

• Plot a group of holes, 

• Report on a group of holes 

• Export data for a group of holes to other systems. 

 

To create a new Hole Set Definition, go to File > New > Definition, then select Hole Set: 

 

 

Next enter the location and name for the new Hole Set: 

 

 

The Hole Set Definition Name that the user supplies can be of any length and contain upper and lower 

case characters but cannot include blanks. 
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To open an existing Hole Set Definition, go to File > Open > Hole Set definition, and then select the 

required Hole Set. 

 

 

Next the Hole Set Definition form is displayed: 

 

 

Holes to be included in the hole set can chosen in three ways: 

• by picking from list 

• by selecting those on a section; 

• using a query 
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6.5.1 Select by Picking from List 

The figure below is the panel of the Hole Set Definition form that enables selecting drill holes by 

creating a list of selected holes from a list of all holes in the project for which data exists for at least 

one data type: 

 

Select from the list on the left, then click the Add to Selection button. Multiple selections can be made 

by using the Ctrl or Shift keys with the mouse. The example above shows that holes AVC030C, 

AVC031C, AVC032 and AVC033 have been included in the Hole Set. To remove holes from the list, 

select them and then click the Remove from Selection button. 

If the Sorted box after Selected Holes is not ticked then the holes are listed in the order that they were 

selected rather than in alphanumeric order: 

 

This is useful, if the user wishes to plot the holes on a section but rather than doing a scaled wants to 

plot the holes a fixed distance apart and to define the order that they appear. 
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6.5.2 Select by Section 

The figure below is the panel of the Hole Set Definition form that enables selecting those drill holes 

that are located along a section:  

 

Select Section Type: 

• East-West Section and then enter the section’s Northing 

• North-South Section and then enter the section’s Easting 

• Oblique Section and then enter the coordinates of the left and right-hand ends of the section  

• Section between specified holes and then select the names of the hole that the section is 

between 

 

The Section Corridor Tolerance allows you to set the width of the corridor for including holes. 

Clearly, Select by Section can only select holes whose coordinates have been entered in the header 

data. 

6.5.3 Select using a Query 

The figure below is panel of the Hole Set Definition form that allows you to create a hole set by using 

a query. The query is in DBL, which is the dBase query language (see Appendix B).  

 

In this example, all holes containing a cored section somewhere in the hole will be selected. The Bit 

Type field in Drilling data is named bt and DW, PC, PW and TC are all CoalLog Bit Types that are 

produce core. Note that when entering a character value in the query it must be enclosed in double 

quotes. 
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6.5.4 Select using a Combination of Methods 

Holes can be selected using a combination of the methods described above by ticking multiple 

methods. For example, to select the cored holes from a list, tick both Select by picking from list and 

Select using a query: 

 

The above example, will select only the cored holes from the list AVC030C, AVC031C, AVC032 and 

AVC033: 
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6.5.5 Importing a Hole Set 

A Hole Set Definition can also be created by importing a list of holes from a text file. For example, 

Notepad++ can be used to create a list of hole names:  

 

 

To create a Hole Set from the text file. Select File > Import > Definition > Hole Set List   

 

 

Next select the file containing the list of 

holes:   
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Finally select the Project for the Hole Set and the name it is to be given: 

 

 

After importing the Hole Set will be displayed: 
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6.6  Creating/Editing Interval Definitions 

An Interval Definition enables specification of downhole intervals, based on specific criteria for the 

top and bottom of the interval. This can be used in the Open Hole window to specify which part of a 

hole or holes to open for viewing, plotting, exporting and/or reporting. 

6.6.1 Creating a New Interval Definition 

To create a new Interval Definition, go to File > New > Definition then select Interval. 

 

 

This displays the window to enter the name for the new Interval Definition: 

 

Enter a relevant name (in this example, WK23SEAM), then click OK.  
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Next, the Interval Definition window for the new interval definition is displayed:  

 

 

 

 

 

 

 

 

 

 

 

 

As with the Query 

option in the Hole 

Set Definition, the 

response to the 

Selected Units 

prompt for the 

interval Top and 

Bottom is in DBL 

(see Appendix B). 
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6.6.2 Open an Existing Interval Definition 

To open an existing Interval Definition, go to File > Open > Definition, then select Interval Definition.  

 

 

This then brings up the window:  

 
 

Select the required Interval Definition and click the OK button to display the Interval Definition 

window (shown below). 

Interval definitions can be specified that display as a single interval, or as multiple intervals that do not 

display all the intervening intervals between the units in the LogCheck editor. Examples of these are 

discussed in the following sections. 
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6.6.2.1 Example 1:  Single Interval for One or More Units 

An interval definition based on the geology data that runs from 2.0m above the top of the WK2 seam 

to 2.0m below the base of the WK3 seam that will display as a single interval in the LogCheck editor 

is shown below: 

 

The result of opening up hole AVC035 with the WK23SEAM interval definition in the LogCheck hole 

editor is shown below on the left. If the hole is then plotted (File > Plot), the results are shown on the 

right. This example illustrates the effect of selecting the “Single interval from the first top to the last 

bottom” option from the Multiple Interval choices in the interval definition.  

 

 

 

 

 

 

 

 

WK3 

WK2 
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The range selected by this interval definition is displayed as a single interval in the LogCheck editor 

even though the intervening interval between the WK2 and WK3 seams is longer than the 2.0m above 

the WK2 seam and below the WK3 seam. 

Note that a blank row coloured dark grey is used to indicate that only part of the hole has been opened. 

Although the total logged depth of the hole is 314.0m, the editor only displays down to the 2.0 m 

below the base of the WK3 seam that was specified in the interval definition. 

The data type used for the selection criteria does not have to be the same as the data type that is being 

opened. For example, the above interval definition could be used to open the LAS data for all depths 

from 2.0m above the top of the WK2 seam to 2.0m below the base of the WK3 seam. As a variation 

on this example, if “WK2” and “WK3” is replaced with “WK”, this would define an interval running 

from 2.0m above the first seam starting with “WK” to 2.0m below the last seam starting with a “WK”. 

Because the selection criteria are applied with the dBASE DBL query language, specifying “WK  ”, 

where there is a blank after the “K”, would select from 2.0m above the first seam named precisely 

“WK” to 2.0m below the seam named precisely “WK”. In this case, the trailing blank enforces a strict 

match with the characters, rather than matching any seam that started with “WK”. 

6.6.2.2 Example 2: Selecting Multiple Intervals in a Single Hole  

This example illustrates the effect of selecting the “multiple intervals from each top to the first bottom 

below that top” option from the Multiple Interval choices in the interval definition.  

 

 
 

The effect is to select potentially non-contiguous sequences and display them at the same time. 

In this example, the Interval Top Definition is set to 1.0 m above each seam that occurs in the hole. 

The Interval Bottom Definition is set to 1.0 m below each seam that occurs in the hole. The end result 
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is to select all seams that occur in the hole, but only the seam itself and 1.0 m of the roof and 1.0 m 

below the floor. 

 

The result of opening up hole AVC031C with the SEAM interval definition in the LogCheck hole 

editor is shown below. Note that a blank row coloured dark grey is used to separate the selected 

intervals – in this case each seam and 1.0 m above it and 1.0 m below it. 

 

 

 

The results of plotting this data are shown below. Note the effect of selecting “multiple intervals” – 

exactly 1.0m above and below each seam, and the seam itself is selected. 
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6.6.2.3 Example 3: Seam Roof Plus Adjacent Bolting Horizon Definition 

Where the roof of a seam is unstable, the user may need to see the unit above the immediate roof to 

determine if it can be used as a stratum in which bolts can be set to support the seam roof. To includes 

this bolting horizon into the interval, select the “top of unit directly above selected units” option for the 

top interval. In this example, the Interval Top Definition is set at 0.5 m above the top of the unit that 

overlies the WK2 seam, and the Interval Bottom Definition is set at 0.0 m above the top of the WK2 seam 

– that is, the top of the WK2 seam. 

 

The result of opening up hole AVC031C with the WK2ROOF interval definition in the LogCheck hole 

editor is shown below. Note that a blank row coloured dark grey is used to mark the beginning of the 

selected interval.  

 

 

 

 

 

 

Top interval: 0.5m 

above the unit (MS) 

overlying WK2 seam 

Bottom interval: 

0.0m above top of 

WK2 seam. 



CHAPTER 6. CREATING, IMPORTING & OPENING DATA 

LogCheck Manual 117 

6.6.2.4 Example 4: a single interval from the first top to the first bottom below it  

An example of selecting the “a single interval from the first top to the first bottom below it” option 

from the Multiple Interval choices in the interval definition is the following for selecting the upper-

most seam in any hole: 

 
 

As WK2 is the upper most seam in the borehole AVC031, the 

resulting plot generated after opening the borehole AVC031 with 

the above Interval Definition would be: 
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Chapter 7  
LogCheck Editor 

 

 

 

 

 

 

By the end of this chapter you will be able to: 

 

▪ Navigate the LogCheck editor form. 

▪ Modify hole data in the hole edit form. 

▪ Append, copy and delete rows in the hole edit form. 

▪ Find and replace logging data. 

▪ Modify options in the Settings menu. 

▪ Validate drill hole data against a dictionary. 

▪ Compare two copies of the same hole or two copies of a dictionary. 
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7.1 Introduction 

The LogCheck editor is used for viewing and modifying both dictionaries and hole data, and for 

viewing summaries and audits. Dictionary can only be modified if Manager status has been turned on 

for the current session (see Chapter 3).  Hole data can generally be modified, however, if the file 

properties are set to read-only, or only part of a hole is opened, it can only be viewed (see following 

section for setting the read-only property). Summaries and audits are all read-only. 

If the data being viewed is read-only, it is shown in grey rather than black. In addition, even when you 

can modify data, there may be calculated fields such as Calculated Thickness in most Hole Data 

Types, and Bit Type and Geologist’s Initials in Geology data that cannot be modified. Bit Type must 

be modified in the hole’s Drilling data and Geologist in the hole’s Geologists data. These read-only 

fields are also shown in grey. 

Most dictionary categories are stored in alphabetical order, however some categories, such as 

weathering and estimated strength in some versions may be entered in a more appropriate order such 

as degree of weathering or strength. For categories in alphabetical order, select Append Rows to add 

further items to the bottom of the list, and LogCheck will automatically move the entry to its 

appropriate place once it has been entered. For categories not in alphabetical order, select Insert Rows 

or Append Rows to enter new data in its appropriate place. 
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7.2 Setting the Read-Only Property of Data Files 

The read-only property can be set for a single file, multiple files or a folder and all of its contents. 

To set or unset the read-only property:  

• Open up My Computer or Windows Explorer and navigate to the folder where the data to be 

set to read-only is stored.  

• Right-click the required folder or files and select the Properties item from the menu: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• The Properties window then displays: 

To set the read-only property, click the 

Read-only checkbox so that it is checked 

and click the OK button. 

To unset the read-only property, clear the 

check from the box, and click the OK 

button. 
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7.3 Editor Form 

After opening the data, as described in Chapter 3 for dictionaries and Chapter 6 for hole data, the data 

is displayed in LogCheck’s data editor, which can display the data in either Grid Layout, or Form 

Layout. The respective items in the View menu allow you to switch between them, or the Shift+F8 hot 

key will toggle between the two views.  

7.3.1 Grid Layout 

In Grid Layout, each row represents a logged drill-hole entry and each column represents a variable. 

The menus that are available along the top of the form are: Edit, View, Tools, Settings and Help.  

 
 

Note that there is no explicit “Close Hole” command – opening another hole automatically closes the 

previously opened hole, however, if any changes have been made to the data, the user is first asked if 

they want to save their changes. 

7.3.1.1 Navigating Data in Grid Layout 

For existing hole data you can move around the Edit Window by using the following keys: 

• Tab key Moves to the next column on the current row 

• Shift Tab key Moves to the previous column 

• PgDn key Moves down a page at a time 

• PgUp key Moves up a page at a time 

• Ctrl+PgUp Moves to the top of the data 

• Ctrl+PgDn Moves to the bottom of the data 

• Mouse wheel Scrolls up or down the log 

• Scroll bars Drag the vertical or horizontal scrollbars with the mouse 

• Arrow keys The Left, Right, Up and Down arrow keys move one item in the selected 

direction 

• F2 Enables editing of current field 

The abbreviation of the current column 
(LQ) is shown in the status line. 
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• End Moves to the last column unless editing current field where it moves to the 

end of the current field 

• Home Moves to the first column unless editing current field where it moves to the 

start of the current field 

7.3.1.2 Entering Comments in Grid Layout 

Most Data Types have a Comments field on the far right of the Hole Edit form enabling additional 

notes to be entered for a unit. There is no limit on the number of characters for comments. You can 

either type a single-line comment, or click the spanner icon, and a multi-line edit box appears. 

 

 

 

 

 

When generating an English log for the data, these comments are appended to the unit’s description. 

To put them on a new line the entered comment should start with a blank line, however, unless there 

are characters on this line dBASE automatically removes the blank line and so it is necessary to type at 

least one space character on this blank line. 

 

 

 

 

 

 

 

 

 

 

 

 

When you first enter the field, it 

shows a spanner on the right-

hand side, as shown below: 

In the multi-line edit box, you 

can add further comments, as 

shown below: 

To terminate the input, click the 

spanner again, and the first line 

of the comment is displayed, as 

shown below: 
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7.3.2 Form Layout 

An example of Geology Data in Form Layout is shown below:  

 

In Form Layout, all the data for just a single data row is shown along with a full description of each 

field. The advantages of this layout are that: 

• You don’t need to scroll across to fields on the right, as in Grid View; 

• The full descriptions of fields are shown alongside the values. 

7.3.2.1 Navigating Data in Form Layout 

For existing hole data you can move around the Edit Window by using the following keys: 

• Tab key Moves to the next column on the current row 

• Shift Tab key Moves to the previous column 

• First button Moves to the first row in the data 

• Previous button Moves to the previous row in the data 

• Next button Moves to the next row in the data 

• Last button Moves to the last row in the data 

• F2 Enables editing of current field; 
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7.3.2.2 Entering Comments in Form Layout 

To enter Comments, double-click the Comments field to bring up a full-screen editor, as shown below.  

 

When entry of Comments is complete, click the Close button (or Ctrl+F4) from the form’s control 

menu, which is to the immediate left of the File menu or click the form’s close button. Do not click the 

close button in top right corner of the form as this not only closes the form but also closes LogCheck: 

 

 

After a comment has been entered for a data row, the comment field displays an A in the 

comment field on the screen: 

7.3.3 LogCheck Editor Functions to minimize Keystrokes 

One of the most important features of the LogCheck editor is that it has been designed to minimize the 

number of keystrokes required to enter data.  

Examples of keystroke minimization employed in LogCheck include: 

• when entering data, the user can either: 

- type the data using the keyboard. 

- use the dictionary/keypad that is displayed on the side of the screen. This is especially 

useful when using tablets which only have a keyboard that pops up on the screen 

 

When the dictionary is displayed, it changes according to the type of data in the current cell. 

To display the dictionary, go to the View menu, then select Display Keypad/Dictionary. 

• when entering depths, if you enter a value less than 1.0, then LogCheck retrieves the integer 

value from the previous line; making it faster to enter data for thin units by reducing the 

amount of typing. For example, for a depth of 170.80, if the previous depth was 170.25, then 

you only need type in .80 – LogCheck carries the 170 down from above. For numeric fields, 

such as depth, even though a numeric keypad may be displayed, it is often easier to use the 

keyboard.  

Click the form’s Close 

button to close entry of 

the comment. 

Do NOT Click 

LogCheck’s Close 

button unless wanting 

to close LogCheck. 
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• when inserting or appending rows to the data, LogCheck automatically copies down values 

from specified fields in the previous row. The user can at any time set or reset the fields they 

would like copied down by selecting Settings > Carry Fields from the LogCheck menu: 

 

 

The following window will then be displayed for the user to select the fields they would like 

to automatically copy down:     

 

 
 

• a lithological unit can be split into two exactly the same units by selecting Split Current Unit 

from the Edit Menu (see Section 10.4.3 – Split Current Unit for more information) 

• where the value to be entered into a field is the same as the previous non-blank value for the 

field, by pressing the F4 key, the previous value is copied into the field rather than the user 

having to retype it. (see Section 10.4.8 - Copy Field from Above for more information)  

• where the entire description of a newly entered unit is the same as the previous unit with the 

same LithoType as the newly entered unit, by pressing Shift-F4, the previous entire 

description is copied down to the newly entered unit.  (see Section 10.4.9 – Copy all Fields 

from same Lithology Above for more information) 
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7.4 Edit Menu 

The Edit menu provides function to assist in editing the data: 

 

 

7.4.1 Inserting Rows Before the Current Row 

To insert new row(s) before the current row in a log, select Edit > Insert Before: 

 

 

The options for Insert Before are: 

• Single Row Inserts a single row, with no further dialog. 

• Multiple Rows  Inserts multiple rows, after prompting the user for the number of 

rows to insert. 

• Copy of Current Unit Inserts an identical copy of the current unit, including the depth. 

• Rows from another hole Inserts specified rows from another hole 
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When new single or multiple rows are inserted, data from some of the columns on the row above are 

copied to the new rows. The user can control which columns are copied by going to the Settings menu, 

then selecting Carry Fields (see above, Section 10.3.3 - Entering and Modifying Data in the LogCheck 

Editor). 

To insert multiple rows before the current row in a log, select Edit > Insert Before > Multiple Rows (or 

Shift+F5). The figure below shows the Multiple Rows dialog, which requests the number of new rows 

to insert: 

 

The new rows are inserted above the current row, and the specified fields (in this case, Seam, 

SampNumb, Li, Sh, Hu, Co, We and St) are copied from the row above, as shown below: 
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Copy of Current Row (or Ctrl+F5) inserts an identical copy of the current row. An example is shown 

below. The first image is before the operation and the second after: 

 

 

As can be seen above, Insert Copy of Current Row only copies a single row not the entire lithological 

unit. To actually copy the entire unit use Split Current Unit as described below. 

 

 

 

 

 

 

 

 

 

Insert Copy of Current 

Row also adjusts the 

thickness of the previous 

current row to 0.0 
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You can also insert rows from another hole (or Shift+F6). This is similar to the copy and paste options 

that are available in a word processor. The Insert Rows from another Hole option prompts for the 

name of the other hole and the interval from the other hole to be inserted: 

 

 

The new rows are inserted above the current row. In the example above, intervals from 190.00 to 

195.00 from hole AVC031C will be inserted in the log for hole AVC030. Inserting rows from another 

hole may be useful when: 

• a separate pre-collar being drilled for a hole by a different rig. 

• coal seam core will be tested for gas desorption and not logged at the time of drilling so that it 

can be sealed in a gas bomb as quickly as possible. It will usually then be logged some weeks 

later, after gas testing is completed. This data will often been recorded in a different file. 

7.4.2 Insert Rows After 

The Insert Rows After menu option provides the same options as Insert Rows Above, except that new 

rows are inserted after the current row. 
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7.4.3 Split Current Unit 

This is only available for Geology data. It enables the user to split a lithological unit at a specified 

depth. It creates a repeat of the unit immediately above the unit and gives the repeat a depth specified 

by the user. If the original unit consists of multiple rows then these are all included in the repeat.  

Splitting the Current Unit can be useful if you want to: 

• take a sample in one half, but not the other half of a unit 

• split a unit into two samples if there is a change in weathering characteristics across the unit, 

but all other aspects are the same 

For example, to split the unit with a top depth of 142 metres and base depth of 145 metres in the 

following data: 

   

• Navigate to any row in the unit 

• Select Edit > Split Current Unit: 

• Enter the depth at which it is to be split: 

 

This depth must be greater than the unit’s top depth and less than the unit’s base depth. 
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The result of the above splitting is: 

 

7.4.4 Append Rows 

The Append Rows option of the Edit menu (or Ctrl+A) adds a new record to the end of the currently 

selected hole. The Append Rows option, as with the Insert Rows option, copies down fields from 

columns above the new row. The user can control which columns are copied by going to the Settings 

menu, then selecting Carry Fields (see above, Section 10.3.3 - Entering and Modifying Data in the 

LogCheck Editor). An alternative way to add a new record to is to page down to the last row, then 

press the Down Arrow key. 

After appending a row, the first column of the new appended row, displays large + sign  to indicate a 

new row is being added: 

 

The new will row only added be after the user adds or modifies any data to the row and then navigates 

to another row or to a menu item. 
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7.4.5 Deleting Row(s) 

The Delete Row option of the Edit menu (or F7) will delete the current row in the grid. Note that 

confirmation of deleting is not requested. If you have accidentally deleted a number of rows, you can 

either choose the Undelete Rows option or if you have not completed a Save during the current 

session, exit LogCheck without saving, and re-open the hole which will restore the previous version of 

the data. 

7.4.6 Undeleting Row(s) 

The Undelete Row option of the Edit menu (or Shift+F7) will undelete a row that was previously 

deleted. Confirmation of undeleting is not requested. You can keep selecting Undelete Row to 

undelete one further deleted row back to the start of the editing session. 

7.4.7 Making Fields Blank 

Deleting data in a numeric field turns the number into 0.0. Blank data generally has a different 

meaning to a value of 0, for example in the depth field, a blank indicates line continuation. If you want 

to convert a numeric value, including 0.0 into a blank, highlight the field and select the Blank Field 

option (or Ctrl+L) from the Edit menu. 

7.4.8 Copy Field from Above 

Copy Field from Above (or F4) searches up the currently selected column to find the first non-blank 

entry, and then copies it to the current row. This option is often useful when adding seams or sample 

numbers into already entered data. 

7.4.9 Copy All Fields from same Lithology Above 

Copy All Fields from same Lithology Above (or Shift+F4) searches up from the current row for the 

first previous row with the same LithoType and Lithology Qualifier as the current row and then copies 

the entire description from this row to the current row. If the previous description for the lithology 

includes more than one row, it only copies the second and subsequent rows if the current row is the 

last row in the data. 

In the following example, the last row of the data has a LithoType of siltstone (ST) and the first 

previous row with a LithoType of siltstone (ST) is three rows above the last row: 
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After selecting Copy All Fields from same Lithology Above the description of the siltstone three rows 

above is copied to the the current unit: 

 

7.4.10  Find 

The Find option of the Edit menu (or Ctrl+F) allows you to find values in a specified column. The 

popup Window below allows you to specify values to find and the field (column) to find it in. 

 

 

In the above example, repeatedly clicking the Find Next button will search for the next occurrence of 

“WK2” in the Seam column. 

7.4.11  Find and Replace 

The Find and Replace option of the Edit menu (or Ctrl+H) allows you to search for specific values and 

replace them with something different.  

The popup Window requests the Field in which to search, the value to be replaced, and the value to 

replace it with: 

 

Clicking the Lookup Dictionary button allows you to select a valid replacement entry from the 

dictionary. The Replace button is only enabled once the next target value is found and will then 

replace the value with the new value. The Replace All button searches for and replaces all copies of 

the target value. In the example shown, all occurrences of Horizon WK2 will be replaced with WK2U. 
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The Find, Find and Replace, and Replace options of the Edit menu are the only Edit options that 

operate when you have multiple holes open. This can be useful if you decide to change the seam 

nomenclature. For example, to change all instances of Seam WK2 to WK2U. Even with multiple holes 

open, all of the changes you make are made to temporary copies of the hole data. They are not made 

permanently until you save the data. 

7.4.12  Replace Field 

The Replace Field option of the Edit menu allows you to replace all entries for a single hole between 

two depths. The replacement value can be either: 

• A blank; 

• A value selected from the dictionary; 

• Manipulated numerical values; 

• Expansion/Contraction of depths. 

7.4.12.1 Replacing with a Blank 

As an example of replacing with a blank, consider the common case of a hole that starts out as 

weathered, then goes to slightly weathered, then fresh, which then repeats for the rest of the hole. This 

clutters the reporting – as all subsequent intervals will generally be fresh, so the solution is to replace 

the remainder of core logged as fresh, with a blank. 

For example, in the data below: 
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To remove the weathering values below 100 metres depth select the following in the Replace popup 

Window: 

 

The result of replacing the F in the Weathering column with a blank from 105m: 
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7.4.12.2 Replacing with a Value from the Dictionary 

This option allows all values between two specified depths to be replaced with another value from the 

dictionary. This can be useful for specifying the seam on all the units that it applies to. 

For example, in the following data: 

  

 

To set the seam for the coal (CO) with base depths from 294.75 to 297.42 to WK2, select the 

following in the Replace popup window: 
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Resulting in WK2 being added as the Seam for base depths 294.75 to 297.42 metres: 

 

7.4.12.3 Manipulating Numerical Values 

The Replace Field option is useful for manipulating numerical values. Coal geologists spend a lot of 

time matching depths in the geology file to depths recorded in the geophysical log of the hole.  

For example, in the following data:  
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To raise the depth of all intervals between depths 47m and 61m by 5cms, select the following in the 

Replace popup Window: 

 

Resulting in the depths between 41.50m and 61.00m being raised by 5cms: 

 

 

A second application of this would be where  dips are 

measured with respect to the horizontal but you have 

historical data where the dips have been measured with 

respect to the core axis (vertical). For these holes,  the dips 

can be corrected by typing –1.00 for the X Old Value, and 

using 90 for the + value, as shown at right: 
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7.4.12.4 Expansion/Contraction 

When matching the geology to the geophysics, it may be necessary to add in a core loss. You should 

try to identify where the core loss occurred and enter a new row indicating “core loss” (KL) in the 

lithology column. Where the drill core is broken up, it may be impossible to identify where the core 

loss occurred, so you can try to spread the loss over the interval.  

For example, in the following data: 

 

To expand the interval 24.00 to 41.50m by 0.5m and spread the expansion over the entire interval, 

select the following in the Replace popup window:  

 

 

 

 

 

 

 

 

 

 

 

 

Resulting in the thicknesses of all the units between 24.00m and 41.50m being expanded to spread the 

core loss over all these units: 

Value 2 has been increased by 

0.5m from 41.50m to 42.00m 
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Another useful application of the Expansion/Contraction option is that after a run core has been 

brought to the surface it may expand and the Expansion/Contraction option can be used to readjust the 

thicknesses of the units such that the end depth of the core run matches the driller’s end depth for the 

core run. In this case, make the Old and New Value1, the depth of the start of the core run and Old 

Value 2 the end depth of the core run according to the geologist’s measurements and New Value 2 the 

end depth of the core run according to the driller. 

Contraction is always allowed, but as expansion should only be used where no Core Loss interval can 

be identified, there is an option in LogCheck s to disallow core expansion in the Replace Field 

window. This can be set by selecting Settings > Options, selecting the Editing tab: 

 

 

 

 

 

 

 

 

 

 

 

 

 

Untick to disallow expansion 
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7.5 View Menu 

The View menu allows you to configure the way the LogCheck Editor Window is displayed.  

 

It contains the following items:  

• Grid Layout – displays the data for multiple records as a scrollable grid (see Section 7.3.1 – 

Grid Layout); 

• Form Layout – displays the data for a single record as a form (see Section 7.3.1 – Form 

Layout); 

• Display Keypad/Dictionary Menu – toggles menu on or off; 

• Display/Hide fields – to choose which fields are to be displayed; 

• Restore Previous Field Display – to restore previous display of fields; 

• Core Photo Viewer – to display a separate window showing the core photo containing the 

currently selected unit. 
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7.5.1 Display Keypad/Dictionary Menu 

The Keypad/Dictionary Menu changes form depending on whether the current cell is numeric, 

alphanumeric that does not have dictionary lookups or alphanumeric that has dictionary lookups: 

 

 

 

When selecting a field that has dictionary lookups, the possible dictionary values for the field are 

displayed. If all the dictionary values for the field do not fit on the screen (for example, Lithology), the 

most recently used values are shown at the top of the list; the remaining values can be accessed by 

scrolling further down the list. For example: 

LithoType - 

recently used code 

list 

LithoType –       

full code list 

The current cell is Depth which is a 

numeric field.  

The current cell is SampNumb which 

is an alphanumeric field that does not 

have dictionary lookups. 

The current cell is Seam which is an 

alphanumeric field that has dictionary 

lookups. 
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The maximum size of the Recently used code list is initially set to 8 but the user can modify this size. 

This is may be useful if they find there generally more or less codes that they regularly use. 

The menu can be set to sit on the left or right hand side of the screen as if using a tablet, left-hand 

users generally prefer to have the menu on the left and right-hand users on the right so that their arms 

do not cover the data area of the screen. 

To select whether the menu is displayed on the left or right-hand side of the screen and the size of the 

recently used code list, select Settings > Options from the LogCheck menu and then the Editing tab: 

 

 

Display of the Keypad/Dictionary Menu for the LogCheck editor can be toggled on/off by clicking the 

Display Keypad/Dictionary Menu item in View menu (or F8): 
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7.5.2 Display/Hide Fields 

The Display/Hide Fields option (F3) of the View menu allows you to select the columns to be 

displayed in the Editor. Tick a column to display it or untick it to hide it. The Tick All button selects 

all columns for display; the Tick None button de-selects all columns. 

 

As the Sample Number, Seam and Ply are usually only filled in for coal seams, you may like to turn 

these off when not in a coal seam, so more of the fields are visible on the screen. 

7.5.3 Restore Previous Field Display 

The Restore Previous Fields option (Shift+F3) of the View menu allows you to restore the previously 

set columns. You can press Shift+F3 to cycle between two displays showing different columns. This is 

useful when moving between coal and non-coal lithologies. This will be greyed out if you haven’t 

made any changes to which fields are displayed since LogCheck was last reinstalled.  
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7.5.4 Core Photo Viewer 

The core photo viewer displays the core photo for the current row in the data: 

 

The Core Photo window and the editor are linked. On navigating the editor the photo will change to 

display the current interval. Clicking the back and forward arrows on the Core Photo window will 

change the photo to the previous and next photos going down the holes and the editor will 

automatically move to the interval in the newly displayed photo. 

Display of the Core Photo Viewer can be 

toggled on/off by clicking the Core Photo 

Viewer item in View menu: 
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The Core Photo Viewer option of the View menu can only be selected when editing Geology data and 

there exists core photos for the hole being edited in a folder named Photos in the LogCheck folder for 

the project. The photos can be .gif, .jpg, .jpeg, .png, .bmp. ico, .tif or .tiff files. In order to tie the photo 

files to the data, each photo files must be named with the name of the borehole as used in LogCheck, 

followed by an underscore, the photo’s top depth, a dash and finally the photo’s bottom depth. For 

example, the .jpg photo for depths 224.50 to 225.50 of hole DDH01 must be named DDH01_224.50-

335.50.jpg. 

LogCheck itself does not include a facility to assist in renaming files into this format but has a sister 

application called LogCheck – Core Photo Renamer available from the LogCheck distributor to assist 

in renaming core photos.  

The Core Photo Renamer first prompts the user to select the files they would like to rename, then 

displays the first and second photo in the sequence: 

 

Next, enter the borehole name and top and base depths for the first photo and the appropriate file name 

then appearts automatically in the New Filename box: 
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To accept the new name, click the accept button and the photos filename as shown above the photo is 

modified to the new name and coloured green: 

 

To navigate to the next photo in the sequence, click the right arrow button and the next photo is 

displayed in the centre of the screen and using the core length and base depth of the previous photo the 

depths are automatically set for the new photo and the appropriate New Filename displayed: 

 

If satisified with the suggested depths and filename, click again the Accept button. If not, modify the 

depths and/or filename and then click Accept or if not wanting to rename the photo just click the right 

arrow button. 

Once satisified with all the renaming select File > Save or Ctrl+S to save the filename changes.   
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7.6 Tools Menu 

The items in the Tools menu are: 

• Validate revalidate the currently open data 

• Compare compare the currently open data to another copy of the data to create a list 

of the differences between the two 

• Graphic Editor open the graphical editor for adjusting the geologist’s log to the geophysics 

• Sort sort the currently open data on user specified fields in the data 

• Filter filter the data based on a dBASE query (see Appendix B) 

• Column Statistics calculate and display the statistics for any user specified column in the data  

• Clear Work Files clear out the user’s and project’s work files 

Which of these can be selected depends on the type of data that is open in the editor: 

• Validate and Compare items can be selected when hole data or dictionaries are open 

• Graphic Editor can only be selected when Geology data is open  

• Sort and Filter items can be selected when audits or summaries are open  

• Column Statistics can be selected when any data type is open 

• Clear Work Files can only be selected when Project Details are open  
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7.6.1 Validate 

Validate checks all data that is currently open. It re-checks all codes against the current dictionary, 

plus all the checks normally performed before a save. Validate can operate on a single hole or across 

multiple holes. Running the Validate tool can be particularly useful after receiving data from another 

copy of LogCheck on another computer as: 

• The dictionary on the other computer may differ from that on the current one. Codes are only 

checked as they are entered and so even if the new data is modified and saved the codes in the 

data will not be rechecked against the current dictionary. 

• The optional validation settings on the current computer may differ to those on the computer 

from which the data was sources. For example, the optional validation that the total depth of 

the data must match that recorded in the header may be set to Ignore on the computer from 

which the data has come but set to Fatal on the current computer. 

• The data may have been recorded using an older version of LogCheck which did not have all 

the validation checks that have been included over time into the current version. 

It is prudent to open all holes and validate them before producing reports, plots or exporting them to 

another system, such as a modelling package. 

When Validate is selected, the popup window shown on the right 

requests where the errors are to be reported: 

 

 

 

When reporting to a 

file, a popup window 

requests a folder and 

file name for the errors: 

 

 

 

 

 

 

 

 

 

 

The default folder is the project’s Export folder and the default file name consists of the hole name, 

data type and the words Error Report. In the above example, the error file is: 

C:\LogData\AVOCA\Exports\AVC030C Error Report.txt 
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7.6.2 Compare 

The Compare tool compare another copy of the current data to another copy of the data – enabling you 

to see the differences between the two copies. You can compare individual files, dictionaries or all 

files in two specified directories. As with Validate, the output can be sent to Screen, Printer or File. 

 

In the following example, the Geology data for hole AVC030C has been opened in LogCheck and 

another copy of this data also exists, and it is desired to find out what, if any differences exist between 

the two. To compare the two files, select Tools > Compare, and then select the file that is to be 

compared with: 

 

 
 

 

Next, the popup window shown on the right requests where the 

differences are to be reported: 
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When reporting to a file, 

a popup window 

requests a folder and 

file name for the 

comparisons: 

 

 

 

 

 

 

 

The default folder is the project’s Export folder and the default file name consists of the hole name, 

data type and the words Comparisons. In the above example, the error file is: 

C:\LogData\AVOCA\Exports\AVC030C Comparisons.txt 

The resulting report for the above example: 

 

 
 

7.6.3 Graphical Editor 

The Graphical Editor is an optional component of LogCheck that allows graphical editing of the data. 

It allows the depths, lithology units, seams, plies and sample numbers to be edited. It is available from 

the distributors of LogCheck. 
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7.6.4 Sort 

Sort is only available when an audit, summary or statistics is open. They can be sorted by up to four 

variables. For example, the Seam summary is initially produced in Hole Name/Seam Floor Depth 

order but you may prefer it in Seam Name/Hole Name order. In the following Seam Summary 

example, select Tools > Sort from the LogCheck menu, and then the Select summary order popup 

window is displayed. In the drop-down list, select the required sort fields, as shown below, then click 

the OK button: 

 

 

The results being: 
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7.6.5 Filter 

Filter is only available when an audit, summary or statistics is open. A dBASE query must be entered 

for the filter. For more information on how to write these, see Appendix B. In the following Seam 

Summary example, select Tools > Filter from the LogCheck menu, and then the Filter Expression 

popup window is displayed: 

 

In the above example, the results will be filtered so that only records where the seam name is “MAU” 

and the thickness is greater than or equal to 1 metre are displayed: 

 

To clear the results of a filter, select Tools > Filter, and delete all text in the Filter Expression dialog. 

If a filter or sort has been applied to the data, the 

LogCheck menu shows a tick against the menu 

item, as shown on the Tools – Column Statistics 
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7.6.6 Column Statistics 

Selecting Column Statistics displays a summary of the data in a specified column. It can be used both 

raw and summary data.  

 

Firstly, the user is prompted for the column whose statistics 

are required: 

 

 

 

 

 

 

 

Where data contain multiple columns for the same variable, the statistics include all the columns in 

calculating statistics for the variable. For example, CoalLog Geology data has four columns for 

Adjectives (A1, A2, A3 and A4) and when calculating the statistics for Adjectives all four of these 

columns are included in the calculations.   

 

The results of Column Statistics are different for coded data and numeric data.  

 

For example, statistics on Lithotype (a coded variable) in the Geology data for AVO030C:  
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Whereas statistics on Seam Thickness (a numeric variable) in a Seam Summary which has been 

filtered on Seam = WK2: 

 

 
  

7.6.7 Clear Work Files 

LogCheck creates a numerous Work files that are preserved even after LogCheck has closed. These 

save information that LogCheck has calculated while accessing data and which it later uses say, when 

generating summaries. If these files do not exist and LogCheck requires them, it simply regenerates 

them but may take it some time. There are two folders where they are stored: 

• C:\Users\userName\AppData\Local\LogCheck\Work where userName is the name the user is 

signed onto the computer with. These files are work files specific to the user. 

• C:\LogData\projectName\Work where projectName is the name of a LogCheck project. These 

work files are specific to the project. 

Sometimes, say if LogCheck crashes while accessing work files, they may become corrupted. 

Additionally, every LogCheck dictionary has an index table to speed up dictionary lookups. These 

indexes may also become corrupted, again say, if LogCheck crashes while accessing them. Clear Work 

Files deletes all the files in both Work folders and also recreates the indexes for all the dictionaries it 

accesses for a project. 

If LogCheck is generating numerous program errors that do not normally occur, running Clear Work 

Files may fix the problem. In order though to run Clear Work Files, the user must first open the 

Project Details for the project whose Work files are to be cleared and whose dictionaries are to be 

reindexed. 
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Chapter 8  
Graphic Editor 

 

By the end of this chapter you will be able to: 

 

▪ Navigate the graphical editor form. 

▪ Modify hole data in the hole edit form. 

▪ Insert a unit in the log. 

▪ Replace (move) depths up or down the log. 

▪ Delete an interval. 

▪ Perform a thickness calculation. 

▪ Rename a lithology, seam, ply or sample number. 

▪ Expand/contract intervals. 

▪ Apply tielines to perform depth corrections. 

▪ Update any associated geotechnical data. 

▪ View and edit multiple holes on the one plot. 

▪ View a log of the edits that have so far been made. 

▪ Undo the edits done in the current session. 

▪ View/edit the dictionary. 

▪ View the available patterns. 

▪ Change options in the program. 

▪ Save the changes done in the current session. 

▪ View the current version of GeoEdit. 

▪ Maintain graphic editor definitions. 
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8.1 Introduction 

The Graphical Editor (GeoEdit) is used for graphically displaying hole data, and aligning depths of 

lithologies with the downhole geophysics. GeoEdit reads data from a hole log generated from 

LogCheck, and displays the lithology, seam, ply, sample number, mechanical state and geophysics in a 

graphical format. The main editing operations are: 

• Moving the depth of an interval(s) either further down or up the hole,  

• Inserting a new interval at the top, bottom or within an existing unit, 

• Expanding or contracting units, either by a single group or a set of tielines, 

• Renaming a lithology, seam, ply or sample number. 

 

It maintains a history of edits done during the current session, and allows you to undo each edit. This 

documentation is available on line by going to Help > Display Manual. GeoEdit also has options to 

view all the available patterns, the dictionary and a log of the original hole before any modifications in 

GeoEdit were made.  

For data formats that have defect data embedded with the geological data, a move, insert or 

expand/contract operation will also update the depths of any associated defect depths. 

Disclaimer: this appendix is a description of the functions of GeoEdit. The examples used are 

illustrative only and do not intend to explain the principles of depth adjustment of lithology boundaries 

from LAS data. 
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8.2 The Editor Form 

The editor form can be used to navigate the hole, insert intervals, adjust depths, and rename units. The 

plot includes the lithology, seam/ply, sample number, mechanical state and LAS lines. An example of a 

hole opened in GeoEdit, with the current lithological unit indicated by the magenta rectangle and the 

geophysical logs on the right, is shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

The menus that are available in GeoEdit: 

File Edit View Help 

  Save   Clear Depth Calcs   Log of Edits   About 

  Exit   Dictionary   View Tie Lines   Display Manual 

   Go To Depth   Zoom In   Display Patterns 

   Delete   Zoom Out  

   Insert Top   Options  

   Insert Within   

   Insert Bottom   

   Move   

   Replace   

   Undo Edit   

 Edit LAS Parms   

 

Ruler, Scale Depth and lithology  LAS plot Undo Lithology, Seam , Sample Nos. 

Mechanical 

state 
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The toolbar and the right-click popup menu provide access to the editing operations, as shown below: 

 

These operations have been given the same shortcuts that are available in LogCheck, and are: 

Operation Shortcut Description 

Exp/Cont Bottom  Expand/contract units in zone by adjusting the bottom boundary. 

Exp/Cont Bottom+Top  Expand/contract units in zone by adjusting the top and bottom boundary. 

GoTo Ctrl-G Move the plot window to a specified depth. 

Delete Ctrl-F7 Delete the current unit. 

Insert Top Ctrl-F5 Insert a unit at the top of the current unit – either above or inside it. 

Insert Within Ctrl-W Insert a unit within the current unit. 

Insert Bottom Ctrl-F6 Insert a unit at the top or bottom of the zone. 

Move Ctrl-M Move all unit(s) up/down the hole – either the entire unit or roof only. 

Rename Ctrl-R Rename a lithology or seam. 

TC  Display the thickness calculations (ruler) of two specified points. 

Tie Line  Prepare to set tielines for expansion or contraction. 

Undo Ctrl-Z Undo the most recent edit. 

 

The right-click popup menu is activated by right-clicking in the lithology column. Note that if the zone is 

not set, the zone operations are disabled, and vice versa. 

8.2.1 Navigating the Editor Form 

Navigation up and down the Editor form can be achieved with the: 

• GoTo button: Click this button and type the depth to move the plot window to; 

• Mouse wheel: Roll the mouse wheel to scroll up or down the plot. 

• Function keys: Use the function keys, as described in the following section. 

• ScrollBar: Use the mouse to scroll up or down the hole, or click in the bar, or the 

arrows at the top/bottom of the bar. 
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Selecting the GoTo button displays the following dialog: 

 

Enter the required depth, then click the OK button – 

GeoEdit then moves the hole log so that the specified 

depth is displayed at the top of the plot window. 

 

8.2.2 Using the Function Keys 

The function keys that are used in GeoEdit are as follows. 

•  Key: Moves the plot up incrementally. 

•  Key: Moves the plot down incrementally. 

• Ctrl + Keys: Zoom in. 

• Ctrl - Keys: Zoom out. 

• End Key: Moves the plot to the end of the hole. 

• Esc: Cancels the current operation; for example, setting the zone or when drawing 

a line (cursor becomes a +). 

• F5 Key: Refreshes the display of the plot. 

• Home Key: Moves the plot to the top of the hole. 

• PgDn Key: Moves the plot down a “page” at a time. 

• PgUp Key: Moves the plot up a “page” at a time. 

8.2.3 The Current Unit 

The current unit is a single unit that can be set by clicking inside a unit in the lithology column. This is 

indicated by a coloured rectangle that extends across the plot. 

8.2.4 Zooming 

The plot can be zoomed by pressing the Ctrl key and rotating the mouse wheel. The default zoom 

ratios available are 0.2, 0.5, 1.0, 2.0 and 3.0. The default is 1.0, where 1 m = 100 pixels of screen 

resolution. These values can be edited in the GeoEdit.ini file, as described at the end of this chapter. 
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8.3 The Edit Zone 

The Edit Zone is one or more currently selected units, and is indicated by a coloured rectangle (cyan, 

in the diagram below) – the top of the Edit Zone is the current unit. The Edit Zone is set by: 

• Selecting the top unit of the zone 

• Holding the shift key down and clicking a unit below (or above) the current unit. 

 

Some edit operations only take place within the bounds of the Edit Zone: these are Delete, Insert, 

Move, Replace and Adjust Bottom+Top. In these cases, adjustment of unit boundaries only takes place 

within the zone. The Edit Zone is shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

The Edit Zone can also be set by clicking in the seam, sample number or mechanical state columns. In 

this case, the only operation allowed is ‘move by dragging’. The Edit Zone can be unset by either 

pressing the Esc key, or clicking outside the zone.  

 

 

8.4 The Highlight Zone 

A yellow highlight zone consisting of a yellow-coloured rectangle extends across the plot, and 

highlights the extent of the current feature. For example, if the mouse is in the lithology column, then 

the extent of the lithology is highlighted. This applies to the lithology, seam, sample number, and 

mechanical state columns.  The Highlight Zone is set by moving the mouse over a column. The 

highlight zone is set independently of the Edit Zone. 
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8.5 Details Frame 

The details Frame is an independent window that sits on top of the GeoEdit display. For the currently 

selected zone, it displays a list of the lithologies within it and the core recovery data for that zone. It 

can be closed if required and re-activated from the View menu. An example is shown below: 
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8.6 Inserting Units 

A new unit can be inserted at: 

• The top, bottom, or within the Current Interval, or 

• The top or bottom unit within the Edit Zone. 

 

A new unit can be inserted in the current unit, or the edit zone. The thickness can be selected by 

pointing at the LAS lines, then refined by updating it in the Thickness field. The lithology can be 

selected from its dropdown box. The seam, ply and sample numbers of the new unit can also be 

entered. 

8.6.1 Inserting at the Top of the Current Interval 

The Insert Top operation allows you to insert a unit within the current unit, extending downwards from 

its top boundary. When a new unit is inserted at the top of the Current Interval, its From depth is moved 

down to make way for the inserted unit. For the To depth, it can be either: 

1) left unaltered (the default), or  

2) moved down, and move all underlying units down to the depth of a specified unit. 

8.6.1.1 Insert at Top and Inside Current Interval 

In the first of these two cases, to insert a new interval at the top and inside of the current unit, leaving its 

To depth unaltered: 

• Select the required unit (CG in this example), right click inside the lithology column, then select 

the Insert Top item on the popup menu.  

 

• Next, this dialog instructs you to indicate the new From depth of the top of the existing unit. 

 

Note: this dialog only appears if you have the Messages option selected. 
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• The cursor then changes from an arrow to a cross (+). At this point, the operation can be cancelled 

by pressing the Esc key. Click to the right of the blue geophysics line to indicate the new From 

depth of the top of the Current interval. GeoEdit draws a marker line from the existing From depth 

to the proposed new depth, as shown below. The Insert dialog is then displayed, as shown below. 

The dialog proposes to insert a new unit 0.20 m thick, BC, at the top of the existing CG unit 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The new unit (BC) is inserted at the top and inside of the current unit.  

A confirmation message is displayed, as follows: 

 

 

 

 The plot then appears as shown below: 

Note that the From depth of the underlying unit (CL) has not changed – the new unit displaced its 

thickness in the current zone. Note that any altered units have their lithology codes displayed in red. 

1. Leave the thickness if it is correct, otherwise type 

in a value. 

2. Select a lithology from the drop-down box. 

3. Click OK. 
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8.6.1.2 Insert at Top and Move Underlying Intervals Down 

In the second of these two cases, to insert a new interval at the top of the current unit and move all 

underlying units down to the depth of a specified unit (using the same interval as in the previous 

example): 

• Select the required unit (CG in this example), right click inside the lithology column, then select 

the Insert Top item on the popup menu.  

 

• Next, a dialog instructs you to indicate the new From depth of the top of the existing unit, by 

clicking at a point on a LAS line. 

 

• Click to the right of the blue geophysics line to indicate the new From depth of the top of the 

Current interval. GeoEdit draws a marker line from the existing From depth to the proposed new 

depth, as shown below. The Insert dialog is then displayed, as shown below. Click the ‘Depth to 

bottom of zone’ combo box, and select the required depth that the underlying units are to be 

moved down.  

 

 

 

 

 

 

 

 

 

 

 

• The dialog at right is then displayed. This shows that a new 

interval with lithology of BC 0.20 m in thickness, will be 

inserted at the top of the zone, and all units down to 203.00 

will be displaced downwards by 0.20 m. Note that the depth of 

the end of the hole cannot be altered in the Graphical Editor. 

 

 

 

 

 

1. Click the ‘Depth to bottom of zone’ combo box. 

2. Select a depth from the drop-down box – in this 

case the end of the hole has been selected. 

3. Click OK. 
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8.6.2 Inserting at the Bottom of the Current Interval 

When a new unit is inserted at the bottom of the Current Interval the To depth of this unit is moved up to 

make way for the inserted unit. To insert a new unit at the bottom of the Current Interval: 

• Select the required unit, then click the Insert Bottom item on the popup menu. You are then asked 

to indicate the new To depth of the bottom of the existing unit: 

• The cursor then changes from an arrow to a cross (+). At this point, the operation can be cancelled 

by pressing the Esc key. Click to the right of the blue geophysics line to indicate the new To depth 

of the bottom of the Current Interval. GeoEdit draws a marker line from the existing To depth to the 

proposed new depth. The Insert dialog is then displayed, as described in the previous section. 

 

8.6.3 Inserting Within the Current Interval 

When a new unit is inserted within the Current Interval, the new unit is inserted somewhere between the 

From and To depths of the Current Interval. The new unit can be inserted either: 

1) without displacing the From/To depths of the Current Interval (the default), or  

2) moving all underlying units down to the depth of a specified unit. 

8.6.3.1 Insert Within and Inside Current Interval 

When a new unit is inserted within and inside the Current Interval, the From depth and To depth of the 

Current Interval remain unaltered. To insert a new interval, such as a core loss within the current unit: 

• Select the required unit, then click the Insert Within 

item on the popup menu.  

 

 

 

 

 

 

 

 

 

 

 

 

 

• Firstly, the From depth of the new unit is 

set. If the Messages option is set, the 

Insert dialog on the right is displayed. The 

cursor then changes from an arrow to a 

cross (+). Click to the right of the blue 

geophysics line to indicate the new From depth of the unit to be inserted. 

 

 

 

• After setting the From depth by clicking at the 

required point on the LAS lines, the bottom (To 

depth) of the new interval is then set.      
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• GeoEdit draws lines to the proposed new From/To depths, as shown below and displays the Insert 

dialog:  

 

 

 

• If the OK button in the dialog above is clicked, the result of inserting the BC within the CL unit is 

shown below with a confirmation dialog is displayed: 

 

 

 
 

 

1. Leave the thickness if it is correct, otherwise type 

in a value. 

2. Select a lithology from the drop-down box. 

3. Click OK 
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8.6.3.2 Insert Within Current Interval and Move Underlying Units Down 

When a new unit is inserted within the Current Interval, the From depth and To depth of the Current 

Interval remain unaltered. To insert a new interval, such as a core loss within the current unit: 

• Select the required unit, then click the Insert Within 

item on the popup menu.  

 

 

 

 

 

 

 

 

 

 

 

 

 

• Firstly, the From depth of the new unit is 

set. If the Messages option is set, the 

Insert dialog on the right is displayed. The 

cursor then changes from an arrow to a 

cross (+). Click to the right of the blue 

geophysics line to indicate the new From depth of the unit to be inserted. 

 

 

 

• After setting the From depth by clicking at the 

required point on the LAS lines, the bottom (To 

depth) of the new interval is then set.     

•  GeoEdit draws lines to the proposed new 

From/To depths, as shown below and displays 

the Insert dialog.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

1. Click the ‘Depth to bottom of zone’ drop-down 

box. 

2. Select a depth from the drop-down box – in this 

case the end of the hole has been selected. 

3. Click OK. 
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• If the OK button in the dialog above is clicked, the result of inserting the BS within the CL unit is 

shown below. Note that the combined thickness of the two CL units is the same as the original CL 

unit, and all units down to the end of the hole have been moved downwards, with the roof of the last 

unit being moved down to accommodate the inserted unit. 

 

 

 
 

 

8.6.4 Inserting in the Edit Zone 

A new unit can be inserted at the top or bottom of the Edit Zone. When inserting a new unit at the top 

of the Edit Zone, all underlying units down to the bottom of the Edit Zone are moved down to 

accommodate the new unit. To insert a new unit into the top of the Edit Zone: 

• Define the Edit Zone, as described previously and click the Insert Top item. 

 

• Click in the region to the right of the blue geophysics line to indicate the new From depth. The 

following dialog is displayed. Select the required lithology and thickness of the new unit, as 

shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The Edit 

Zone goes 

from 4.0 – 

7.0 m 
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• The following dialog is displayed, confirming the results of the operation: 

 

 

 

 

 

After clicking OK, the results of the Insert Zone operation are as shown below: 

 

 

 

 

 

 

 

 

 

In the above example, the inserted unit (MS) has been inserted at the top of the S6 unit. The thickness 

of the S6 and LS2 units remain unchanged, although their boundary depths have been moved down by 

40 cm. The thickness of the unit (MS) at the bottom of the edit zone has been reduced by 40 cm and its 

From depth is lowered by 40 cm, but its To depth remains the same. 
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8.7 Deleting Units 

The Current Interval can be deleted – in this case, the underlying unit 

is moved up to replace the deleted unit. To delete a unit: 

• Select the required unit (CG in this example), right click inside 

the lithology column, then select the Delete item on the popup 

menu.  

 

 

 

 

 

• You are then asked to confirm the deletion: 

 

 

 

 

 

 

 

 

• The underlying CL unit moves up to fill the gap left by the 

deleted unit. 
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8.8 Moving Depths 

The Move Depth operation  (in the LogCheck editor, this is equivalent to the Replace command) 

allows you to move the Edit Zone up or down the hole, by either selecting the Move item from the 

popup menu, or dragging the selected unit(s). When a unit(s) is/are moved, either the unit(s) is/are 

moved entirely (unit fixed), and the units above and below are lengthened/shortened, or the roof is 

fixed and the floor is moved (floor only moved). This is determined by: 

• Options:  In View/Options the default option of Floor Only or Unit Fixed can be 

selected. 

• Replace Form:   For each individual move operation, when the Move/Replace form is 

displayed, 

  Roof Fixed or Unit Fixed buttons can be selected to override the default 

option. 

• Dragging:   If the Control key is held down while dragging, only the floor is moved, and 

  the roof remains fixed – this overrides the default behaviour. 

 

8.8.1 Moving the Current Unit 

For the Move operation, when applied to the current unit, there are two choices: 

1. Move the entire unit, or 

2. Move only the floor of the current unit, by leaving the roof fixed. 

 

The following example demonstrates the first choice. To move the current interval up/down, right 

click the lithology column and select the Move item from the popup menu. In the example shown 

below, CL is the current unit. 

The cursor then changes from an arrow to a cross (+). At this point, the operation can be cancelled by 

pressing the Esc key. After clicking on the required depth in the geophysics, a line is drawn to indicate 

the changes that will be made, and the following dialog is displayed: 

 

An ‘x’ marks the depth where 

the user has clicked that the 

floor is to be moved. The line is 

drawn to the ‘x’ to indicate 

where the floor will be moved. 

The roof is fixed, so only the 

floor will be moved, in this case 

by -0.21 m.  



CHAPTER 8. GRAPHIC EDITOR 

 174  LogCheck Manual 

After clicking the Move button, the display of the log is updated and a confirmation message is 

displayed:  

 

Notice that the floor of the CL unit has been moved up 0.21m. The unit below it (SA) has had its From 

depth moved up to 3.79 m and its thickness increased by 0.21 m. 

Note: if moving the boundary up the hole, you can’t move the boundary by an amount that exceeds the 

thickness of the overlying unit and if moving the boundary down the hole, it can’t be moved more than 

the thickness of the current interval. 

8.8.2 Extending the Range of the Move 

The To depth of the move operation can be increased by clicking in the To Interval Base Depth combo 

box, and selecting one of the available intervals. In this case, all depths down to the specified interval 

will be moved; this allows you to move all depths down to the bottom of the hole, as can be done in 

the LogCheck editor. The depth required can be selected from the drop-down box as shown below:: 

 

 

 

 

 

 

 

 

 

 

The Move can be 

extended by selecting a 

depth from the combo 

box 
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8.8.3 Moving the Edit Zone 

The depths of all units that have been defined in the Edit Zone can be moved up or down the hole in 

the one operation. To move all units in the Edit Zone: 

• Define the Edit Zone, as described previously. 

• Right click the lithology column and select the Move item from the popup menu: 

• The cursor then changes from an arrow to a cross (+). At this point, the operation can be cancelled 

by pressing the Esc key. After clicking on the required depth in the geophysics plot, a line is 

drawn from the top (From) of the Edit Zone to that depth to indicate the changes that will be 

made.  

• Then a dialog requesting the amount to replace depths with is displayed. 

 

After clicking the Move button, operation is completed and a confirmation message is then displayed: 

8.8.4 Moving and Deleting 

When moving the floor of the Edit Zone, if the thickness of the requested move equals the thickness of 

the unit at the opposite end of the zone, you are asked if you want to delete it.  

8.8.5 Moving by Dragging 

The current unit, or the edit zone, if it is defined, can be moved by dragging with the mouse. This can be 

done by clicking within the lithology column, holding the left mouse button down, and dragging up or 

down to the required depth, and releasing the mouse button. This method is much simpler – no lines are 

drawn to the LAS region and only a confirmation dialog is displayed.  

Note: when moving the current unit by dragging, only the roof is moved, however when dragging the edit 

zone, the roof and floor of the edit zone are moved. 
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8.9 Setting Tielines 

Tielines can be set by clicking the TieLine button on the GeoEdit toolbar. When in tieline state, the 

button turns red, and the caption changes to Adjust. To start setting tielines click the TieLine button, 

then: 

1. Set the start of the first tieline by clicking a lithology unit. The start of a tieline is always the 

top of the currently selected unit. 

2. Click the Adjust button. The cursor then changes to a thin crosshair cursor, which 

indicates that GeoEdit is ready to set an endpoint in the LAS region. 

3. Set the end of the tieline by clicking at a relevant point on a LAS line. This draws 

the line and the cursor then changes to the move cursor (a thick cross with 

directional arrows). 

4. Click on a unit in the lithology column to set the start of another line. 

5. Repeat steps 3-4 until all tielines are set. 

6. When all tielines have been set, to adjust the tielines, click the Adjust button again – this then 

adjusts all units within the tielines to the depth indicated on the LAS lines. 

 

 

 

 

 

 

 

 

 

 

 

 

4. The cursor  indicates 

that  the start of another 

tieline can be set. 

1. Select the first lithology unit. 

2. Click TieLine/Adjust button. 

3. Set tieline end in LAS 
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This figure shows three tielines that have been set: 

 

 

 

 

 

 

 

 

 

 

 

To complete the process, click the Adjust button – a 

dialog confirming whether to proceed or not is 

displayed. Clicking the Yes button adjusts units 

within each set of tielines to match the depths set in 

the LAS region. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The adjustment process uses the same method to adjust the depths as that outlined in the 

Expand/Contract section of this chapter. 
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8.10 Moving Tielines 

After a tieline has been set, the LAS endpoint can be moved up or down the plot before the final 

adjustment. Place the cursor inside the box that marks the endpoint.  The cursor then changes to a hand 

cursor and the point can then be dragged to the required location: 

 

 

 

 

After moving tielines, the plot can be refreshed by pressing the F5 function key. All tielines can be 

cleared and the operation cancelled by pressing the “Esc” key, or pressing Ctrl+K. 

8.11 Automated TieLines 

LogCheck can send a list of tielines that are calculated on the slopes of the LAS lines to GeoEdit. 

When it is initially invoked, the following dialog allows the tielines to be accepted or not. Clicking the 

Adjust button then attempts to perform the selected depth adjustments. 

When inside the endpoint, it 

can be moved up or down the 

plot. 
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8.12 Thickness Calculations – Using the Ruler 

Thickness calculations can be made by clicking the Ruler (TC) button on the toolbar. The 

first endpoint is set by clicking on the plot to the right of the blue geophysics line, then 

clicking at the other endpoint. A ruler is drawn on the plot that represents the thickness of 

the line; it displays the start, midpoint and end depths. Multiple calculations can be 

performed; they can be cleared by pressing the Control+K key combination. Two examples 

are shown below: 

 

 

 

 

 

 

8.13 Renaming a Lithology/Seam 

The rename operation has three contexts: 

1. Rename the current interval – the lithology, seam, ply and sample number can be edited. 

2. Rename a seam when the mouse is in the seam column – this affects all lithology units with 

that seam name. Only the seam name is edited. 

3. Rename when the edit zone is set – renames all seams or no seams to the one seam name 

defined by the edit zone. 

 

 

8.13.1 Renaming the Current Interval 

Renaming the current interval allows the lithology, seam, 

ply and sample number to be edited. In the following 

example, the lithology of the current unit (ST) is to be 

renamed. Right-click the lithology column somewhere in 

ST, and select Rename Interval from the popup menu. 

The existing lithology and seam are displayed, and a drop-

down list box provides the lithology codes available in the 

LogCheck dictionary, that the existing code can be renamed 

to. In this example, ST is to be changed to S1. Clicking OK 

will update the log; clicking Cancel leaves the existing code 

unchanged.  
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The updated log is shown on the right. 

Note that if a lithology unit does not 

have a seam, one can be applied in this 

dialog. When an interbedded unit is 

renamed, any interbedded units can be 

merged into a single unit, or left as 

interbedded units, where only the first 

lithology is renamed (the other 

lithologies can be renamed in 

LogCheck). 

8.13.2 Renaming an Entire Seam 

An entire seam can be renamed – in the previous section, only a lithology and its associated seam 

could be renamed. To rename an entire seam, right click in the seam column, and select the Rename 

Seam item: 

 

In the Rename dialog shown on the right, enter the new seam name (for example, G) in the Seam list 

box: 

 

After clicking the OK button all lithology units have their seam name updated from H to G. 
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8.13.3 Renaming all Seams within the Edit Zone 

By selecting an edit zone, all seams, as well as units with no seam within the edit zone can be renamed 

to the same name. In the example below, the edit zone extends from the roof of the WK2L seam to the 

base of the WK3 seam, as shown in the figure on the left. Right-clicking in the lithology column, then 

selecting Rename Seam from the popup menu, and changing the seam name to WK2U results in the 

figure on the right: 

 

  

The Edit 

Zone  
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8.14 Expanding/Contracting Units 

Units in the Edit Zone can be expanded or contracted by the same algorithm that is used in the 

LogCheck editor. These edits are better suited to non-core sampled holes. The choices are: 

• Adjust Zone Bottom: Expand/contract all units in zone by adjusting the bottom boundary. 

• Adjust Zone Bottom+Top: Expand/contract all units in zone by adjusting the top and bottom 

boundary. 

 

In both cases, you draw a line to the geophysics plot that indicates how far you want the interval to be 

moved. 

8.14.1 Expanding/Contracting the Edit Zone Bottom 

To expand/contract all units in the Edit Zone by adjusting the bottom boundary: 

• Define the Edit Zone, as described previously. 

• Click the Adjust Zone Bottom item from the right click 

popup menu. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• If the Messages option is checked, the 

following message is displayed: 

 

 

 

• The cursor then changes from an arrow to a cross (+). After clicking on the required depth on the 

blue geophysics line, a line is drawn from the top (From) of the Edit Zone to the depth on the 

geophysics line to indicate the changes that will be made.  
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• Then a dialog requesting the amount to expand / contract depths by. In this example, the Edit Zone 

extends from 2.0-5.0m. The From depth of 2.0m will be unaltered; the remaining intervals will be 

proportionately compressed, and the To depth of the unit at the bottom of the zone will be raised 

by 0.2m to 4.8m: 

 

 

 

 

 

 

 

 

 

 

A confirmation message is displayed – the results of this edit are shown below: 
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8.14.2 Expanding/Contracting the Edit Zone Bottom+Top 

Units can be expanded/contracted from both the top and bottom unit of the Edit Zone in the one 

operation. To expand/contract all units in the Edit Zone by adjusting the bottom and top boundaries: 

• Define the Edit Zone, as described previously. 

• Select the Adjust Zone Bottom+Top item from the popup menu,: 

 

 

 

 

 

 

 

 

• If the Messages option is checked, 

the following message is displayed 

to remind the user to set the To 

depth of the bottom unit: 

 

 

• After the bottom line is set, if the Messages 

option is checked, the following message is 

displayed, to remind the user to set the From 

depth of the top unit: 

 

• After the two lines are drawn the following dialog is displayed, that requests the new From depth 

of the top of the zone, and the new To depth of the bottom of the zone. Click the Adjust button to 

complete the operation: 
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• The results of this operation are to move the From depth of the top of the zone down to 2.20m and 

move the To depth of the base of the unit up by 0.2m, and proportionately compress the units in 

between, as shown below. Then a confirmation message is displayed: 

 

 

 

 

 

 

 

 

 

The dashed grey lines are retained to indicate the amount of the adjustment. 

8.14.3 Validation 

The following validations are applied when replacing depths: 

(a) The first (top) interval in a hole can’t be replaced. 

(b) The replace operation will not proceed if the required thickness to be adjusted is greater than 

the thickness of the bottom unit in the edit zone. 
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8.15 Updating Defects 

Where geotechnical data (RMUs and defects) is present for a hole, the GeoEdit will attempt to update 

any changes in the depths of lithology units with corresponding depths of the geotechnical data, where 

appropriate. On saving and returning to LogCheck, any changes will also be made in the LogCheck 

data file for that hole. The figures shown below are artificially composed to illustrate the main points. 

8.15.1 Moves 

The depths of any corresponding geotechnical data are moved proportionately with the movements of 

the lithology units. The figure below shows the CL unit and its associated defects before the move: 

 

 

 

 

 

The figure below shows the CL unit after it has been moved down 20 cm. The RMU D1 has also been 

moved down, and RMU C and D2 adjusted proportionately: 

 

 

 

8.15.2 Inserts 

If a lithology is inserted into the current unit or zone, the position of geotechnical data is preserved, 

unless it is a core loss. Where a core loss is inserted: 

a) Inserting at top of Current Interval: the RMU depths are preserved, however any defects 

are moved proportionately down the hole so that they don’t coincide with the core loss. 

The figure below shows the BR unit and its associated defects before the insertion: 
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The figure below shows the BR unit after the insertion of a core loss. Defects BP and FT have 

been moved down proportionately: 

 

 

b) Inserting at bottom of Current Interval: the RMU depths are preserved, however any 

defects are moved proportionately up the hole so that they don’t coincide with the core 

loss. 

c) Where RMU boundaries do not correspond to the roof/floor of a lithology, the defects are 

not adjusted. 

8.15.3 Expand/Contract Operations 

The depths of any corresponding geotechnical data are adjusted proportionately with the 

expansion/contraction of the lithology units. The figure below shows the units CL – FK and their 

associated defects before the contraction: 

 

 

 

 

 

 

 

The figure below shows the units CL – FK after the contraction. The geotechnical data has been 

adjusted proportionately:  

 

 

 

 

 

 

8.15.4 Delete 

Where a lithology unit is deleted, any geotechnical data will remain unaltered. 
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8.16 Displaying Multiple Holes 

Multiple holes can be displayed in GeoEdit.  Up to six holes can be displayed in the same frame, as 

shown below:  

 

It is necessary to select the holes in LogCheck before entering GeoEdit. Each hole can be scrolled 

independently of the other holes. Note that it is not a geological cross section. Additional options are 

added to the View menu that allow the holes to be: 

• Aligned along the current depth. 

• Aligned with the current unit and 

• Aligned with a selected seam. 

 

 

8.17 The View Menu 

The View menu  contains the following items:  

• Log of Edits: Displays sequence of edits in the current session; 

• View Tie Lines: Displays a copy of the original hole before any edits were made in 

GeoEdit; this is useful for comparing the original hole with the edited 

version 

• View Patterns: View the available lithology patterns; 

• Options: Displays GeoEdit options; 
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8.18 View the Log of Edits 

GeoEdit keeps track of every edit operation that you make. An example of the log of edits form is 

shown below. The edits are arranged chronologically:  

 

 

 

 

When undoing an edit, it is always the last edit that is undone.  In addition to this summary log, as 

each hole is saved, a text file is generated that records the alterations that were done to a hole. The file 

is saved as a CSV file in the Work folder under the project name, for example for a project named 

Training, it is saved to C:\LogData\Training\Work, and the format of the file name is 

EditLog_HoleName.csv. For example, the following diagram shows log files for DDH001, DDH002, 

DDH004, DDH005 and DDH009: 

 

The log file for hole, being saved in CSV format can be opened in any text editor, or Microsoft Excel. 

For example for  EditLog_DDH009 when opened in Excel is: 
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The columns in this are: 

• Hole:  The hole number. 

• Date:  The date the edit was saved. 

• Time:  The time the edit was saved. 

• No.: A sequence number for a particular session. 

• From: The from depth that the operation started. 

• To: The to depth that the operation ended. 

• Operation: The type of operation, for example, move, rename, insert or adjust. 

• Description: The description of the operation. 

• Seq.: For a given operation, a sequence number that is the count of intervals affected 

by that operation. 

• Lith: The lithology of the unit. 

• Old From: The from depth before the operation took place. 

• Old To: The to depth before the operation took place. 

 

 

8.19 Undoing Edits 

Each edit that is done is recorded in a list. Edits can be undone one edit at a time, starting with the 

most recent edit, and working backwards in the list by either: 

• Clicking the Undo button on the Toolbar, or 

• Pressing the Ctrl+Z key combination. 

 

Confirmation of the action is requested before GeoEdit proceeds with the undo. 
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8.20 View/Edit a Dictionary 

To view or edit the colours in the Lithology Dictionary, go to the Edit > Dictionary menu. The colours 

are the ones that were entered in the LogCheck dictionary. The lithology dictionary is as shown below 

on the left. A colour can be changed by the following steps: 

Dictionary Colour Editor Form AutoCAD Colours Form 

1. Double-clicking in the Colour column.   

 2. This brings up an AutoCAD colour 

palette (shown below) from which an 

AutoCAD colour can be selected by 

clicking on a colour with the mouse, or 

typing a number in the Colour Number 

field. 

3. Click the OK button 

4. Click the Save button  

 

Any changes to the colours are not (yet) updated in the LogCheck dictionary. 
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8.21 Viewing the Patterns  

To view the available lithology patterns, go to the View > View Patterns menu, as shown below: 
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8.22 GeoEdit Options 

The GeoEdit options can be accessed from 

the View > Options menu. The options 

available in GeoEdit are:  

• Plot Scales, 

• Highlight Colour, 

• Background, 

• Use Patterns, 

• Use Messages, 

• Full Toolbars, 

• Solid Core, 

• Move Default. 

 

8.22.1 Plot Scales  

Various sets of plot scales are available, as shown on the right. After a plot scale 

is selected, the changes don’t take place until the Graphic Editor is re-started. If 

long holes cause an out-of-memory error, it will be necessary to choose the 

bottom set of three scales (it may be necessary to open a shorter hole first, select 

the set of three scales, exit the Graphic Editor, then open the long hole). 

8.22.2  Highlight Colour 

Selecting this option allows you to specify the colour of the rectangle that highlights the currently 

selected unit, by displaying the Autocad colour palette from which the desired colour can be selected. 

8.22.3 Background Colour 

The plot background can be altered between a 

white background and a black background. Go to 

the View > Options menu, and select either the 

black or the white option.  

 

 

 

 

 

8.22.4 Use Patterns 

The display of the lithology units can be altered between colours and patterns, which are determined 

by the LogCheck dictionary. Go to the View > Options menu, and tick the Use Patterns checkbox to 
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display the lithology as a pattern. Mostly, you will want this feature checked – especially if not all 

lithologies have been allocated a colour. 

8.22.5 Use Messages Option 

If the Use Messages option is checked, then additional help dialogs and confirmation messages are 

displayed. This is useful for users who are new to using GeoEdit. However as a user gains more 

editing proficiency, unchecking this option improves the performance and efficiency of editing.  

8.22.6 Full Toolbars Option 

Checking this option enables the display of the full toolbar menu – changes to this option don’t take 

effect until you re-open GeoEdit. Usually, the right-click popup menu provides faster access to the 

editing commands. 

8.22.7 Solid Core Option 

Any lithology units that have a Mechanical State code that matches one of the codes entered here as 

being solid core, will remain unaffected as a result of an expansion/contraction or insertion operation. 

Also, if a move is attempted that involves an overlying or underlying unit that matches a solid core 

code, the move is not allowed. 

8.22.8 Move Default 

The default move operation can be set be selecting either Base Only or Entire Unit. This default can be 

overridden in the Move unit dialog (see Section 3.8).  

8.23 Data Input 

GeoEdit reads the geology, geophysics, parameters and dictionary data that is output from the 

LogCheck editor. The files are: 

• Fills: GraphicEditorFills.csv 

• Geology: GraphicEditorGeology.csv 

• Geophysics: GraphicEditorLasData.csv 

• Parameters: GraphicEditorParameters.csv 

• Patterns: GraphicEditorPatterns.csv 

• Dictionary: GraphicEditorLithologyDictionary.csv 

. 

To obtain a meaningful LAS plot, the LAS parameters need to be set in LogCheck before invoking 

GeoEdit. 
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8.24 Saving Your Data 

Changes made during the current session can be saved. Go to File > Save. This data is then imported 

back into LogCheck. Also, a log of all the edits performed on a hole are saved in a text file, that is 

located in the Work folder of the current project. 

The file is named as: EditLog_HoleName.csv, for example, EditLog_MO11-67.csv, as shown below: 

8.25 Zooming Your Plot  

The plot can be zoomed in or out by holding the Ctrl key and rotating the mouse wheel, or the Ctrl+ or 

Ctrl- keyboard combinations to zoom in/out. Each click of the wheel moves to the next scale. The scales 

at which the plot is displayed can be specified by the user either by selecting one of the sets from View 

> Options, or edit the applications initialisation file. To do this, make sure you are not in GeoEdit, then 

go to: 

            C:\ProgramData\Logcheck\Work  

and edit the GeoEdit.ini file in Notepad. Something like the following will be displayed: 

#Mon Nov 28 13:56:54 EST 2011 

patterns=yes 
messages=no 

toolbars=no 

scales=0.2, 0.5, 1.0, 2.0, 3.0 
invert=no 

 

You can alter any of the 5 scales – for now GeoEdit expects 5 values separated by commas. For 

example, to make the last scale bigger, you could alter the 5th line to: 

scales=0.2, 0.5, 1.0, 2.0, 4.0 

You will only see the 5th line, if you have already run GeoEdit at least once. If it is not there, you can 

add it in. If you make any changes to it, they will only take place the next time you run GeoEdit. 
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8.26 The About Box 

The About box is available 

from the Help menu. It 

displays the product name and 

version number and build 

date.  

 

 

 

 

 

 

8.27 Displaying the Manual 

This documentation can be viewed as a PDF file by selecting the Display Manual item from the Help 

menu. 
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8.28 Graphic Editor Definitions 

A Graphical Editor Definition file 

determines which LAS lines will be 

displayed in GeoEdit. Before GeoEdit 

will run, it is necessary to define at least 

one Graphical Editor Definition (GED) 

file in LogCheck. To create a new GED, 

go to the File > New > Graphical Editor 

Definition menu item; then give it a 

name in the following dialog:  

 

The following form is then displayed: 

 

 

 

 

 

 

 

 

 

 

For each LAS line, the columns to be completed are: 

• Variable: The name of the LAS line to be plotted. 

• Column: Whether the line is to be displayed in the left or right area of the plot. 

• LeftEdge: The minimum value of a variable to be displayed on the left hand axis of the plot. 

• RightEdge: The maximum value to be displayed on the right axis of the plot.  

• Colour: The AutoCAD colour number for the LAS line. 

 

Note that the minimum/maximum values can be reversed for the LeftEdge/RightEdge. A completed 

example is shown below:  
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An existing GED can be viewed or updated by going to File > Open > Graphical Editor Definition. 

To determine the settings for a GED, the maximum and minimum values can be determined from the 

LAS statistics option in LogCheck (see Section 8.4.2 – Las Variable Statistics).  

8.29 Updating LAS Parameters within GeoEdit 

The scale of the LAS parameters can be modified from within GeoEdit. From the main menu, select 

the Edit /Edit LAS Parameters item to display the following dialog: 

 

Select the required LAS variable 

from the dropdown box. It displays 

the current values, and then the 

maximum and minimum values 

encountered in the data, and suggests 

these as the new values. Enter the 

required values, then select OK, or 

Cancel to exit without modifying the 

LAS plot scales. 
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8.30 Graphic Editor Fails to Launch 

If the Graphic Editor fails to launch, the most likely possibilities are: 

• The Java Runtime is not installed on your computer – see Chapter 2 of the LogCheck User Manual 

for further instructions. 

• If the Java Runtime has been installed, you need to add a JAR file association. 

 

If you have Java installed on your system, but the file association is not working, continue with the 

following steps for adding the JAR file association on Microsoft 

1. Choose Start > Control Panel. 

2. Click Default Programs and select Associate a file type or protocol with a program.  

3. In the 

Registered File 

Types list, 

select the .jar 

extension 

(Executable 

JAR File). 

 

Click the 

Change 

Program 

button. 

 

 

 

 

 

 

 

 

4. In the Open With dialog 

box, select Java Platform 

SE Binary. 

5. Click OK to exit the Open 

With dialog box.  Click 

Close to exit the Associate 

a file type or protocol. 
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Chapter 9  
Audits, Summaries and Statistics 

 

 

 

By the end of this chapter you will be able to: 

 

▪ Audit LogCheck data. 

▪ Summarise LogCheck data. 

▪ View statistics for coded data and LAS variables. 
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9.1 Introduction 

Audits of drill holes are performed to verify the consistency and accuracy of the data, as opposed to 

Summaries, which are usually for reporting or exporting information to other software. 

The audits, summaries and statistics available in LogCheck are: 

Audits Summaries Statistics 

• Dictionaries 

• Codes 

• Holes 

• Drilling 

• Coded Data Frequencies 

• Interval Thickness Statistics 

• Projects 

• Holes 

• Uncorrelated Coals 

• Seam/Horizon Picks 

• Seams/Plies 

• Samples 

• LAS Variables 

• Unsampled Coals   

• Unsampled Seams   

• Horizons   

• Strats   

• Seams   

• Plies   

• LAS files 

 

  

9.2 Audits 

To open an audit select File > Open > Audit from the LogCheck menu: 
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9.2.1 Dictionary Audit 

The Dictionary Audit analyses a selected dictionary and determines how many times a code has been 

used in a selected dataset in a project. A dictionary audit is useful when cleaning up dictionaries as 

you can see if a code has been used at all, before deleting it. 

LogCheck only checks that an entered code is in the current dictionary when it is actually entered or if 

the Tools > Validate is selected from the LogCheck menu (see Section 7.6.1 Validate for more 

information). It is therefore possible for there to be codes in the data that are not in the current 

dictionary. This can occur for a couple of reasons: 

• The code has been deleted from the dictionary after it has been entered. 

• The data files have been copied directly from LogCheck on another computer whose 

dictionary is different from that on the current computer. 

In this case, the code will be included in the audit but will display “MISSING FROM DICTIONARY” 

in the Desc column. 

To create a Dictionary Audit, select Files > Open > Audit > Dictionary, Next, LogCheck prompts for 

the dictionary and category within this dictionary to audit: 

In this example, the Colour 

category has been selected for the 

Geology dictionary in the 

Dictionaries folder, sorted by 

code: 

 

 

 

 

 

 

 

 

 

 

Then select the required holes and intervals from the standard hole selection popup window. 
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The audit of the Colour dictionary for 

the selected holes and intervals is then 

displayed: 

 

 

 

 

 

 

 

 

 

This includes the fields: 

• Code Dictionary code 

• No_Used Number of times the code was used 

• First_Hole First hole in the list of holes where the code occurs 

• Last_Hole Last hole in the list of holes where the code occurs 

• Desc Description for this code 

 

In the above example, the colour orange appears 7 times in the hole logs, with the first occurrence in 

hole AVC031C and the last occurrence in AVC038. One can further “drill down” into this information 

by doing a code audit (see next section), which will display where selected codes have been used in 

selected group of holes. 
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9.2.2 Codes Audit 

A Codes Audit displays where a particular dictionary code has been used in a selected group of holes.  

To create a Codes Audit, select Files > Open > Audit > Codes from the LogCheck menu, then select 

the required holes and intervals to be searched from the standard hole selection popup window. 

Then from the popup window shown on the right select the 

category of the required code(s), and then select the required 

code(s):  

 

Note that more than one code can be selected using the Shift 

and Ctrl keys. 

 

 

 

 

 

In the previous Dictionary Audit section, it was 

determined that there were 7 instances of Colour orange. 

To find where they occur, select Geology and All Holes, 

and then with category of Colour and code O (orange), 

and the audit displays the 7 occurrences of orange in the 

project: 

 

 

 

 

This includes the fields: 

• Hole Hole name of hole where the code occurs 

• From From depth of the unit where the code occurs 

• To To depth of the unit where the code occurs 

• Variable Name of variable where the code occurs. With most categories they apply to 

only a single variable but categories such as Lithological Adjective apply to 

multiple variables.   

• Code The found code. This is only relevant where the user has selected more than one 

code to be search for. 
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9.2.3 Projects Audit 

A Projects Audit displays a list of all projects on your computer.  If you have a number of copies of 

LogCheck on your computer for handling different data formats, it only displays the projects for the 

version that you are currently using. It displays for each Data Type the number of holes stored on the 

computer for the project and for each Definition Type the number of definitions stored on the computer 

for the project.   

Project audits are useful to quickly see if you have the same number of holes for each Data Type and that 

these match the number of holes that were drilled. 

To create a Projects Audit, select Files > Open > Audit > Projects from the LogCheck menu. An example 

Project Audit is shown below, Due to the large number of columns, the display has been divided up into 

three figures: 
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9.2.4 Holes Audit 

The Holes Audit displays the total depth in each data type’s data for the selected drill holes. It enables 

you to detect any types of data for a specific hole that were only partially entered or not entered at all. 

For example, the top part of a hole may have been entered but the lower part, which was recorded on a 

different day or by a different geologist may have accidentally not been.  

To create a Holes Audit, select Files > Open > Audit > Holes from the LogCheck menu, then select the 

required holes and intervals to be searched from the standard hole selection popup window. 

The results of a Holes Audit are: 

 

Hole AVC031C has no entry for the Headers column telling the user that no Header data has been 

entered for this hole whereas Hole AVC032 has an entry of 0.0 telling the user that Header data has 

been entered for this hole but no Total Depth was entered in the Header. 

Some observations that can be made from this audit include: 

• The Coal Quality column is entirely empty indication that no Coal Quality has been entered 

for any of the holes.  

• Hole AVC030C has a total depth of 303.80 in the Header and Drilling data but only 300.86 in 

the Geology data suggesting that the Geology for the last 2.94 metres of the hole was either 

not recorded or not entered into LogCheck.  

• The Las data for hole AVC030C goes to 318.00m which is 14.2m past the end of the drilling 

as shown in the Drilling column! This would be an issue that should be investigated. 

• The last Point Load base depth for holes AVC030C and AVC031C is 303.08m for both holes, 

suggesting that possibly the Point Load data entered for the two holes is actually only the 

Point Load data for one of the holes and has been accidently entered into the system for the 

other.  
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9.2.5 Uncorrelated Coals Audit 

The Uncorrelated Coals Audit analyses each the selected holes and intervals and shows the top and 

bottom depth of each seam and any instances of coal that occurs outside these seams. The audit also 

shows the thickness of these coals and the percentage of the units that are coal, so that you can 

determine how significant they are. 

To create an Uncorrelated Coals Audit, select Files > Open > Audit > Uncorrelated Coals from the 

LogCheck menu, then select the required holes and intervals to be searched from the standard hole 

selection popup window. 

An example Uncorrelated Coals Audit: 

 

 

 

 

 

 

 

 

This includes the fields: 

• Hole Hole name of the hole  

• From From depth of coal unit or seam 

• To To depth of coal unit or seam 

• Thick Thickness of coal unit or seam 

• Seam Seam names of each seam in the hole 

• PercentCoal Percent coal in the unit or seam. 

From the above audit it can be seen that in hole AVC030C there are two strata of 30 and 20cms above 

the WK2 seam that are 100% coal but have not been given a seam name. 
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9.2.6 Unsampled Coals Audit 

The Unsampled Coals Audit analyses each of the selected holes and intervals and shows the intervals 

where coal has been logged as a lithotype but no sample number has been entered for the unit. This 

may be useful for detecting coals that have accidentally not been sampled or whose sample numbers 

have accidentally not been entered into LogCheck. Again, it determines that a lithology is coal from 

the Group column of its dictionary entry. 

To create an Unsampled Coals Audit, select Files > Open > Audit > Unsampled Coals from the 

LogCheck menu, then select the required holes and intervals to be searched from the standard hole 

selection popup window. 

An example Unsampled Coals Audit: 

 

 

 

 

 

 

 

 

This includes the fields: 

• Hole Hole name of the hole  

• From From depth of coal unit or seam 

• To To depth of coal unit or seam 

• Thick Thickness of coal unit or seam 

• PercentCoal Percent coal in the unit or seam. 

As coals in open holes will generally not be sampled, one may want to use a Hole Set containing 

just holes that have cored intervals to select the holes. To see more about defining Hole Sets see 

Section 6.5 – Creating/Editing a Hole Set Definition. 
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An example of such a Hole Set Definition for CoalLog data would be: 
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9.2.7 Unsampled Seams Audit 

The Unsampled Seams Audit analyses each of the selected holes and intervals and shows seams or 

parts of seams where no sample number has been entered. This may be useful for detecting where 

seams or parts of seams have accidentally not been sampled or whose sample numbers have 

accidentally not been entered into LogCheck.  

To create an Unsampled Seams Audit, select Files > Open > Audit > Unsampled Seams from the 

LogCheck menu, then select the required holes and intervals to be searched from the standard hole 

selection popup window. 

An example Unsampled Seams Audit: 

 

 

 

 

 

 

 

 

 

This includes the fields: 

• Hole Hole name of the hole  

• From From depth of coal unit or seam 

• To To depth of coal unit or seam 

• Thick Thickness of coal unit or seam 

• Seam Seam name of interval that has not been sampled 

As coals in open holes will generally not be sampled, one may want to use a Hole Set containing 

just holes that have cored intervals to select the holes. See the previous section Unsampled Coals 

Audit to see how to do this. 

 

 



CHAPTER 9. AUDITS, SUMMARIES & STATISTICS 

 212  LogCheck Manual 

9.2.8 Horizons, Strats, Seams and Plies Audits 

In some LogCheck formats, Horizons, such as Base of Tertiary, are stored in the Seam column of the 

geological data, on a unit with the same base depth as the preceding unit and blanks in all the 

remaining columns. Other LogCheck formats, such as CoalLog have separate Seam and Horizon 

columns. 

The Seam column can also include Strats – a strat is a unit that is to be used for correlation purposes, 

as opposed to a seam, which only refers to a coal-bearing unit. It is distinguished from a coal seam by 

having the word STRAT in the Group column of the Seam category of the current Seams Dictionary.  

Horizon, Strat, Seam and Ply audits are all similar in their output format.  

For each audit, each row is a hole and each column is a horizon, strat, seam or ply that occurs in at 

least one of the holes you have requested. The value in each cell is the depth for the horizon audit and 

thickness for the remainder. 

9.2.8.1 Horizons Audit 

This can be used to identify missing horizons. For example, the engineer may need a model of the 

Base of Tertiary. If a Base of Tertiary that should have been there has been omitted, it may corrupt the 

model. If there is no Base of Tertiary in a particular hole as with hole AVC032 in the example below, 

it could be because the geologist forgot to identify it, or that the hole may have been in rock the whole 

way. This would need to be checked before it was modelled.  

To create a Horizons Audit, select Files > Open > Audit > Horizons from the LogCheck menu, then 

select the required holes and intervals to be searched from the standard hole selection popup window. 

An example of a Horizon audit: 

 

 

 

 

 

 

 

 

In this audit, the value in each cell is the depth of the horizon. Each horizon has its own column – in 

this case, there are three: BHWE, BHWL and BUTE. A full description for the current column can be 

found in the bottom left corner of the screen. 

9.2.8.2 Seams Audit 

The Seams Audit shows the thickness of each seam in each hole. A seam is distinguished from a strat by 

the word SEAM in the Group column of its entry in the dictionary. The Seam Audit can show up where 

a seam is missing from a hole or where it is atypically thicker or thinner than other instances across the 
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project. The seams are displayed in the audit in stratigraphic order as defined by their order in the Seams 

Dictionary. 

To create a Seams Audit, select Files > Open > Audit > Seams from the LogCheck menu, then select 

the required holes and intervals to be searched from the standard hole selection popup window. 

An example of a Seams audit: 

 

 

 

 

 

 

 

9.2.8.3 Strat and Ply Audits 

The Strat audit shows the thickness of each strat in each hole, and the Ply audit shows the thickness of 

each ply in each hole. These audits can identify where a strat or ply is missing from a hole and they 

can also identify where they are atypically thicker or thinner than other instances. From the Audit 

menu, select the Strat or Ply menu item. 
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9.2.9  LAS Files Audit 

The LAS file audit reads the headers of all the project’s LAS files and lists for each file, the hole 

(WELL), from and to depths (STRT and STOP), reading interval (STEP), logging company (SRVC), 

logging date (DATE) and variables in the file. 

An example of a LAS header as shown in Notepad++: 

 
 

Often, there will often be a multitude of LAS files; even numerous files for a single hole, as there may 

be separate LAS files for different reading intervals, geophysical tools and/or parts of the hole. It is 

often difficult for the logger to incorporate the hole name, reading interval, tool and section of the hole 

all into the file name. 

When LogCheck requires the LAS data for a specified hole, depth and variable, it determines the 

required file(s) from the LAS Audit table. In order to successfully do this though, the Well line in the 

LAS file should contain the hole name as it is used in LogCheck. 

To create a Las Files Audit, select Files > Open > Audit > Las Files from the LogCheck menu, then 

select the required holes from the standard hole selection popup window. 
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An example of a Las Files Audit:  
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9.3 The Summary Menu 

To open a summary select File > Open > Summary from the LogCheck menu: 

 

9.3.1 Hole Summary 

The hole summary examines all the data stored within LogCheck for the selected hole(s), summarizes 

it and displays the summary. It includes items such as Hole Type, Hole Purposes, Survey, Drilling, 

Geology, Geophysics and Environmental: 

 

This is not only useful for seeing all aspects of a hole but is usefult to check that all the expected data 

for the hole has been entered. 

To create a Holes Summary, select Files > Open > Summary > Holes from the LogCheck menu, then 

select the required holes to be included from the standard hole selection popup window. 
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At any time, the summary displays just the results for a 

single hole. However, if multiple holes are selected then 

each can be displayed by selecting it from the drop down 

box in the summary for Hole Name: 

 

 

 

 

 

 

9.3.1.1 Header Data 

An example of the Hole 

Summary’s Header data 

summary: 

 

These items are all obtained 

directly from the Header data. 

 

 

 

 

9.3.1.2 Drilling Data 

An example of the Hole 

Summary’s Drilling data 

summary: 
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This includes the fields: 

• Drilling Company a list of codes for all the drilling companies that drilled parts of the hole 

• RigType a list of codes for all the rig types that were used drilling the hole 

• Date Started the first drilling date in the drilling data for the hole 

• Date Completed the last drilling date in the driling data for the hole 

• Total Depth the total depth according to the driller 

• Bit Summary table showing Bit Type, Drill Size, Core Size and Hole Size. A new row 

is shown each time one of these changes 

• Casing table showing all the Casing data for the hole 

9.3.1.3 Geology Data 

An example of the Hole Summary’s Geology data 

summary: 

 

 

 

 

 

 

 

 

This includes the fields: 

• Geological Organization the code for the Geological Organization that logged the 

hole 

• Geotechnical Log a flag indicating the hole has a geotechnical log 

• Core Photos a flag indicating that there are core photos for the hole 

• Logging Geologists list of the names of the Geologists who logged the hole 

• Horizon, Strat, Seam Summary a table showing the Name, From Depth, To Depth and 

Thickness of any Horizons, Strats or Seams logged in the 

hole 

9.3.1.4 Geophysics Data 

An example of the Hole Summary’s Geophysics data summary: 
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This includes the fields: 

• Logging Company the code for the geophysical logigng company that logged the hole 

• Logger’s Name the name of the person who geophysically logged the hole 

• Logs Run list of logs run on the hole according to what is recorded in the hole’s 

header 

• Las File Summary a table showing the From Depth, To Depth, Step, Date Logged and the 

Curves for each of the hole’s Las files 

By comparing the Logs Run as recorded by the geologist in the hole’s header with the Las File 

Summary, this summary can be used to double check that the logging company has provided all the 

Las files for all the hole’s logs. 

9.3.1.5 Environmental Data 

An example of the Hole 

Summary’s Environmental data 

summary: 

 

 

 

 

 

This includes the fields: 

• Standing Water Level Standing Water Level 

• Standing Water Level Date date Standing Water Level was measured 

• Rehabilitation Date date of completion of hole’s rehabilitation 

• Cementing  table showing all the Cementing data for the hole 

• Rehabilitation a table showing all the Rehabilitation data for the hole 
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9.3.2 Drilling Summary 

The Drilling Summary displays the number of metres of each type of drilling performed by each 

drilling company for each hole. This is useful for reconciling drilling company invoices with the actual 

drilling data.  

To create a Drilling Summary, select Files > Open > Summary > Drilling from the LogCheck menu, 

then select the required holes to be included from the standard hole selection popup window. 

An example of a Drilling Summary: 

 

 

The summary includes the fields: 

• Hole Hole name 

• StartDate Start date of drilling 

• EndDate End date of drilling 

• DrC Drilling company 

• RNo Rig number 

• BT_x Metres of drilling in the code for bit type x, where x is the bit type found in the 

Drilling Dictionary, for example, A – roller bit or D – diamond bit drilling, 

• Total Total depth of drilling 

Note: where a hole has had more than one drilling company or rig operating on the hole a separate line 

is shown for each drilling company/rig combination. To calculate total meterage for different bit types 

over a set of holes, open a drilling summary for these holes, export it to Microsoft® Excel as a comma 

delimited file (.csv) and then sum the columns in Excel. 
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9.3.3 Seam/Horizon Picks 

The Seam/Horizon Picks summary generates a “picks” file that has tops, bottoms and thicknesses for 

export to a modelling package. Note that when exporting this data, LogCheck provides the option of 

augmenting the data with its 3-D coordinates.  

To create a Seam/Horizon Picks, select Files > Open > Summary > 

Seam/Horizon Picks from the LogCheck menu, then select items to 

include in the Picks: 

Note that the Plies option only appears if you have a Ply column in 

your data format. 

 

 

 

Then select the required holes and intervals from the standard Hole Selection dialog.  

An example of a Seam/Horizon Picks summary: 

 

 

 

 

 

 

 

 

 

 

 

The summary includes the fields: 

• Hole Hole name 

• Unit The Horizon/Strat/Seam/Ply name 

• From From depth of unit 

• To To depth of unit 

• Thick Thickness of the unit 
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9.3.4  Seam/Plies Summary 

The Seam/Plies Summary displays a summary of the seams or plies occurring in each hole. For each 

intersection it includes: thickness, recovery, thicknesses of coal and partings and stripping ratios. The 

strip ratios may be useful during exploration to give ballpark figures for the economics of opencut 

mining. Be mindful though that when modelling strip ratios, these strip ratios should not be used for 

modelling, rather strip ratio models must be generated from thickness and coal density models. 

To create a Seam/Horizon Summary, select Files > Open > Summary > Seams/Plies from the 

LogCheck menu, then select type of summary required: 

 

If Plies is chosen, it works on the Ply column, not the Seam column; if Seams + Plies is chosen, it 

works on the seam code concatenated with the Ply code. 

Next select the required holes and intervals from the standard Hole Selection popup window.  

Then select the required Seam 

Summary Parameters: 
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When deciding whether a unit is coal or partings, you can specify a minimum parting thickness in this 

window. This may be necessary, as anything less than this thickness that is not coal, may not be able 

to be separated during mining from the actual coal, and therefore needs to be included with the coal.  

The coal density is required, in order to calculate the stripping ratio, though this is irrelevant for 

underground mining. There are two ways to specify the density: 

• Using two estimated densities – one for all coal and one for all stone. 

• Using LAS density.  

An example of a Seam Summary (left-hand columns): 

 

An example of a Seam Summary (right-hand columns): 

 

 

The summary includes the fields: 

• Hole Hole name 

• Seam Seam name 

• From From depth of seam 

• To To depth of seam 

• Thickness The seam thickness – the difference between the From and To Depths. This 

thickness includes partings and core loss. 
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• Coal Thickness of coal in the seam. Whether a lithology is coal or not is determined 

by whether the lithology has a value of COAL or not in its Group column in the 

current Geology Dictionary, may include core loss – see following section. 

• Partings Thickness of all lithologies in the seam that are not coal, may include core loss 

– see following section. 

• Core Loss Thickness of all lithologies in the seam that have CORELOSS or CORE LOSS 

in the Group column of its lithotype’s entry in the current Geology Dictionary 

• Cored Thickness of the seam whose Bit Type in the corresponding drilling data has 

CORED in the Group column in the current Drilling Dictionary 

• Recovery The linear recovery – the percentage of the seam length that is cored and not 

recorded as Core Loss in the geology. 

• Coal_Density Coal density, for use in strip ratio calculations, 

• Coal_Mass Coal mass per square metre, 

• Burden Thickness of over/interburden, 

• Strip_Rat Burden thickness/coal mass (strip ratio), in bank cubic metres per tonne of coal. 

• Cum_Coal_Mass Cumulative coal mass per square metre, 

• Cum_Burden Cumulative thickness of over/interburden, 

• Cum_Strip_Rat Cumulative strip ratio (cumulative burden / cumulative coal mass), 

• Lithology List of lithotypes and their percentages for the seam 

 

9.3.4.1 Determining Whether a Core Loss is Coal or Non-Coal 

For the purposes of dividing the seam into coal and partings, any core loss is allocated to one or the 

other. If the core loss is adjacent to coal, it is considered coal, otherwise it is considered parting. When 

deciding whether a core loss is to be regarded as coal or non-coal, four situations can be distinguished, 

based on whether the core loss is overlain/underlain by coal/non coal. The core loss is considered coal 

for the first three and non-coal for the last. 

Coal  Non-coal  Coal  Non-coal 

Core Loss  Core Loss  Core Loss  Core Loss 

Coal  Coal  Non-coal  Non-coal 

       

1. Core loss is 

regarded as coal 

 2. Core loss is 

regarded as coal 

 3. Core loss is 

regarded as coal 

 4. Core loss is 

regarded as parting 
 

 

 

 

 

 

The cumulative values 

include the combination of 

all the overlying values 
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9.3.5 Samples Summary 

The Samples Summary displays a summary of the samples taken for each hole. This is useful for 

tracking samples and producing sample tags.   

To create a Samples Summary, select Files > Open > Summary > Samples from the LogCheck menu, 

then select the required holes to be included from the standard hole selection popup window. 

The Theoretical Sample Mass 

Calculation popup window is 

then displayed: 

 

 

 

 

 

 

 

If the “Calculate theoretical sample mass” box is checked, a theoretical sample mass is calculated for 

each sample by multiplying the sample length by drill hole cross-sectional area (derived from the core 

size in the drilling data) by a density which can either be derived by using a specified density for each 

of coal and stone or from a density from the LAS data. The sample mass as measured either in the 

field or by the laboratory can be compared to this to determine the volume recovery for the sample. 

The theoretical sample mass can also be used as a check that samples have not been confused, as the 

laboratory recorded sample mass cannot be greater than the theoretical sample mass. 

An example of a Sample Summary (left-hand columns): 
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An example of a Sample Summary (right-hand columns): 

 

The summary includes the fields: 

• Hole Hole name 

• SP Sample purpose 

• SampNumb Sample number 

• From From depth of sample 

• To To depth of sample 

• Thick Difference between the From and To depths 

• Coal Thickness of the coal in the sample. Whether a lithology is coal or not is 

determined by whether the lithology has a value of COAL or not in its Group 

column in the current Geology Dictionary. 

• Core Loss Thickness of all lithologies in the seam that have CORELOSS or CORE LOSS in 

the Group column of its lithotype’s entry in the current Geology Dictionary 

• Cored Thickness of the seam whose Bit Type in the corresponding drilling data has 

CORED in the Group column in the current Drilling Dictionary 

• LinearRecov The linear recovery – the percentage of the seam length that is cored and not 

recorded as Core Loss in the geology. 

• FromSeam Top seam in the sample. If the top of the sample is in the roof of a seam, 

then this field will display the seam name followed by the letters RF. 

• FromPly Top ply in the sample 

• ToSeam Bottom seam in the sample. If the bottom of the sample is in the floor of a 

seam, then this field will display the seam name followed by the letters FL. 

• ToPly Bottom ply in the sample 

• DrillDate Date of drilling, as derived from drilling data, 

• CoSz Core size, as derived from drilling data, 

• Density The estimated density of the sample, calculated either by applying the user 

specified densities for coal and stone or from the geophysics. 

• TheoryMass Theoretical sample mass – assuming 100% core recovery. 

• DispatchMass Mass of the sample in kilograms measured before it is dispatched 

• VolRecov The ratio of the DisptachMass to TheoryMass as a percentage 

• Lithology Summary of the sample’s lithology. 

 

To produce sample tags from the summary select File > Export > Sample Tags from the LogCheck 

menu. 
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9.4 Statistics 

To open a statistical analysis, select File > Open > Statistics from the LogCheck menu: 

 

 

9.4.1 Coded Data Frequencies Statistics 

The Coded Data Frequencies displays the frequency of occurrence of each required variable in the 

selected hole(s) and intervals, either a direct count of the number of occurrences or weighted by 

thickness. Each selected variable can be analysed by its actual value, or by the value’s group in its 

dictionary. A second variable can optionally also be selected to be combined with the first.  

 

To create a Coded Data Frequencies Statistics, select Files > Open > Statistics > Coded Data 

Frequencies Statistics from the LogCheck menu, then select the required holes and intervals to be 

included from the standard hole selection popup window. 

9.4.1.1 Example 1: Sum of Coded Value Thicknesses  

This example sums the thicknesses of the LithoTypes in the 5m of roof of the WK2 seam. It uses an 

interval definition called WK2_Roof_5m to select these intervals (see Section 6.6 – Creating/Editing 

Interval Definitions). The results may then be used to see how the roof of the seam varies over the 

deposit. 

The required parameters for this are:  
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The generated statistics are: 

 
 

If the Show as Percentage of Total for Each Hole box is ticked in the parameters window, the results 

are shown as a percentage of the 5 metres of roof, rather than the actual thickness: 

 

9.4.1.2 Example 2: Sum of Coded Value’s Dictionary Group Thicknesses  

This example again sums the thicknesses of the LithoTypes in the 5m of roof of the WK2 seam using 

the interval definition called WK2_Roof_5m. However, the user has first set the Group in the 

LithoType category of the current Geology Dictionary to COAL for all coals and CARB_SED for all 

carbonaceous LithoTypes. 
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The required parameters for this are:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The generated statistics are: 

 

 

 

 

 

 

 

9.4.1.3 Example 3: Occurrence Count of Combined Variables  

This example counts the number of occurrences of each combination of Surface Shape and Roughness 

in a set of Defect. When selecting the data, Defects was selected for Data Type in the standard Hole 

Selection popup window. 

The required parameters for this are:  

 

 

 

 

 

 

 

 

 



CHAPTER 9. AUDITS, SUMMARIES & STATISTICS 

 230  LogCheck Manual 

The generated statistics are: 

 

 

These results may be a useful to assess how the likelihood of slipping across defects changes over the 

deposit. 

 

When using combinations of two variables, it is only viable for categories with a small number of 

entries, such as Defect Shape and Roughness as LogCheck creates a temporary category for every 

combination of the two variables. For example, if your data format is CoalLog, and you select 

Lithology and Estimated Strength, there are 97 lithologies and 18 estimated strengths. LogCheck 

attempts to categorise data into 97 x 18 groups, that is 1746 categories. This number exceeds the 

maximum allowable of 1020 combinations. 

LogCheck can produce a histogram from the generated statistics. However, one must first create an 

appropriate Histogram Definition by selecting:    

 

 

A popup window then requests a project and name for 

the new definition: 
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Next select the required option: 

In this example, the histogram will 

group data together by hole, and 

display all categories. 

By entering a list of specified 

categories, the user can control the 

order that the categories appear on the 

histogram. 

 

 

After the histogram definition is created, display the 

required statistics in LogCheck, then select File > 

Plot from the LogCheck menu and select the required 

definition: 

 

 

 

Finally, the user is prompted for the folder and filename for the plot to be generated. 

The resulting plots for the above generated statistics: 

 

 

 

 

 

 

 

 

 

Shape/Roughness statistics 

grouped by Hole 

Shape/Roughness statistics grouped 

by Category 
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9.4.2 LAS Variables Statistics 

Las Variables Statistics generates statistics such as minimum, maximum, mean, standard deviation etc 

for the user selected LAS variables for specified holes and intervals within the holes. 

To create a Coded Data Frequencies Statistics, select Files > Open > Statistics > Coded Data 

Frequencies Statistics from the LogCheck menu, then select the required holes and intervals to be 

included from the standard hole selection popup window. 

Next select the required LAS variables: 
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Next select the 

step interval data 

to include in the 

statistics: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Generated LAS Variables Statistics for MC2F: 

 

 

The includes the fields: 

• Filename Name of LAS file 

• Hole Name of Hole in the file 

• Variable Geophysical variable code 

• Units Unit of measurement 

• No Number of non-missing values 

• NoMissing Number of missing values 

• Minimum Minimum value encountered in each file 

• Maximum Maximum value encountered in each file 

• Mean Sum of all values divided by the number of non-missing values 

• StDev Standard deviation, which is a measure of the variation from the average 

• Percentile_05 5th percentile, that is the value below which 5% of the values occur 

• Percentile_25 25th percentile, that is the value below which 25% of the values occur 

• Median Value below which 50 % of the values occur, that is, the middle value in the 

sorted list of all values 

• Percentile_75 75th percentile, that is the value below which 75% of the values occur 

• Percentile_95 95th percentile, that is the value below which 95% of the values occur 
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These can then be displayed as a Box & Whisker plot. This can be useful for checking the calibration 

between holes and for selecting a scale to display the LAS variables. To produce a Box & Whisker 

plot, after the LAS statistics are displayed in LogCheck, select File > Plot from the LogCheck menu. 

Then select the folder and filename for the plot. 

The plot for the above results: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Box and Whisker plots are a useful graphical summary of the spread or variation in a set of data 

values. In the above plot, each of the horizontal bars represents the minimum, 5th quartile, median, 95th 

quartile and maximum values for each hole. The box itself represents where half the number of values 

lie. The bottom bar of the box represents the 25th percentile and the top bar of the box represents the 

75th percentile. The width of the box is proportional to the number of values in the list of values. 

Maximum value 

75th Percentile 

Median value 

25th Percentile 

Minimum value 

5th Percentile 

95th Percentile 
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Chapter 10  
 Printing and Exporting 

 

By the end of this chapter you will be able to: 

 

▪ Print dictionaries and data as tables. 

▪ Print dictionaries, data and summaries as reports. 

▪ Print sample tags for sample bags. 

▪ Export data to other file formats. 

▪ Move or Copy multiple LogCheck files between projects or computers. 
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10.1 Introduction 

LogCheck can print dictionaries and hole data as both tables and reports. It can also print reports for 

hole summaries and generate Sample Tags for sample bags. 

LogCheck can export all dictionaries, data, audits, summaries and statistics in a variety of formats 

including CSV and TXT files.  

It also has a facility for Moving or Copying as LogCheck files, all the data for specific holes between 

projects or computers. 

All example print-outs in this chapter for both tables and reports, display the GeoCheck logo in the top 

left-hand corner but the user can supply their own logo by entering the name of the file that contains 

their logo in the Project Company Logo box in the Project Details for their project (see Section 4.4.4 

Company Project Logo). 
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10.2 Printing Data 

LogCheck can print all its dictionaries and data as tables. The dictionary tables look similar to how 

they appear on the screen and the data tables look similar to hand written coding sheets of the data.  

To print the currently open dictionary or data select:   

 

 

Next select the required printer: 

 

 

To create a PDF file of the output select a PDF writer as the printer. If you do not have one installed, 

the producers of LogCheck recommend the freeware PrimoPDF available from: 

https://www.gonitro.com/primopdf 

If logging boreholes directly into LogCheck in the field, it is highly recommended that one regularly 

creates PDF’s of the coded data and save these to flash disk so that if anything happens to the tablet 

then the data can be later re-entered from the PDF’s.  

https://www.gonitro.com/primopdf
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10.2.1 Printing Dictionary Categories  

An example of printing the LithoType category of the Geology Dictionary: 

 

10.2.2 Printing Actual Data 

An example of printing Geology Data: 
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10.3 Printing Reports 

LogCheck can print reports for its dictionaries, some of its data types and some of its audits and 

summaries.  

To print the currently open dictionary, data, audit or summary as a report select:   

 

 

10.3.1 Dictionary Report 

An example of the Dictionary Report for a Geology Dictionary: 
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10.3.2 Activities Report 

An example of the Report for a day’s Activities: 
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10.3.3 Headers Report 

An example of the Report for a hole’s Header data: 
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10.3.4 Casing Report 

An example of the Report for a hole’s Casing data: 

 

10.3.5 Cementing Report 

An example of the Report for a hole’s Cementing data: 

 

10.3.6 Drilling Report 

An example of the Report for a hole’s Drilling data: 
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10.3.7 Geology Report 

An example of the Report for a hole’s Geology data: 

 

 

For the Geology report the user has a number of options that they can set by selecting Settings > 

Options and then selecting the Exporting & Printing tab: 

 

 These include: 

• Orientation Portrait or Landscape 

• Seams & Ply Columns if ticked then as well as columns for Depth, Thickness, Sample 

Number and Lithology as shown in the above example, columns 

are included to display the Seam and Ply codes 

• Seam Top & Base Lines if ticked then lines are dispalyed across the report for the top and 

base of Seams as shown in the example above 
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10.3.8 Water Flows Report 

An example of the Report for a hole’s Water Flows data: 

 

10.3.9 Basic Coal Quality Report 

An example of the Report for a hole’s Basic Coal Quality data: 
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10.3.10 Defects Report 

An example of the Report for a hole’s Defect data: 

 

10.3.11 Point Loads Report 

An example of the Report for a hole’s Point Load data: 
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10.3.12 Hole Summary Report 

An example of the Report for a hole’s Hole Summary: 
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10.4 Exporting Data 

All Dictionaries, Site Data, Hole Data, Audits, Summaries (except Hole Summaries) and Statistics can 

be exported from LogCheck in a number of different formats. These can then be imported by other 

copies of LogCheck or other software such as Excel or modelling programs.  

To export any of these, open them and then select: 

 

 

 

 

 

 

 

 

 

Next the user is prompted for the export file layout and format: 

 

The options on this popup window include: 

• Export Layout Which options are available for this depend on the type of data being 

exported. The LogCheck option is available for all data types. This option 

exports the data just as shown on the screen. CoalLog Data Transfer is only 

available for CoalLog versions of LogCheck and then only for Hole Data. 

In general, the other layouts are only available for Header and Geology 

data and only in specific Header and Geology formats. Please contact the 

distributors of LogCheck for further assistance with the non LogCheck or 

CoalLog layouts.  
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• Export Format Delimited or Fixed Format. Delimited formats separate each column of 

data by a Column Delimiter such as a comma. Fixed Format lays the data 

out with a fixed number of characters for each column in the file. For 

example, Hole Name may be the first eight characters of the file and then 

Depth may be the next seven characters etc. 

• Column Delimiter If Delimited Export Format is selected then this is the character to separate 

columns. This will generally be a comma but in some countries where they 

use commas for decimal points they may use another delimiter between 

columns. 

• Combine adjacent lines with duplicate data 

If multiple lines have the same data apart from depths, if this is ticked then 

the superfluous lines are removed. For example, if the user exports just the 

Calculated Depth, Depth and Sample Numbers from the Geology data, then 

if this is unticked then there will be a line in the export file for each row in 

the original Geology data: 

 

Whereas if ticked, there is only one line for each sample number: 
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• Write individual holes to separate files 

This option is only available if the current data includes more than one 

hole. If ticked then the exported data for each hole will be exported to a 

separate file. 

When exporting data, the hole name, from depth and to depth is automatically included with each unit. 

However, the user is next asked if they want to add the coordinates for the top and bottom of each unit 

and how to determine these: 

 

The coordinates are calculated based on the Easting, Northing and Collar Elevation in the header plus 

an offset determined from each unit’s From and To Depth. These offsets can be calculated either by 

using the holes inclination and azimuth at the collar which is recorded in the hole’s Header data or 

from a Las file containing the offsets that have been calculated from a Verticality log.  

Clearly to add the coordinates, the hole’s coordinates must exist in the Header data, and either 

inclination and azimuth of the hole must exist in the Header data or the user must have a LAS file 

containing the offsets. 

For example, here is the export of a Seam Summary without coordinates added: 

 

And with coordinates added: 
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Next the user is prompted for what fields they wish to include as well as Hole Name, From and To 

Depths: 

 

 

Lastly, they are prompted for the folder and file name for the generated file: 
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After the export file is generated the user is 

asked if they would like to open it: 

 

 

 

 

10.4.1 Exporting Sample Tags 

For Sample Dispatch Data and Sample Summaries, there is also an option to export sample tags for 

printing.  

To export these, after opening the required 

Sample Dispatch Data or Sample Summary 

select: 

 

 

 

 

 

 

 

 

Next the user is prompted for the required 

format: 

 

 

 

 

 

 

 

They are then prompted for the name of the folder and file name for the tags and once generated asked 

if they would like to open it. 
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An example of the Sample Tag export: 
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10.5 Moving and Copying LogCheck Data Files 

One can manually move or copy LogCheck data files between projects on a computer or between 

LogCheck installations on different computers using Windows Explorer (see Appendix A: LogCheck 

Folders and Files). However, LogCheck has the ability to Move or Copy multiple LogCheck data files 

at one time. This is useful for moving and copying all the data files for a specific set of holes.  

When moving files, LogCheck moves them from where they currently sit on the user’s computer to a 

specified folder, however, it also takes a copy of the moved files and places them in a folder named 

Archived in the user’s project folder. Moving files can be useful when the filed geologist has finished 

editing them and wishes to move them to a server or the database manager’s computer. They thus can 

easily determine which files have been moved and which have not by seeing which are in their original 

folders and which are in the Archived folder. 

To Move or Copy files for a specific set of holes. First set up a Hole Set containing these holes (see 

Section  6.5 Creating/Editing a Hole Set Definition).  

Next, if just wanting to Move or Copy one data type, open the Hole Data for the Hole Set, by selecting 

File > Open > Hole Data and then select the Data Type and Hole Set. If wanting to Move or Copy the 

data for all data types for the specific Hole Set, open the Hole Audit for the Hole Set, by selecting File 

> Open > Audit > Holes and then select the Hole Set. 

Next select either Move or Copy Currently Displayed 

Files from the LogCheck’s File menu: 

 

 

 

 

 

 

 

 

Next, if the data to moved or copied 

includes Geology data with an 

accompanying Seams Dictionary, 

LogCheck asks: 
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It then informs the user that: 

 

 

 

 

For example, if moving or copying Headers and Geology data for a set of holes, then once the user 

provides the name of a folder in which to Move or Copy the files then if there is no Headers and 

Geology folder in the desired folder, LogCheck will create these folders and put the appropriate files in 

each. 

It then prompts for the name of the folder to move or copy to: 

 

 

It then moves or copies the files and informs the user: 
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Chapter 11  
 Plotting Hole Plans 

 

By the end of this chapter you will be able to: 

 

▪ Create a Hole Plan Definition 

▪ Plot a Hole Location Plan including Data for each Hole 

▪ Plot  a Seam Thickness Map 
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11.1 Introduction 

LogCheck can plot a hole plan displaying the location of selected holes plus additional information 

such as the date drilled or the thickness of a particular seam. Data from the following data types can be 

displayed on a Hole Plan: 

• Hole Audit 

• Drill Sites 

• Headers 

• Drilling Summary 

• Horizon, Strat, Seam or Ply Audits 

• Seam / Horizon Picks 

• Seam or Ply Summaries 

 

Before plotting a hole plan though the user needs to create a Hole Plan Definition that specifies items 

such as minimum and maximum Eastings and Northings and annotation heights for the plan. 
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11.2 Creating and Editing a Hole Plan Definition 

To create a new Hole Plan Definition select: 

 
 

Next LogCheck prompts for the project and name for the new Hole Plan Definition: 

 

Next the Hole Plan Definition window displays: 
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11.2.1 DXF Template File 

When LogCheck creates a DXF file, it builds on another DXF 

file – that is, the DXF Template File. If this field is left blank, 

LogCheck uses its own default empty template, called 

LogCheck.dxf. However, the user can specify the name of 

another DXF file in this field for LogCheck to build on.  

When LogCheck creates a new DXF file, it will look for the named DXF template file in the following 

folders in the following order: 

1. PlotPara under the folder Definitions in the current project folder. 

2. PlotPara under \LogData\Definitions. 

3. PlotPara under \Program Files\LogCheck\Definitions – this is distributed with the software. 

The user can set up their own DXF file template which be a standard company sheet or default legends, 

however, the DXF file must be in Release 12 format.  Most CAD software offers DXF Release 12 as a 

file type in their Save As option.  

11.2.2 Map Border 

This enables the user to setup the minimum and maximum 

coordinates for the map and the tick spacing along the edge 

of the map: 

 

 

 

When creating a Hole Plan Definition LogCheck initially sets the minimum and maximum coordinates. If 

minimum and maximum coordinates have been set in the Project Details for the project it uses these 

otherwise it determines the minimum and maximum coordinates from the Headers of all the and then uses 

rounded values of these. 

11.2.3 Map Scale 

The map scale is the scale at which the plots are to be 

created.  

 

All plots generated by LogCheck are produced in mm’s and so when creating hardcopies of the plots 

using software such as AutoCAD TrueView then the hardcopy needs to be generated at a scale of 1 

drawing unit = 1mm.  

Scales can be specified in either Metric (1m on the ground = so many mm’s on 

the plot) or Ratio format (1m on the plot = so many m’s on the ground). 

Which of the two formats is used in the Plot Definition editor can be set in the 

Scale Format panel of the LogCheck plotting options (select Settings > 

Options, then select the Plotting page), as shown at right. A metric format of 1 

metre on ground = 20mm on paper is equivalent to 1:50 in ratio format. 
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If the Scale Format is set to Metric, then the Map Scale panel appears as shown on the left; if the Scale 

Format is set to Ratio, then the Map Scale panel appears as shown below on the right: 

  

 

11.2.4 Bottom Left Corner Position 

The plot is created in millimetres and the Bottom Left Corner 

Position is the position in the plot for the bottom left corner of 

the map.Generally this will be set by the user to 0,0: 

 

However, if the Map Scale is set to 1 metre = 1 mm and the Bottom Left Corner Position is set to the 

map’s minimum Easting and Northing then when viewing the map in AutoCAD TrueView then as the 

mouse is moved around the screen the true coordinates of the mouse’s location will apear in the 

bottom right of the screen.  

11.2.5 Data Posting 

This enables the user to specify the type of symbol to be used for the 

drill hole location, the size of the symbol, the size of the annotation for 

each hole and the angle for plotting the annotation. 
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11.3 Generating a Hole Location Plan 

To generate a Hole Plan for all the holes in a project showing each hole’s name and elevation: 

• Open the Header data for all holes in the project.  

• Select File > Plot: 

 

 

 

 

 

 

 

 

 

• Select the Hole Plan Definition to 

use and the Variables to be 

plotted. When selecting the 

Variables, the Shift and Ctrl keys 

can be used to select more than 

one Variable: 

 

 

 

 

 

 

 

 

• Select the folder and file name for the resulting plot file. 
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Using the MyHolePlan Definition shown above and the selected Variables shown above will generate 

the Hole Location Plan: 
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11.4 Posting Seam Thicknesses on a Hole Plan 

To post Seam Thicknesses on a Hole Plan for a number of specified seams for all the holes in a project 

showing each hole’s name and the seam thicknesses. 

• Open the Seam Audit for all holes in the project. 

 

 

• Select File > Plot: 
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• Select the Hole Plan Definition to 

use and the seams whose 

thicknesses are to be plotted. 

When selecting the seams, the 

Shift and Ctrl keys can be used to 

select more than one seam: 

 

 

 

 

 

 

 

• Select the folder and file name for the resulting plot file: 
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Using the MyHolePlan Definition shown above and the selected Variables shown above will generate 

the Hole Location Plan: 
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Chapter 12  
Plotting Down Hole Data  

 

By the end of this chapter you will be able to: 

 

▪ Open, create and save a Plot Definition file. 

▪ Set parameters for the layout of plot sheets. 

▪ Add, edit, and delete tracks for a plot. 

▪ Plot a hole or a section. 

▪ Plot the LAS data by appending to an existing plot file. 
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12.1 Introduction 

LogCheck provides a wide variety of options for plotting downhole data. The many variations are 

controlled by parameters that are defined in what is referred to as a Plot Definition.  

All plots are generated as AutoCad release 12 DXF files (note that Release 12 has no facilities for 

bitmaps or JPEG files). Many freeware packages and most CAD packages can display and plot these 

files.  We recommend AutoCad’s TrueView to display the plot file. This is available for free and can 

be downloaded from (at the time of printing): 

https://www.autodesk.com/viewers 

The size and position of all items recorded in the DXF file are in millimetres in the DXF file. This 

means that when generating a hard-copy plot from the DXF file then the Scale should be set to 1 mm = 

1 unit: 

 

 

A Plot Definition includes parameters such as the vertical scale, the width, location and contents of 

columns (known as tracks), the horizontal scale for sections, and items to be shown in the title block. 

A Plot Definition contains over 120 different parameters that can be modified by the user.  

When the user plots their currently open data, they are prompted for the location and name of the Plot 

Definition to be used. 

A Plot Definition consists of four files, for example, the Plot Definition named LC_SEAM consists of 

the four files:  

LC_SEAM.mem 
LC_SEAM_Bars.dbf 

LC_SEAM_Titles.dbf 

LC_SEAM_Tracks.dbf  

 

Plot Definition files can be renamed, deleted or copied to another location. If renaming these files, 

they must all be given the same Plot Definition name and the .mem, _Bars.dbf, _Titles.dbf, and 

_Tracks.dbf components of the name must be preserved. 

LogCheck comes with a standard set of Plot Definition files, which all have the prefix “LC_”. These 

are described in Appendix B and include: 

• A seams only plot at 1:20 
• Entire hole with Geophysics (Density, Gamma and Calliper) 

• 1:20 plot of individual holes in A4 and A3. 

• 1:100 plot of individual holes in A4 andA3. 

• 1:200 plot of individual holes in A4 and A3. 

• A4 and A3 section plots without horizontal scale (ie sit 10 mm apart for a fence diagram) at 

1:100 and 1:200. 



CHAPTER 12. PLOTTING DOWN HOLE DATA 

LogCheck Manual 267 

12.2 Plotting Single Holes 

To plot the data for single holes:  

• Open the hole(s) and data type to be plotted by selecting File > Open > Hole Data. When selecting 

the data to be opened, the user can select all holes, a user specified Hole Set or a single hole. They 

can also select the entire hole, a depth interval or part of the hole as defined by a user specified 

Hole Interval Definition. 

 

• Select File > Plot from the menu. 

 

• Select the category and name of the Plot Definition to be used. The Categories are LogCheck 

standard plots (these all start with LC_ and are stored with the software), the user’s default 

Plot Definitions (stored in C:\LogData\Definitions\PlotPara) or Plot Definitions that are 

specific to a project (stored in C:\LogData\projectName\ Definitions\PlotPara).  

 

 

 
 

 

 

• If more than one hole has been opened (by selecting All Holes or a user defined Hole Set), the 

user will be asked if they would like to Plot individual holes to separate files? They should 

reply Yes otherwise the multiple holes will be plotted as a single section.  
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• Provide the location and name(s) for the generated plot file(s): 

 

- If plotting a single hole, LogCheck prompts for a file name for saving the file: 

 

 
 

 

The suggested filename will consist of the hole name followed by the interval definition name 

(if used) and if a hole’s plot consists of multiple pages a suffix. If the plot consists of 26 pages 

the suffix for the first page will be _A, the second _B, etc. If the plot consists of more than 26 

pages, the suffix for the first page will be _AA, the second _AB, etc. The files have a file type 

of .dxf. 

 

 

- If plotting multiple holes, LogCheck prompts for a folder name for saving the files: 

 

 

 
 

 

It then automatically creates filenames for each plot which consist of the hole name 

followed by the interval definition name (if used) and if a hole’s plot consists of multiple 

pages a suffix. If the plot consists of 26 pages the suffix for the first page will be _A, the 

second _B, etc. If the plot consists of more than 26 pages, the suffix for the first page will 

be _AA, the second _AB, etc. The files have a file type of .dxf. 
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• If a plot file name already exists, LogCheck asks whether to overwrite the file, or append the 

current hole to data that is already in the file, as shown below: 

 

 
 

 

If one of the Append options is chosen, the data is added to the existing plot; if one of the Overwrite 

options is chosen, the original plot file is deleted and a new plot is created.  

 

To plot Geology data and LAS data to the same file, first open the Geology data and plot it. Then open 

the LAS data and plot it to the same plot filename, selecting Append rather than Overwrite. If 

Overwrite is chosen, the plot will show only the LAS data, not the Geology data, as the Geology data 

plot will be overwritten. 
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12.3 Plotting a Section 

To plot a section:  

• Create a Hole Set Definition specifying the holes required for the section. The holes to be 

included in a particular Hole Set can be specified by creating a list, those within a specified 

corridor of a user defined section line and/or using a query. When doing a scaled section 

LogCheck projects the holes onto a section line. If a section line has been specified in the Hole 

Set Definition then this is the section line onto which the holes are projected otherwise 

LogCheck fits a best fit line through the collar coordinates of the selected holes and the holes 

are projected onto this line. 

 

• Open the holes and data type to be plotted by selecting File > Open > Hole Data. When selecting 

the data to be opened, the user should specify the Hole Set they have defined as described above. 

They can also select the entire hole, a depth interval or part of the hole as defined by a user 

specified Hole Interval Definition. 

 

• Select File > Plot from the menu. 

  

• Select the category and name of the Plot Definition to be used. The Categories are LogCheck 

standard plots (these all start with LC_ and are stored with the software), the user’s default 

Plot Definitions (stored in C:\LogData\Definitions\PlotPara) or Plot Definitions that are 

specific to a project (stored in C:\LogData\projectName\Definitions\PlotPara).  

 

 
 

 

 

• The user will then be asked if they would like to Plot individual holes to separate files? They 

should reply No otherwise LogCheck will plot separate plots for each hole rather than a 

section of the holes. 
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• Provide the location and name for the generated plot file: 

 

 

 
 

 

The suggested filename will consist of the Hole Set Definition name followed by the Interval 

Definition name (if used). The file will have a file type of .dxf. 

 

 

• If a plot file name already exists, LogCheck asks whether to overwrite the file, or append the 

current hole to data that is already in the file, as shown below: 

 

 
 

 

If one of the Append options is chosen, the data is added to the existing plot; if one of the Overwrite 

options is chosen, the original plot file is deleted and a new plot is created.  

 

To plot Geology data and LAS data for a section to the same file, first open the Geology data and plot 

it. Then open the LAS data and plot it to the same plot filename, selecting Append rather than 

Overwrite. If Overwrite is chosen, the plot will show only the LAS data, not the Geology data, as the 

Geology data plot will be overwritten. 
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12.4 Plot Definition Files 

12.4.1 Creating a Plot Definition File 

A new Plot Definition can be created by going to File > New > Plot Definition (or pressing the 

Ctrl+F11 keys), as shown below: 

 

 

The following form is then displayed: 

 

 

In this example, a new Plot Definition will be created in the user’s default Plot Definitions 

(C:\LogData\Definitions\PlotPara), and its name will be GEOLASPR. Plot Definition file names can 

be of any length, contain upper and lower case characters, but cannot contain blanks. They also cannot 

begin with the characters LC_ as this prefix is reserved for LogCheck standard Plot Definitions. 
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12.4.2 Opening Plot Definition Files 

A Plot Definition file can be opened for viewing and editing by going to File > Open > Plot Definition. 

The following form is then displayed: 

 

 

The Plot Definition Categories are LogCheck standard plots (these all start with LC_ and are stored 

with the software), the user’s default Plot Definitions (stored in C:\LogData\Definitions\PlotPara) or 

Plot Definitions that are specific to a project (stored in 

C:\LogData\projectName\Definitions\PlotPara).  

  

12.4.3 Copying a Plot Definition File 

An existing plot file can be copied to another plot file – which presumably will then have some 

modification performed on it. To copy a Plot Definition file: 

• Open an existing Plot Definition file. 

 

• From the File menu, select Save As: 
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• Enter a new name for the plot (as shown on the right). Note that as names starting with LC_ 

are reserved for the LogCheck standard Plot Definitions, then the name cannot begin with LC_ 

 

 

12.4.4 Plot Definition Editor 

An example of a Plot Definition in its editor is: 

 

 

There are five tabs at the bottom of this form. On selection of each, a different set of parameters for 

defining the plot layout are displayed: 

 

• Sheet Layout:  Horizontal and vertical scales, how to split a hole into multiple columns 

across the page and vertical alignment of multiple holes on the same 

page. 

• Sheet Annotations:  Sheet border, text to be plotted on each page and depth bars that appear 

once per page. 

• Stratigraphy: Stratigraphy to be plotted between holes on a section. 

• Hole Annotations:  Text to be plotted for each hole plotted on the page. 

• Tracks:  Set options for the location and content of the various tracks that are to be 

drawn on the plot. 
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12.5 Plot Definition - Sheet Layout Page 

The parameters that can be set in the Sheet Layout page as displayed in the previous section include: 

Horizontal aspects of the Layout: 

 

• Horizontal Offset from the Top Left corner of the sheet to the First Hole on Left 

• For Single Hole plots: Maximum Number of Repetitions across Sheet and Distance between 

Repetitions 

• For Sections: whether the distance between holes is defined by a Scale or a Fixed Distance 

and what the Scale or Fixed Distance is  

 

 

Vertical aspects of the Layout: 

 

• Vertical Offset from the Top Left corner of the sheet to the top of the Hole or for sections the 

top of the Shallowest Hole 

• Vertical Scale 

• For Single Hole plots: Maximum Length of the Track before the Track is split into one or 

more further tracks displayed across the page 

• For Sections: how to align the holes vertically, that is on Hole Elevation, Top or Bottom of 

Displayed Interval or a Level Chosen from the Data 

 

 

Ability to plot all fixed length track boxes and their titles even if no data 

 

12.5.1 Offset to First Hole on the Left 

The distance in millimetres from the left-hand side of the page to the left-hand edge of the first hole on 

the left. Where a sheet border has been plotted this will be the horizontal distance from the tick mark 

in the top left-hand corner of the sheet. 

 

 

 

 

12.5.2 Horizontal Layout for Single Hole plots 

12.5.2.1 Maximum Number of Repetitions 

The maximum number of repetitions is the maximum 

number of times that tracks are repeated across the sheet. 

 

12.5.2.2 Distance between Repetitions 

Where there are repetitions of tracks across the sheet, this specifies the distance between them in 

millimetres. 

Offset to first 
hole on the left 
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The page layout example specified above would plot 6 tracks across the page separated by 40mm. The 

first track is from 0-8m, the second from 8-16, etc.: 

 

12.5.3 Horizontal Layout for Sections 

To plot holes on a section, the user must first create a Hole Set Definition to define the holes that are 

to be plotted and then select this Hole Set when opening the data to plot. 

 

Holes plotted on a section can either be positioned at a 

specified horizontal scale or at a fixed interval of a specified 

distance in millimetres between holes. If Scaled is selected, 

only holes whose coordinates have been entered in the their 

Headers can be plotted.  

 

Scales can be specified in either Metric (1m on the ground = so many mm’s on 

the plot) or Ratio format (1m on the plot = so many m’s on the ground). 

Which of the two formats is used in the Plot Definition editor can be set in the 

Scale Format panel of the LogCheck plotting options (select Settings > 

Options, then select the Plotting page), as shown at right. A metric format of 1 

metre on ground = 20mm on paper is equivalent to 1:50 in ratio format. 
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If the Scale Format is set to Metric, then the Section panel in the Plot Definition appears as shown on 

the left; if the Scale Format is set to Ratio, then the Section panel appears as shown below on the right: 

 

 

 

  

 

The position of holes on a section is also controlled by how the corresponding Hole Set has been 

defined. Hole Sets can be defined by creating a list of holes, specifying the coordinates of a section 

and a corridor tolerance from the section on which the holes lie and/or specifying a query: 

 

For scaled section plots: 

• if Select by section is ticked in the Hole Set Definition, the holes are plotted in their position 

as projected onto the Section defined in the Hole Set Definition.  

• if Select by section is not ticked, then a best fit line is fitted through the coordinates of the 

selected holes and the holes are projected onto this section. 

 

For fixed distance plots:  

• if Select by section is ticked in the Hole Set Definition, the holes are plotted in the order they 

occur on the section.  

• if Select by section is not ticked but Select by picking by list is, the holes are plotted in the 

order they appear in the Selected Holes list, that is the order is that in which they have been 

added to the list unless the Sorted box at the top of the list is ticked in which case they are in 

alphabetic order. 

• if only Select using a query is ticked they are plotted in alphabetic order. 
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12.5.4 Offset to Shallowest Hole Top 

The distance in millimetres from the top of the page to the shallowest hole top. Where a sheet border 

has been plotted this will be the vertical distance from the tick mark in the top left-hand corner of the 

sheet. A negative value for this offset indicates going down from the top of the page and a positive one 

going up. 

 

 

 

 

 

12.5.5 Vertical Scale 

Vertical scale is that used to plot the log data.  

Scales can be specified in either Metric (1m on the ground = so many mm’s on 

the plot) or Ratio format (1m on the plot = so many m’s on the ground). 

Which of the two formats is used in the Plot Definition editor can be set in the 

Scale Format panel of the LogCheck plotting options (select Settings > 

Options, then select the Plotting page), as shown at right. A metric format of 1 

metre on ground = 20mm on paper is equivalent to 1:50 in ratio format. 

If the Scale Format is set to Metric, then the Vertical Scale in the Plot Definition appears as shown on 

the left; if the Scale Format is set to Ratio, then the Vertical Scale appears as shown below on the 

right: 

 

 

12.5.6  Vertical Layout for Single Hole plots 

The maximum track length is the maximum length of hole 

that will be displayed going down the page before starting a 

new column across the page or starting a new page. 

 

If the entire hole does fit onto a single sheet based on the maximum no. of repetitions across the page 

and maximum track length, LogCheck writes the remaining plot into separate DXF file(s), identified 

by the hole name and a letter. For example, if the maximum no. of repetitions across the sheet is 6 and 

maximum track length is 8 metres then if the plot contains more than 6 times 8metres, that is 48 

metres of a hole, the plot will be automatically broken into multiple sheets.  

 

 

Offset to shallowest hole top 
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The following plot uses a Maximum Track Length of 8 metres. 

 

 

12.5.7 Vertical Layout for Sections 

The Vertical Alignment panel allows the holes to be aligned by: Hole Elevation, Top of Displayed 

Interval, Bottom of Displayed Interval, or a Level Chosen from the Data: 
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12.5.7.1 Alignment by Hole Elevation 

The holes are vertically aligned such that any particular elevation lies in the same vertical position on 

the sheet for all the holes 

An example of vertical alignment by hole elevation: 

 

 

 

 

 

 

 

 

12.5.7.2 Alignment by Top of Displayed Interval 

The holes are vertically aligned such that the top of the displayed interval for each hole lies in the 

same vertical position on the sheet for all holes.   

An example of vertical alignment by Top of Displayed Interval: 

 

 

 

 

 

 

 

 

 

 

12.5.7.3 Alignment by Bottom of Displayed Interval 

The holes are vertically aligned such that the bottom of the displayed interval for each hole lies in the 

same vertical position on the sheet for all holes.   

 

 

 

The collar of the hole 

on the left has an 

elevation of 513.14 

and the one on the 

right is 514.84.  
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An example of vertical alignment by Bottom of Displayed Interval: 

 

12.5.7.4 Alignment by Level Chosen From Data 

The holes are vertically aligned such that a particular level derived from the data lies in the same 

vertical position on the sheet for all holes. The user specifies the level by providing both the Data 

Type to be searched and the DBL (DBase Language) expression (see Appendix A) for the search. For 

example, the following example would use the Geology data to determine the depth of the Top of the 

Seam named J. 
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12.5.7.5 Plot all fixed length track boxes and their titles even if no data 

 

 

Ticking this option means that all fixed length track boxes and their titles are plotted when the plot is 

first created rather than when data is appended to the plot. For example, tick this if you would like the 

box for Las to appear on all the plots created with the definition even though there is no Las data for 

the particular hole or depths being plotted. 

Note though that it will only plot these track boxes and titles for those tracks whose length is fixed to 

the size of the page rather than the length of available data. To fix box lengths to the page length for a 

particular track, go to the Tracks tab, select the track you require and then tick Fix Box Length to Page 

Length: 
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12.6 Plot Definition - Sheet Annotations Page 

An example of the Sheet Annotations page: 

 

 

The parameters that can be set in the Sheet Annotations page include those for: 

• A sheet border 

• Additional text to be plotted on the sheet including that shown in the sheet’s title box 

• Depth/R.L. bars that are only displayed once per sheet as opposed to once per hole. This may 

include say RL bars on the left and right hand sides of an entire section. 

 

X and Y positions of items on the Sheet Annotations page are in millimetres and are with respect to 

the top left-hand corner of the plot. Negative Y values indicate going down from the top left-hand 

corner of the plot. 
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12.6.1 Sheet Border 

12.6.1.1 DXF Template File 

When LogCheck creates a DXF file, it builds on another DXF 

file – that is, the DXF Template File. If this field is left blank, 

LogCheck uses its own default empty template, called 

LogCheck.dxf. However, the user can specify the name of 

another DXF file in this field for LogCheck to build on.  

When LogCheck creates a new DXF file, it will look for the named DXF template file in the following 

folders in the following order: 

4. PlotPara under the folder Definitions in the current project folder. 

5. PlotPara under \LogData\Definitions. 

6. PlotPara under \Program Files\LogCheck\Definitions – this is distributed with the software. 

The user can set up their own DXF file template which be a standard company sheet or default legends, 

however, the DXF file must be in Release 12 format.  Most CAD software offers DXF Release 12 as a 

file type in their Save As option.  

 

12.6.1.2 Plot Sheet Border 

If Plot Sheet Border is ticked then when the plot is first created, LogCheck adds a sheet border and title 

box to the plot: 
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12.6.1.3 Plot Corner Ticks 

If Plot Corner Ticks is ticked then when the plot is first created, LogCheck includes corner ticks 

defining the edge of the sheet: 

 

 

12.6.1.4 Sheet Size 

If plotting either a sheet border or corner ticks, LogCheck needs to know the sheet size to be used. This 

can be A0, A1, A2, A3, A4 or A5. 

 

12.6.1.5 Orientation 

If plotting either a sheet border or corner ticks, LogCheck needs to know the orientation of the sheet to 

be used. This can be Portrait or Landscape. 
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12.6.2 Sheet Text 

Text can be added to the plot. This text will normally but not necessarily be located in the title block 

of the sheet. It can be text specified by the user or text derived from the data. The text to be plotted, its 

position, height, angle and whether a prefix describing the text is specified in the Sheet Text grid: 

   

 

The above specifications would produce the following Title Block for hole AVC030C: 

 
 

Further text entries can be added to the plot by adding rows to the above grid by going to the last row 

in the grid and then pressing the down arrow key. Rows can also be Appended, Inserted or Deleted 

and values can Blanked or Copied from Above using the Edit menu at the top of the screen. 

Each row in the grid has the following values that the user can set: 

• Text_Type:  The text type of the entry. This column has a drop-down box with available 

LogCheck variables that can be displayed on the plot. For both single holes 

and sections the following options are available: 

- Specify the user can specify a text string in the row’s 

Text_Value column 

- Project the name of the Project as specified on the Project 

Details page 

- Plot Filename the name of the .dxf file containing the plot 

- Scale the plot scale in a 1:nnnn format 

- Plot Date date the plot was created  

- Basin the holes’ Sedimentary Basin as recorded in its 

Header data 

- Lease No the holes’ Lease No as recorded in its Header data 

 

For sections the following option is available: 

- Hole Set Name the name of the Hole Set being plotted 

 

For single holes the following options are available: 

- Hole the name of the Hole being plotted 

- Page Number for use where a plot has to be split over a number 

of sheets. This is in the format nnn of nnn 

- Easting the hole’s Easting as recorded in its Header data 

- Northing the hole’s Northing as recorded in its Header data 

- Elevation the hole’s Elevation as recorded in its Header data 
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- Total Depth the hole’s Total Depth as recorded in its Header 

data 

- Hole Inclination the hole’s Inclination as recorded in its Header data 

- Hole Azimuth the hole’s Azimuth as recorded in its Header data 

- Start Date the hole’s Start Date as recorded in its Header data 

- Total Depth the hole’s Total Depth as recorded in its Header 

data 

- Geolog. Company the Geological Organization that logged the hole as 

recorded in its Header data 

- Geophys. Total Depth the hole’s Geophysical Total Depth as recorded in 

its Header data 

- Header Comment the Header Comment as recorded in its Header 

data 

- Geologist the hole’s Geologist(s) as recorded in its 

Geologists’ data 

- Driller the hole’s Driller as recorded in its Drilling data 

- Rig Type the hole’s Rig Type as recorded in its Drilling data 

 

• Text_Value:  When Text_Type is Specify, the user specified text to be plotted on the sheet. 

 

• Text_X:  The X coordinate of the text in millimetres relative to the top left-hand corner 

of the plot. For Text_Just: 

-  Left the X coordinate of the left-hand edge of the text.  

- Centre the X coordinate of the centre of the text 

- Right the X coordinate of the right-hand edge of the text 

See examples below. 

 

• Text_Y:  The Y coordinate of the text in millimetres relative to the top left-hand corner 

of the plot. Note that positive values are up and negative values down. For 

Text_Just: 

-  Left the Y coordinate of the left-hand edge of the text.  

- Centre the Y coordinate of the centre of the text 

- Right the Y coordinate of the right-hand edge of the text 

  See examples below. 

 

• Sheet_Size_Tie: On ticking this, if Text_X and Text_Y are blank and Plot Sheet Border has 

been ticked, LogCheck, enters values in Text_X and Text_Y to place the text 

in an appropriate location in the title block. If Sheet_Size_Tie is ticked, then 

when the Sheet Size or Sheet Orientation is modified the Text_X and Text_Y 

are automatically modified so that they remain in the same position in the title 

block after the modification. 

    

• Text_Just:  The text justification (Left, Right or Centre). 

 

• Text_Hgt:  The height of the text in millimetres. 

 

• Text_Ang:  The angular rotation of the text, 0 is horizontal, 90 vertical. See examples 

below. 

 

• Add_Text_Type: If ticked, a prefix is added to the text describing the text. For example, if a 

hole has an Easting of 603451.12 and Add_Text_Type is ticked the text that 

would be plotted would be Easting: 603451.12 instead of just 603451.12. 
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Examples of values for Text_X, Text_Y, Text_Just and Text_Ang: 

 

 

 

Text_Ang = 0° 

 

Text_Just = Left   Text_Just = Centre   Text_Just = Right 

 

  

 

` 

 

 

 

 

 

 

 

 

Text_Ang = 90° 

 

Text_Just = Left   Text_Just = Centre   Text_Just = Right 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Text_X Text_X 
Text_X 

Text_Y Text_Y 

Text_X 

Text_Y 

Text_X 

Text_Y 

Text_X 

Text_Y 

Text_Y 
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12.6.3 Sheet Depth Bars 

Depth and RL (Reduced Level) Bars can be defined to be displayed on plots. These bars fall into two 

categories: those that are plotted once for each sheet, called Sheet Depth Bars and those that are 

plotted once for each hole, called Hole Depth Bars. Generally, Hole Depth Bars are used for 

displaying depth bars on plots but Sheet Depth Bars can be useful for including a single depth bar on a 

Section. For example, to create a single RL bar for the entire section where the holes are vertically 

aligned based on their elevation. The Sheet Depth Bars to be displayed on the plot are specified in the 

Sheet Depth Bars grid: 

 

 

 

Depth Bars can be added to the plot by adding rows to the above grid by going to the last row and then 

pressing the down arrow key. Rows can also be Appended, Inserted or Deleted and values can be 

Blanked or Copied from Above using the Edit menu at the top of the screen. 

The vertical position of the top of Sheet Depth Bars is that of the Vertical Offset to the Shallowest 

Hole as defined in the Vertical Layout panel on the Sheet Layout page.  

Each row of the Sheet Depth Bars Grid has the following values that the user can set: 

• xOrig: the position of the depth bar relative to the left-hand edge of the sheet.  

• Variable: Depth or R.L. 

• Layer: the layer on which to plot the bar. The default layer generally used in .dxf 

plots is called 0. 

• Title_Hgt: the text height in millimetres of the title (either “Depth” or “RL”) that appear 

at the top of the bar. If set to blank or zero, no title appears on the bar. 

• Tick_Side: Left or Right. 

• Tick_Step: the depth interval between ticks. For example, a value of 0.2 means that a tick 

will be placed every 0.2 m down the hole. 

• Tick_Size: the horizontal length of each tick in millimetres. 

• Annot_Step: the depth interval between ticks that are annotated with their value – as 

generally a value is not required on every tick. Annot_Step has to be a 

multiple of the Tick_Step. 

• Annot_xOff: the distance from the bar to the start of the annotation. Where the Tick_Side is 

Left then it is the distance to the right-hand edge of the annotation and where 

it is Right it is the distance to the left-hand edge of the annotation. 

• Annot_Hgt: text height in millimetres of the depth bar values. If this is set to blank or zero 

no annotations are displayed. 
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For the Sheet Depth Bars table shown above, the resulting plot is shown below. Note the “Depth” on 

the left of the plot, and “R.L.” on the right side of the plot. The Tick_Step is 0.2, creating 5 ticks to 

the metre, and the Annot_Step is 1.0 metre. 
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12.7 Plot Definition - Stratigraphy Page 

The Stratigraphy Page is only used for sections. An example of the Stratigraphy page: 

 

 

12.7.1  Connections between Adjacent Holes 

The stratigraphic units to be connected between neighbouring holes on the section: 

• Horizons connect Horizons such as Base of Weathering. 

• Strats connect non-coal stratigraphic marker units such as Yarrabee Tuff. These are 

recorded in the Seam columns of the Geology data but are classified as Strats 

by have a value of STRATS in the Group column of the Seam Dictionary. 

• Coals connect coals. One of the following needs to be selected: 

- Seams as recorded in the Seam column of the Geology data  

- Plies as recorded in the Ply column of the Geology data 

- Seams + Plies the Seam and Ply as recorded in the Seam and Ply 

columns of the Geology data and then concatenated 

together. 
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12.7.2  Offsets from Left-Hand Edge of Holes 

Horizontal offsets of connections can be specified with respect to the holes on the left and the right-

hand side of each connection. If connections are drawn between holes, the values of the Offsets from 

Left-Hand Edge of Hole on Left and on Right alters the position of the connecting lines with respect to 

the lithology column. The effect of altering these values can be seen in the following examples where 

the width of the lithology columns is 20mm: 
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12.7.3  Layer and Text Height 

The layer is the name of the layer in the dxf file on which the stratigraphy lines and colouring are 

written. If no layer is specified, they go on the default layer 0. 

The text height is height for the text displaying the name of the Horizon, Strat or Coal Connection 

half-way between holes. If set to zero, no name appears. 

 

12.7.4  Fill with Strat / Seam Colour 

If ticked, then the connection between holes is filled in. The colour used is that in the Colour column 

of the user’s Seam Dictionary: 

 

 

If no colour is specified in the dictionary for a the Seam or Strat then the connection is coloured black. 

 

Example with Fill with Strat / Seam Colour not ticked: 
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Example with Fill with Strat / Seam Colour ticked: 

 

 

 



CHAPTER 12. PLOTTING DOWN HOLE DATA 

LogCheck Manual 295 

12.8 Plot Definition - Hole Annotations Page 

An example of the Hole Annotations page: 

 

 

The parameters that can be set in the Hole Annotations page include those for: 

• Additional text to be plotted for each hole 

• Depth/R.L. bars that are only displayed once per hole.  

 

X and Y positions of items on the Hole Annotations page are in millimetres and are with respect to the 

top left-hand corner of the hole that it applies to. Negative Y values indicate going down from the top 

of the hole. 

 

12.8.1  Hole Text 

The user can add text to each hole on the plot. This can be text specified by the user or derived from 

the user’s data. The text to be plotted, its position, height, angle and whether a prefix describing the 

text is specified by the user in the Hole Text grid: 
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Text entries can be added to each hole by adding rows to the above grid by going to the last row and 

then pressing the down arrow key. Rows can also be Appended, Inserted or Deleted and values can be 

Blanked or Copied from Above using the Edit menu at the top of the screen. 

Each row has the following values that the user can set: 

• Text_Type:  The text type of the entry. This column has a drop-down box with available 

LogCheck variables that can be displayed on the plot. The following options 

are available: 

- Specify the user can specify a text string in the row’s 

Text_Value column 

- Hole the name of the Hole being plotted 

- Easting the hole’s Easting as recorded in its Header data 

- Northing the hole’s Northing as recorded in its Header data 

- Elevation the hole’s Elevation as recorded in its Header data 

- Total Depth the hole’s Total Depth as recorded in its Header 

data 

- Hole Inclination the hole’s Inclination as recorded in its Header data 

- Hole Azimuth the hole’s Azimuth as recorded in its Header data 

- Start Date the hole’s Start Date as recorded in its Header data 

- Total Depth the hole’s Total Depth as recorded in its Header 

data 

- Geological Company the Geological Organization that logged the hole as 

recorded in its Header data 

- Geophys. Total Depth the hole’s Geophysical Total Depth as recorded in 

its Header data 

- Header Comment the Header Comment as recorded in its Header 

data 

- Geologist the hole’s Geologist(s) as recorded in its 

Geologists’ data 

- Driller the hole’s Driller as recorded in its Drilling data 

- Rig Type the hole’s Rig Type as recorded in its Drilling data 

 

• Text_Value:  When Text_Type is Specify, the user specified text to be plotted on the sheet. 

 

• Text_X:  The X coordinate of the text in millimetres relative to the top left-hand corner 

of the hole. For Text_Just: 

-  Left the X coordinate of the left-hand edge of the text.  

- Centre the X coordinate of the centre of the text 

- Right the X coordinate of the right-hand edge of the text 

See examples below. 

 

• Text_Y:  The Y coordinate of the text in millimetres relative to the top left-hand corner 

of the hole. Note that positive values are up and negative values down. For 

Text_Just: 

-  Left the Y coordinate of the left-hand edge of the text.  

- Centre the Y coordinate of the centre of the text 

- Right the Y coordinate of the right-hand edge of the text 

  See examples below. 

 

• Text_Just:  The text justification (Left, Right or Centre). 

 

• Text_Hgt:  The height of the text in millimetres. 
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• Text_Ang:  The angular rotation of the text, 0 is horizontal, 90 vertical. See examples 

below. 

 

• Add_Text_Type: If ticked, a prefix is added to the text describing the text. For example, if a 

hole has an Easting of 603451.12 and Add_Text_Type is ticked the text that 

would be plotted would be Easting: 603451.12 instead of just 603451.12. 

 

 

Examples of values for Text_X, Text_Y, Text_Just and Text_Ang: 

 

 

 

Text_Ang = 0° 

 

  Text_Just = Left   Text_Just = Centre                     Text_Just = Right 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Text_Ang = 90° 

 

Text_Just = Left   Text_Just = Centre        Text_Just = Right 

 

 

 

 

 

 

 

 

12.8.2  Hole Depth Bars 

Depth and RL (Reduced Level) Bars can be defined to be displayed on plots. These bars fall into two 

categories: those that are plotted once for each sheet, called Sheet Depth Bars and those that are 

plotted once for each hole, called Hole Depth Bars. Generally, Hole Depth Bars are used for 

Text_X Text_X Text_X 

Text_X Text_X Text_X Text_Y  Text_Y  Text_Y

  

Text_Y

  

Text_Y  Text_Y  
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displaying depth bars on plots but Sheet Depth Bars can be useful for including a single depth bar on a 

Section. The Hole Depth Bars to be displayed for each hole are specified in the Hole Depth Bars grid: 

 

 

 

Depth Bars can be added to the plot by adding rows to the above grid by going to the last row and then 

pressing the down arrow key. Rows can also be Appended, Inserted or Deleted and values can be 

made Blank or Copied from Above using the Edit menu at the top of the screen. 

The Hole Depth Bars for a hole have the same vertical position and extents as the displayed data for 

the hole they are attached to. As the Hole Depth Bars are only plotted when the plot is first created not 

when it is appended to, the depth range displayed will be that for the hole’s data that is plotted when 

the plot is created.  

Each row in the Hole Depth Bars grid has the following values: 

• xOrig: the position of the depth bar relative to the left-hand edge of the hole.  

• Variable: Depth or R.L. 

• Layer: the layer on which to plot the bar. The default layer generally used in .dxf 

plots is called 0. 

• Title_Hgt: the text height in millimetres of the title (either “Depth” or “RL”) that appear 

at the top of the bar. If set to blank or zero, no title will appear on the bar. 

• Tick_Side: Left or Right. 

• Tick_Step: the depth interval between ticks. For example, a value of 0.2 means that a tick 

will be placed every 0.2 m down the hole. 

• Tick_Size: the horizontal length of each tick in millimetres. 

• Annot_Step: the depth interval between ticks that are annotated with their value – as 

generally a value is not required on every tick. Annot_Step has to be a 

multiple of the Tick_Step. 

• Annot_xOff: the distance from the bar to the start of the annotation. Where the Tick_Side is 

Left then it is the distance to the right-hand edge of the annotation and where 

it is Right it is the distance to the left-hand edge of the annotation. 

• Annot_Hgt: text height in millimetres of the values that appear on the depth bar. If this is 

blank or zero no annotations will be displayed on the plot. 

 

 

For the Hole Text and Hole Depth Bars table shown above, the resulting plot is shown on the next 

page. Note the “Depth” on the left of each hole, and “R.L.” on the right of each hole. The Tick_Step 

is 1 metre and the Annot_Step 5.0 metres. 
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12.9 Plot Definition - Tracks Page 

The Tracks page specifies the tracks, that is columns, to display and their appearance. Tracks can be 

inserted between existing tracks, added to the end of the existing tracks, or deleted. An example of the 

Tracks page is: 

 

In this example, there are three Geology tracks and a Las track. The first track plots the LithoType as a 

Pattern. The second plots the LithoType as a Value, 10mm to the right of the left-hand edge of the first 

track. The third plots the Strength (ST) as a Bar Chart. The fourth the Short Spaced Density as a Line 

Trace. 

12.9.1   How the Tracks Page Works 

The top grid panel has columns for all the parameters that can be set for plotting a track. The values in 

the bottom panel change depending on which row in the top grid panel is currently selected. 

  

 

 

 

 

 

 

 

 

Setting values in the top grid 

panel updates the 

Note that the grid at the top only shows the 

abbreviated name for each parameter, whereas the 

panel at the bottom shows a fuller description of each.  

Selecting a row in 

the top grid panel 

alters the values in 

the bottom panel to 

those for the new 

selected row 
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corresponding values in the bottom panel and setting values in the bottom panel updates the corresponding 

values in the top grid panel.  

To view the remaining columns in the grid panel, drag the knob in the scroll bar. 

 

The first four columns of the grid panel (XOrig, Width, Data_Type and Variable) are the Track 

identification columns and as the grid is scrolled, they remain fixed as the first four columns while the 

subsequent columns are moved left. After scrolling one column to the left, the grid shows: 

 

Notice that the Disp_Type column has “disappeared”, and the remaining columns to the right are 

moved to the left. 

The advantage of the grid panel at the top is that one can see the value of the same parameter across 

multiple tracks. This can be useful for example if one wants to ensure that the Text Height is the same 

for each track. 

The bottom panel of the Tracks page does not include the Track identification columns (XOrig, Width, 

Data_Type and Variable) and the current row in the top grid panel needs to be checked to determine 

which track is currently shown in the bottom panel. This panel has six panels:   

• Display Type panel 

• Display Options panel  

• Horizontal Scale panel  

• Vertical Scale panel 

• Track Title panel 

• Boundary Box panel 

 

The Track Identification variables and all the panels are described below. 

 

 

First four columns 

are fixed. Drag the scroll 

bar. 

Layer is now the 

fifth column. 
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12.9.2   Track Identification Columns 

The Track Identification Columns are: 

 

• XOrig the horizontal position in mm’s of the left-hand edge of the track relative to 

the position of each hole. By convention, the left-hand edge of the lithology 

pattern track is usually given an XOrig of 0.0. 

• Width the width in mm’s of the track 

• Data_Type the Data Type of the hole data to be used 

to populate the track. This is selected 

from a drop-down box which includes not 

only data supplied by the user such as 

Geology, Defects, Las but also calculated 

data such as Seam Composites, Run 

RQD’s, Fracture Frequencies, Point Load 

Indices 

 

• Variable   the variable in the specified Data_Type to be used to populate the track. 

Multiple variables separated by columns can be entered but if multiple 

variables are entered then the only available options for Disp_Type are Value 

and Description. 

The name of the variable can either be typed into the grid column or selected 

from a list of valid variables for the Data_Type. This list can be displayed by 

pressing the F8 function key. For example, if Data_Type is set to Geology 

and F8 is pressed when the cursor is in the Variable column, the following 

menu is displayed: 
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Each item selected from this list will be appended to any already displayed 

in the Variable column. 

If the user types in a Variable name that does not exist in the specified 

Data_Type it is not accepted and a Warning similar to the following is 

displayed: 

 

12.9.3 Track Display Type Panel 

The manner in which the track’s selected data is displayed is selected in the 

Display Type panel. The available options will depend on the variables that have 

been selected. What is more, the manner that some options display the data 

depends on whether the selected data is character or numerical. The available 

display types are: 

 

 

 

 

 

• Value this option is available for all data including where Variable contains multiple 

variables separated by commas. 

 

Character Variable Numerical Variable Multiple Variables 
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• Description This option is available for all data including where Variable contains 

multiple variables separated by commas. 

 

Character Variable  Numerical Variable Multiple Variables 

 

 

 

 

 

 

 

 

 

• Bar Chart This option is available for all character and numerical variables but is best 

suited to values recorded over an interval such as Estimated Strength or Ash 

rather than data recorded at depth points such as Defect Type or geophysical 

readings. For character variables the horizontal scale will be the distinct set of 

values for the variable whereas for numerical variables it will be a scale bar. 

For more information on the Horizontal Scale see the section below on Track 

Horizontal Scale.  

BarChart can be used for point depth data but in the case of point depth data 

the bar for each value is drawn from the depth half-way between the previous 

and current value to half-way between the current value and the next value.  

 

  Character Variable Numerical Variable 
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• Line Trace This option is available for all character and numerical variables but is best 

suited to values recorded at depth points such as Defect Type or geophysical 

readings. For character variables the horizontal scale will be the distinct set of 

values for the variable whereas for numerical variables it will be a scale bar. 

For more information on the Horizontal Scale see the section below on Track 

Horizontal Scale.  

Line Trace can be used for data recorded over an interval such as Estimated 

Strength or Ash but in the case of data recorded over an interval the line 

between a value and the next value is drawn from the depth at the half-way 

point of the current interval to the half-way point of the next interval.  

 

  Character Variable Numerical Variable 

 

 

 

 

 

 

 

 

 

 

• Symbol This option is available for all character and numerical variables but is best 

suited to values recorded for at depth points such as Defect Type or 

geophysical readings. This option produces a similar display as Line Trace but 

places a cross at each data point rather than joining the data points with lines. 

 

  Character Variable Numerical Variable 

  

 

 

 

 

 

 

 

 



CHAPTER 12. PLOTTING DOWN HOLE DATA 

 306  LogCheck Manual 

• Boundary Depth This option is available for all character and numerical variables but is best 

suited to values recorded over an interval such as Seam or Ash. It displays the 

depths at the top and bottom of each unit. For example, it can be used for 

displaying the top and bottom depths of seams by selecting Data_Type of 

Geology and Variable of SEAM: 

 

 

 

 

 

 

 

 

 

 

A tick is plotted along with the depth. If Left Justification is selected for the 

depth text then the tick will appear to the left of the text and if Right 

Justification is selected then the tick will appear to the right.  

    

• Unit Thickness This option is available for all character and numerical variables but is best 

suited to values recorded over an interval such as Seam or Ash. It displays the 

thickness of each unit. For example, it can be used for displaying the top and 

bottom depths of seams by selecting Data_Type of Geology and Variable of 

SEAM: 
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• Pattern This option is available for all character variables whose values are limited to 

those specified in the dictionary for the Data_Type and who are recorded over 

an interval, for example LithoType or Rock Mass Unit Type. It displays a 

pattern for each value that has a pattern and/or fill recorded for it in the 

Data_Type’s dictionary: 

 

 

The user can specify one or two patterns and a fill for each code and these will 

all be superimposed on top of each other. When editing the dictionary, the 

names of the available Patterns and Fills can be seen by turning on the 

dictionary menu by selecting View > Display Keypad/Dictionary Menu. 

An example of Display_Type Pattern for LithoType data: 
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• Defect Line This option is only available for the Variable DEFECT in Defect or Scanner 

data. It plots a line for each defect. It uses the dip angle recorded in the defect 

field named A1 and its shape as recorded in the defect field named Sh. 

This is a symbolic representation rather than a display of the actual defect. In 

particular, even though the line is plotted at its actual angle, if the width of the 

column does not match the width of the core scaled as per the vertical depth 

scale then the length of core affected by the defect will be different to that 

recorded in the data variable DefLen. For example, if the vertical scale is 1:20 

and the original core had a diameter of 61mm, then the column on the defect 

line column on the plot needs to be 3.05mm wide. If the column is wider, then 

the defect will appear to affect more of the core than it actually does.     

An example of Display_Type Pattern for Variable RT and Display_Type 

Defect Line for Variable DEFECT: 

 

This depicts a broken Rock Mass Unit followed by: 

•a low angle planar defect 

•a high angle stepped defect 

•a low angle undulose defect 

•a medium angle irregular defect 

•a low angle concave / convex defect  

 

 

 

 

 

 

 

 

 

• Tadpole This option is only available for the Variable A1 or AN (dip angle) in Defect 

or Scanner data. It plots a tadpole for each defect. The horizontal position of 

the tadpole indicates the dip of the defect and the tail indicates the orientation 

down dip as recorded in the variable DO. This data can only be recorded on 

orientated core or scanner interpretations. An example of a tadpole plot: 
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12.9.4   Display Options Panel 

The Display Options panel of the Tracks page controls the way data is displayed on the plot.  

 

 

This panel includes the following parameters and the parameter’s column name in the main grid 

shown in bold: 

• Layer Name (Layer): The plot layer for the track. This is a user-defined layer name. When 

displaying the resulting .dxf file in a viewer such as AutoCad’s TrueView, layers can be 

turned on or off.  If a layer is not specified, the entity is plotted on Layer 0. 

 

• Combine Identical Adjacent Displays (Comb_Dupl): combines identical adjacent displays. 

This is only available where the Display_Type is Value, Description, Boundary Depths, Unit 

Thickness or Pattern. Where adjacent units would display the same then they are combined 

into a single unit.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

With the following example the siltstone has been divided in the data into three separate units 

since each unit has a slightly different colour. If Comb_Dupl is off as with the diagram on the 
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left then both the pattern and text shows the three separate siltstones whereas if it is on then 

the three are shown as a single unit.  

 

                                                                  

 

 

 

Another example of having Comb_Dupl on and off when plotting Defect Descriptions:  

 

 

 

 

 

• Display Lithology Detail (Brightnesses & Grain Sizes) (Detail_On): this determines if coal 

brightnesses are displayed. It is only available for Display_Types of Description, Boundary 

Depths, Unit Thickness or Pattern. In addition for CoalLog data, if Display_Type is Pattern 

then if Detail_On is on, then the pattern used is based on the data’s LithoTypes and 

Combine Identical Adjacent 

Displays option on 

Combine Identical Adjacent 

Displays option off 
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Lithological Qualifiers not just the LithoType. In other words, not only are coal brightnesses 

shown but also grain and clast sizes for clastic material.  

 

The examples below display Pattern, Description, Boundary Depths and Unit Thickness for an 

interval. The image on the left has Detail_On turned off and the image on the right has it 

turned on. 

 

 

• Display Coal Zones Only (Coal_Only): if this is set then only the coal zones are displayed. 

This option is only available for the Display_Type of Pattern. This can be particularly useful 

when doing sections and not wanting to be distracted by the non-coal units.  
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The example below, displays the previous images, however, now the Coal_Only flag has been 

turned on. 

 

  

 

 

 

• Text Justification (Text_Just): can be Left, Centre, Right or Value. Left justifies the text to 

the left of the track. Centre justifies it to the centre. Right justifies it to the right. Value locates 

the text according to its value.  
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Text_Just can be selected for Display_Types of: Value, Description, Boundary Depths and 

Unit Thicknesses. For Display_Type of Symbol or Tadpole, Text_Just cannot be selected 

rather it is automatically set to Value 

 

The Text_Just option of Value can only be selected for Display_Type of Value and then only 

if the Variable being displayed is one whose values come from a data dictionary. 

 

Below are examples of weathering values plotted with Left, Centre, Right and Value 

justification: 

 

                                                                            

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Text Height (Text_Hgt): is the height of the displayed text in millimetres. It is used for all 

Disp_Types except Bar Chart, Line Trace, Pattern and Defect Line. 

 

• Text Orientation (Text_Orient) is the angle counter-clockwise from the horizontal for plotting 

text. It is used when Disp_Type is Value, Description, Boundary Depths or Unit Thickness. 

 

• Decimal Places (Text_NDec) is the number of digits to display after the decimal point. It is 

used when Disp_Type is Value, Boundary Depth or Unit Thickness. For Disp_Type Value 

though it is only used when Variable is numeric variable. 

• Colours enables the user to select the colours for displaying data. Colours can be selected for 

both Entities and Background for all Disp_Types. In addition, the Fill colour can also be 

selected for Disp_Types of Bar Chart, Line Trace, Pattern and Tadpole. 
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A single colour can be used for all the data displayed in a track or different colours can be 

used based on the value of the variable being plotted or based on any other variable that is on 

the same record in the data as the variable being plotted. For example, one could plot a pattern 

for each LithoType in a hole but then colour these patterns according to their Estimated 

Strengths or one could plot a bar chart for Ash and colour its fill according to its Calorific 

Value. 

 

To assign a single colour for all the data displayed in a track then in the box under the title 

Colour No. or Variable enter the AutoCAD colour number required (see Appendix ?? for the 

AutoCAD colour numbers). After the colour number is entered, its actual colour will appear 

on the screen in the square to the right of the where the colour number has been entered. For 

example: 

 

 

 

If the Colour Nos for Entity and Fill are left blank then when plotted they will be black when 

displayed on a white screen or plotted on paper and white when displayed on a black screen. 

 

If the Background Colour No is left blank then the background will be left uncoloured. 
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The above Colour No specifcations would generate the following results for a LithoType 

Pattern plot and an Estimated Strength Bar Chart: 

 

                                                                                                    

 

For the Pattern plot the LithoType symbols are in red, the fill of the coals and the carbonaceous bars 

are in cyan and the background is in yellow.. 

For the Bar Chart, the outline of the bar is in red, the fill of that bar chart is in cyan and the 

background, that is the area to the right of the Bar Chart, is in yellow. 

To colour images according to the value of one of the variables in the data then instead of specifying 

an AutoCAD colour number in the Colour No. or Variable box, enter the name of the variable to use 

for colouring. The names of all the data variables can be found at the top of the screen when editing 

the data. 
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In order to use a variable, it must either be a character variable which has a dictionary lookup or a 

numerical variable. For example, as Sample Numbers can contain non-numeric characters and do not 

have dictionary lookups, they cannot be used for specifying colours. 

How variables control colours depends on whether they are character or numerical variables. For 

character variable such as LithoType, it looks up the LithoType in the dictionary and then uses the 

colour number in the dictionary Colour column if being used for Entities, uses that specifed in the 

FillColour column if being used for Fills and uses that specifed in the BgColour column if being used 

for the Background: 

  

 

The Geology dictionary supplied with the CoalLog version of LogCheck already has the CoalLog 

standard LithoType colours setup in the Colour and BgColour columns of the LithoType dictionary. 
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The following examples show the LithoType value being used to colour a LithoType pattern plot: 

         

               

                                                                                               

 

In order to colour a plot using a numerical variable it is first necessary to create a Colour Scale 

Definition (see Creating and Editing Colour Scale Definitions) and then to specify in the Colour panel 

of the Plot Definition the name of the Variable and the name of the Scale Definition to be used. When 
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LogCheck is creating the plot, it searches for the specified Colour Scale Definition firstly in the 

ColourScale folder in the Definitions folder of the project folder of the data and if a ColourScale 

Definition of that name does not exist there it looks for it in the ColourScale folder of the Definitions 

folder in the LogCheck data folder which is generally called C:\LogData. 

The following plots show two example Ash bar charts of the same hole interval, however, the first has 

the fill of the bar chart coloured according to the actual Ash value whereas the fill of the second is 

coloured according to the Volatile Matter values for the intervals. Both examples, not only show the 

resulting plot but also the Plot Definition Colour panel and the Colour Scale Definition used to 

generate them. 
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With this second example it is notable that at around 31.5 metres there is a unit that is relatively higher 

in Volatile Matter despite the fact that it is also high in Ash. 
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12.9.5   Horizontal Scale Panel 

The Horizontal Scale panel of the Tracks page controls both the horizontal scale and how it is displayed for 

each track. Specification of the Horizontal Scale is required for Disp_Types of Bar Chart, Line Trace, 

Symbol or Tadpole. It is also required where Disp_Type is Value and the Text_Just is set to Value.  

  

 

 

Only one of the two panels Coded Data and Numerical Data is enabled depending on whether the 

Variable being plotted records coded values with dictionary lookups or numerical values. 

12.9.5.1   Coded Data Panel 

The Coded Data options (Coded_Scale) controls which values are used for the horizontal scale. 

 

 

The available options are to use:  

• All Codes  all codes from the dictionary for the selected Variable, regardless of whether 

they occur on the plot or not. 

• Plotted Codes  only those codes occurring on the plot. 

• Specify  only those codes that are specified. The specified codes should be separated 

by commas. Any values that are not included in this list will not appear on the 

plot. 

 

 

For the All Codes and Plotted Codes options, the codes occur on the scale in the order they appear in 

the dictionary whereas for the Specify option they appear in the order that they are specified. 

Therefore, Specify can also be used to plot all the codes but in an order different to that in which they 

appear in the dictionary.  
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The example below illustrates the effect of these three options: 

 

12.9.5.2   Numerical Data Panel 

The information in the Numerical Data panel controls the scale for plotting numerical data.  

The values (LVal and RVal) for the left and right-hand 

edges of the track must be specified. These are in the 

units of the data. To plot in reverse, simply swap the 

left and right-hand edges so that the left-hand edge 

value is greater than the right-hand one. 

 



CHAPTER 12. PLOTTING DOWN HOLE DATA 

 322  LogCheck Manual 

If the Logarithmic Scale box (Log) is ticked then a logarithmic scale will be used. This is useful to see 

more resolution of low values while still being able to see higher values. When using a logarithmic 

scale both LVal and Rval must be greater than zero. 

The following example shows on the left a Resistivity log plotted with left and right-hand values of 0 

and 180 on a non-logarithmic scale and the on the right the same log with left and right-hand values of 

5 and 180 but on a logarithmic scale: 
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12.9.5.3   Specifying the Horizontal Scale Bar 

To display a horizontal scale bar at the bottom of a track, tick Plot 

Horizontal Scale Bar (Scale_On).  

The Vertical Offset (Scale_Y) moves the scale bar in relation to the 

end of the track. A negative value moves the scale bar down and a 

positive value up.  

The Text Height (Scale_Hgt) specifies in mm’s the height of the 

ticks, the scale annotation and the scale title.  

The Tick Direction (Scale_Tick) controls whether the ticks go up or 

down. 

The Scale Title (Scale_Title) can be: 

• None no variable name is plotted on the scale bar 

• Code name of the variable being plotted 

• Description description of the variable being plotted 

 

The following examples display horizontal scale bars for a downhole geophysical plot. The one on the 

left has Scale_Title set to Code for both DENB and GRDE and has Scale_Tick set to Up for DENB 

and set to Down for the GRDE. The example on the right has Scale_Title set to Description and 

Scale_Tick set to Down for both DENB and GRDE, however, it has Scale_Y set to 0 for DENB and -

8.0 for GRDE. 

  

 

 

 

12.9.5.4   Plotting Horizontal Scale Graticule 

To plot vertical graticule that aligns with the annotation displayed on 

the Horizontal Scale Bar, tick Plot Scale Graticule (SGrat_On). This 

can be checked even if no Horizontal Scale Bar is displayed.  

The following example show the bottom of two Short Spaced Density plot. The one on the left has no 

horizontal scale graticule whereas the one on the right does.   
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12.9.6   Vertical Scale Panel 

This panel enables specification of Depth Graticule. 

 
 

Tick Plot Depth Graticule (DGrat_On) to include horizontal graticule for depths. Graticule Interval 

(DGrat_Step) enables specification of the interval between depth graticule lines and if Text Height 

(DGrat_Hgt) is non-zero, depth values will be displayed on the right-hand edge of the track.   

 

The following example shows two plots of Short Spaced Density. The one on the left without any 

depth graticule and the one on the right with depth graticule at an interval of 0.2 metres: 
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12.9.7   Track Title Panel 

The Track Title panel enables the specification of title for the 

track.  

The Vertical Offset (Title_Y) specifies the vertical distance from 

the top of the track to the bottom of the title text. 

The Text Height (Title_Hgt) specifies in mm’s the height of the 

title text.  

The Text Angle (Title_Ang) specifies the angle anti-clockwise 

from the horizontal to plot the title text. 

The title type (Title) can be: 

• None no title is plotted on the track 

• Code name of the variable being plotted 

• Description description of the variable being plotted 

• Specify the user can specify their own title (Title_Text) 

 

 

The following example displays the track title for a geophysical plot. The title for the Gamma track 

has Title_Y set to 0.0 and Title to Description whereas the Density track has Title_Y set to 3.0 and 

Title to Specify and Title_Text to High Res. Density. 
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12.9.8   Boundary Box Panel 

A box can optionally be drawn around the track (Box) and its 

length optionally fixed to the page length (Box_Fixed). These 

options are set in the Boundary Box panel: 

 

The following example shows the Lithology and Seam names for an interval. Both figures have a Box 

plotted around the Lithology track but only the one on the right has a box around the Seam track: 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

When plotting a single hole, it can be split over several pages 

by setting the Maximum Track Length on the Sheet Layout 

page:   

 

If this is the case and one is plotting boxes around a track, the last page in the sequence of pages will 

look different to the previous pages as the boxes on this page will be the length of the deepest depth 

rather than the length of the page. This is particularly noticeable if plotting data from different data 

types that each have different final depths. To overcome this, tick Fix Box Length to Page Length 

(Box_Fixed). 



CHAPTER 12. PLOTTING DOWN HOLE DATA 

LogCheck Manual 327 

12.9.9 Summary of Tracks Parameters 

The parameters that can be set in the Tracks tab, in the order they appear in the Tracks grid are: 

• XOrig Offset from the zero point of the particular hole to the left edge on the plot. 

• Width  Width in mm of the track. 

• Data_Type  Data type of the data used to populate the track. This column displays a 

drop down box with the available data types. 

• Variable Variable or variables being plotted in the track 

• Disp_Type The display type, for example, Value, Description or Histogram. 

• Layer The plot layer for the track.  

• Comb_Dupl  Combine identical adjacent displays. 

• Detail_On Display detailed lithology. 

• Coal_Only Display only coal zones. 

• Text_Just Text justification – left, right or centre. 

• Text_Hgt Text height (mm). 

• Text_Orient Text orientation in degrees anti-clockwise from the horizontal 

• Text_NDec For numeric data, the number of numerals after the decimal point to 

display 

• Colour  The AutoCad colour number or variable for colouring the entities in the 

track 

• Colour_Scale The name of the ColourScale Definition to use when colouring the entities 

according to a numerical variable 

• Fill_Colour The AutoCad colour number or variable for colouring the fill in the track 

• Fill_Scale The name of the ColourScale Definition to use when colouring the fill 

according to a numerical variable 

• Bg_Colour  The AutoCad colour number or variable for colouring the background of 

the track 

• Bg_Scale The name of the ColourScale Definition to use when colouring the 

background of the track according to a numerical variable 

• Coded_Scale Horizontal scale type (All, Plotted or Specify). 

• Specified_Codes  If Coded_Scale is set to Specify, list of specified codes to be plotted on a 

histogram. 

• LVal, RVal Left and right-hand limits of the horizontal scale. 

• Log Use a logarithmic scale for the horizontal scale. 

• Scale_On Show the horizontal scale. 

• Scale_Y The vertical offset of the horizontal scale. 

• Scale_Hgt The horizontal scale text height (mm). 

• Scale_Tick Tick direction of the horizontal scale (up or down). 

• Scale_Title Optional title for the horizontal scale. 

• SGrat_On Option to plot horizontal scale graticule. 

• DGrat_On Option to plot the depth graticule. 

• DGrat_Hgt Depth graticule annotation height (mm). 

• DGrat_Step Depth graticule interval (mm). 

• Title_Y Vertical offset of title (mm). 

• Title_Hgt Track title height (mm). 

• Title_Ang Track title orientation (degrees). 

• Title Title for a track (none, variable name, variable description or specify) 

• Title_Text Text to plot for the title if Title is set to Specify 

• Box Draw a box around the track and its title. 

• Box_Fixed Fix box length to page length. 
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12.10   Plotting a Legend 

A legend of the patterns and fills can be generated to accompany downhole plots. To create a legend, 

open the appropriate category of the dictionary, for example, Lithology (File > Open > Dictionary) 

and select File > Plot.  

Next select items to include:  

 

 

 

 

 

 

 

• All items in Dictionary Category will display All items in Dictionary Category. 

• Select Items enables the user to select which items to include. For example: 
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• Select Data whose Items are Required. This can be for one or more holes and for the entire 

hole or part of the hole, for example: 

 

If using CoalLog and plotting Lithologies the additional option Include Lithological Qualifiers 

Symbols is displayed. If this is ticked then not only the patterns and fills for each LithoType are 

displayed but also those for all their Lithological Qualifiers. 

Next a Plot Legend Definition is asked for: 

 

See the next section for further information on creating and editing a Plot Legend Definition. 
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Next, the folder and filename for the generated plot is prompted for: 

 

 

An example plot of the legend for the LithoTypes that occur in AVC030C: 
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12.10.1 Creating a Plot Legend Definition 

To create a Plot Legend Definition, select: 

 

 

The user is then prompted for the location and name for the Plot Legend Definition: 
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The new Plot Legend Definition will then display for editing: 

 

 

There are three panels in this screen: 

12.10.1.1 Sheet Border 

For a description of the options in this panel, see Section 12.6.1 Sheet Border for downhole plots. 

12.10.1.2 Legend Layout 

This includes: 

• No. of Columns Number of columns across each page of the legend. 

• No. of Rows Number of rows down each page of the legend. 

• Top Left Corner Position Offset from the Top Left corner of the sheet to the top left corner 

of the first pattern box.  

• Pattern Box Size The dimensions in mm’s for each pattern box 

• Offset between Boxes Distance between pattern boxes 

• Annotation Height The size of the annotation describing each pattern  

12.10.1.3 Sheet Text 

For a description of the options in this panel, see Section 12.6.2 Sheet Text for downhole plots. 
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Chapter 13  
 Geotechnical Extension 

 

 

 

By the end of this chapter, you will be able to understand: 

 

▪ The setting up of Groups in Defect Dictionaries. 

▪ The LogCheck Geotechnical data formats. 

▪ Generating Geotechnical summaries. 
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13.1 The Defect Dictionary Group Column 

The Group column is used by LogCheck’s audits, summaries and statistical tools. For most dictionary 

categories it is not required, however it is required for the following Defects Dictionary categories: 

13.1.1 Defects Dictionary – Rock Mass Unit Category Groups 

Group is required for all items in the Rock Mass Unit Category of the Defects Dictionary so that 

procedures calculating Rock Quality Designator (RQD), Fracture Frequency and Defect Spacing know 

how to calculate these for each RMU. The Group must be one of BROKEN, DEFECTS, 

NO_SAMPLES, OPEN and UNBROKEN. An example of the Rock Mass Unit Category: 

 

13.1.2 Defects Dictionary – Defect Type Category Groups 

In order to correctly calculate RQD, Fracture Frequency and Defect Spacing, the Defect Type category 

of the Defects Dictionary needs INDUCED against any Defect Types that are induced and BAND 

against any solid bands so that they are not included in the calculation. It also needs ZONE against 

anything that represents a broken zone so that it is treated appropriately in the calculations. 
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13.1.3 Defects Dictionary – Intact Category Groups 

In order to ignore any intact defects when calculating RQD, Fracture Frequency and Defect Spacing, 

the Intact category of the Defects Dictionary needs INTACT against any values that indicate that the 

defect is intact: 

 

13.1.4 Defects Dictionary – Defect Continuity Category 
Groups 

In order to plot any defects that are discontinuous across the core as discontinuous, any Defect 

Continuity values that represent Discontinuous Defects need to have DISCONTINU in the Group 

column of the Defect Continuity Category in the Defects Dictionary: 
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13.2 LogCheck Geotechnical Data Types 

13.2.1 Defect Data 

Defect data consists of two parts: 

• Rock Mass Unit (RMU) details, from the Depth column up to but not including the Defect 

column. Each RMU has uniform geotechnical characteristics. It is a broader grouping than just 

a single lithology and will often consist of multiple lithology units. 

• Defect details for each defect, starting with the Defect column.  

The RMU variables in the CoalLog version of LogCheck are: 

• CalcThick Thickness of the RMU interval, that is the difference as calculated by LogCheck, 

between the base depths of this interval and the previous one  (read-only) 

• Depth Base depth of each RMU. The interval top is assumed to be the base depth of the 

previous unit. Interval base depth must be greater than the base depth of the 

previous unit. Blank Depth values are used in LogCheck to indicate that the row 

in the table is a continuation of the data for the lithological unit on the previous 

row. 

• RT RMU Type – broken zone (B), defects (D), core loss (L), etc. RT is used by 

LogCheck to guide it on how to calculate summary information such as Rock 

Quality Designator (RQD), Fracture Frequency or Average Stick Length for units 

not containing any defects. 

• We Weathering – fresh (F), distinctly weathered (D), etc. 

• Al Alteration – fresh (F), distinctly altered (D), etc. 

• ES  Estimated strength – firm (C3), loose (S1), medium strength rock (R4), etc. 

• BS Bed spacing – irregular spaced bedding (IR), thinly bedded (TB), etc. 

• BD Bedding dip angle 

• MS Moisture Sensitivity – low sensitivity (L), high sensitivity (H), etc. 

• Pl Plasticity – brittle (B), high plasticity (H), etc. 

 

The only mandatory variables for RMU’s are Depth and RT. 

 

The Defect variables in the CoalLog version of LogCheck are: 

• Defect The mid-point depth in metres for the defect, see figure on the next page. 

• DefLen The length in metres of core affected by the defect, see figure on the next page. 

• DT Defect Type of defect – bedding plane (BP), joint (JN), vein (VN), etc. 

• DI Flag indicating if the defect is intact (I). 

• DC Defect Continuity, whether the defect crosses the entire width of core. If not, then 

it does not constitute a break in the core.  

• A1 & A2 Minimum and maximum dip angle in degrees. 

For individual defects only A1 is used but A2 is 

also used when describing broken zones. 

Different users have different conventions as to 

whether the angle is measured relative to the 

core axis or relative to the perpendicular to the 

core axis. In general, the Australian coal 

industry uses the second convention, that is  

relative to the perpendicular to the core axis. It does not overly matter which 

convention is selected, just that everybody in the organisation is using the same 

convention. 

Angle relative to 

perpendicular of 

the core axis 

Angle relative to 

the core axis 
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• DO Defect dip orientation (azimuth) in degrees. That is the direction down dip of the 

defect. Having this data is rare as it can only be obtained from either oriented 

core or acoustic scanner interpretation. 

• DOM Dip orientation method – directly measured from reference line (D), measured 

from televiewer (A), etc. 

• Sh Surface shape of the defect – planar (P), stepped (S), etc. 

• Ro Surface roughness – slickensided (K), smooth (S), etc. 

• Width Infill Perpendicular Width in millimetres, see figure below. 

• PT Primary Infill Type – calcite (CA), plant fragments (PF), etc. 

• ST Secondary Infill Type – carbonaceous remains (XR), carbonate (CB), etc. 

• Mo Infill mode – blebs (L), surface completely coated (C), etc. 

• IS Infill strength – medium strength rock (R4), firm (C3), etc. 

• IP Infill plasticity – brittle (B). high plasticity (H), etc. 

 

Figure demonstrating Defect Depth, Defect Length and Perpendicular Width: 

 

The mandatory Defect fields are Defect and DT though DefLen can also be set by the database 

manager to also be compulsory, see Section 3.4.1 CoalLog Validations Settings in Chapter 3. 

An example of Defect data: 

 

This shows the first 285.18m of the hole was Open followed by a Defects RMU to 289.76m with 

joints at 285.18m and 287.48m, and then an Unbroken RMU to 291.29m. 
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The following table describes how LogCheck calculates RQD, Fracture Frequency and Defect Spacing  

 

RMU Type 

Code 

Description RQD Fracture 

Frequency 

Defect 

Spacing 

O Open blank blank blank 

L Core Loss blank blank blank 

N Not Recorded blank blank blank 

U Unbroken Core 100 0 Calculated 

D Core with Defects Calculated from the individual recorded defects 

B Broken Zone 0 50 0.02 

S Soil Properties 0 50 0.02 

 

13.2.2 Acoustic Scanner Analysis Data 

Acoustic Scanner Analysis data records just the results of interpretation of acoustic scanner data rather 

than the actual acoustic scanner data. 

The RMU variables in the CoalLog version of LogCheck are: 

• Depth Base depth of each lithological unit. The interval top is assumed to be the base 

depth of the previous unit. Interval base depth must be greater than the base depth 

of the previous unit. Blank Depth values are used in LogCheck to indicate that the 

row in the table is a continuation of the data for the lithological unit on the 

previous row. 

• RT RMU Type – broken zone (B), defects (D), core loss (L), etc 

 

Both Depth and RT for each RMU. 

 

The Defect variables in Acoustic Scanner data are: 

• Defect The mid-point depth in metres for the defect, see figure on the next page. 

• DefLen The length in metres of core affected by the defect, see figure on the next page. 

• DT Defect Type of defect – bedding plane (BP), joint (JN), vein (VN), etc. 

• DI Flag indicating if the defect is intact (I). 

• An Dip angle in degrees.  

• DO Defect dip orientation (azimuth) in degrees. That is the direction down dip of the 

defect.  

• DC Defect Continuity, whether the defect crosses the entire width of core. If not, then 

it does not constitute a break in the core.  

 

The mandatory Defect fields are Defect and DT. 
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An example of Acoustic Scanner data: 

 

13.2.3 Point Load Test Data 

In a point load test, a stick of core is subject to compressive forces in either an axial (along the axis of 

the core) or diametral (across the core) directions, until the core fails. The force measured is the force 

in kN at which the core fails. An established testing procedure involves: 

1. An initial diametral test, where pressure is applied across the core, until it breaks into two 

sticks of core. 

2. A diametral test is then applied to each of the two sticks derived from 1.  

3. This usually results in four pieces of core on which axial tests are done.  

 

Examples of valid diametral failures 

are as shown on the right: 

 

 

 

 

Examples of valid axial failures are as 

shown on the right: 

 

 

 

 

Examples of invalid failures are 

shown on the right (diametral on the 

left, and axial on the right): 
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The results can be standardised to a 50 mm diameter core and then averaged for a sample. These are 

known as Point Load indices. For test results to be included in the calculation of Point Load Indices, 

they must be: 

• A valid test, 

• If it is a diametral test, the core length must be greater than the diameter, or 

• If it is an axial test, the core length must be less than or equal to the diameter and greater than 

0.3 times the diameter. 

The Point Load data variables in the CoalLog version of LogCheck are: 

• Depth The depth to the base of the sample. 

• Thickness  The original length of the sample. 

• SampState Either wet (W) or dry (D). 

• SampNumb Sample Number 

• TestId A unique number within each sample to uniquely identify a particular test 

sample. 

• TestMidDep The depth at the mid-point of each test sample. 

• TestType Refers to the direction that the pressure was applied to the core, either diametral 

(D) or axial (A). 

• PlatenSep Separation of the platens in the testing device. For diametral tests this will be 

the core diameter. For axial tests, it is the length of the individual sample being 

tested. 

• Width The width of the core perpendicular to the load direction. For diametral tests, 

this will be the length of the individual sample. For axial tests, it will be the 

core diameter. 

• Load The force in kN at which the core failed. 

• FailMode Mode of failure – invalid test as shown in the previous diagram (I), bedding 

plane (B), joint (J) and penetrative (P). 

• Index Point Load Index (MPa) calculated by LogCheck for each sample. (read-only) 

 

Depth, Thickness and SampState are required for each initial sample from the core. TestId, 

TestType, PlatenSep, Width and FailMode are required for each test sample.  

Some non-CoalLog versions have Length and Diameter instead of PlatenSep and Width. In this 

case, Length for diametral tests will be the length of the core perpendicular to the load direction and 

for axial tests, it will be the platen separation. Diameter for diametral tests will be the platen 

separation and for axial tests, it will be the core diameter. 

An example of Point Load Test data: 

In this data display, for the sample 

with a base depth of 285.30, Test Id. 

1 is the initial diametral test, Test Ids. 

2 and 3 are the tests on the two sticks 

of core derived from Test Id. 1 and 

Test Ids. 4, 5 and 6 are the results of 

the axial tests on the sticks of core 

derived from the diametral tests. 
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13.2.4 Geotechnical Laboratory Test Data 

Geotechnical Laboratory Test Data records the results from Laboratory Tests 

The Geotechnical Laboratory Test variables are: 

• Depth Base depth of sample in metres 

• SampNumb Sample number for sample 

• From From Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• To To Depth of the sample as determined from the drillhole’s Geology data. 

         (read-only) 

• Thickness Sample thickness as automatically calculated from the difference between its 

From and To depths.      (read-only)  

• TestType Type of test such as UCS for Uniaxial Compressive Strength or ITS for Indirect 

Tensile Strength 

• Result Result value of test 

• Units Result’s units 

• Comments Comments 

 

The variables SampNumb, TestType, Result and Units are required for every record. 

 

An example of Geotechnical Laboratory Test Data: 
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13.3  Geotechnical Summaries 

Geotechnical Summaries are summaries LogCheck generates from its geotechnical data. The 

summaries that it can generate are: 

• Rock Mass Units 

• Drill Run RQD 

• Defect Spacing 

• Fracture Frequency 

• Point Load Indices 

 

To open the required summary, select: 

 

 

 

For all Geotechnical Summaries, if one chooses to generate a summary for more than one hole at a 

time, then LogCheck just displays a list of holes whose summary will be generated. However, these 

summaries can all then be exported or plotted and the results for each hole will be generated as they 

are exported or plotted. 
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13.3.1 Rock Mass Unit Summary 

The Rock Mass Unit Summary displays the recorded data for each individual Rock Mass Unit, 

summary values calculated from the recorded defects in each Rock Mass Unit (RMU), indices 

calculated from the Point Load data, UCS’s from various sources and finally a Unit Rating calculated 

from the other calculated results. The Unit Rating values for the roof can then combined together 

outside LogCheck to calculate a Coal Mining Roof Rating (CMRR). 

By selecting File > Open > Summary > Rock Mass Unit Summary from the LogCheck menu then 

LogCheck will calculate the RMU Summary. As the RMU Summary calculates UCS from sonic logs, 

before calculating the summary LogCheck prompts for which Las file resolution and which Las 

Formula Definition to use: 

 

For more information Las Formula Definitions see Section 6.4.5 – Opening Las Data. 

The variables in the Rock Mass Unit Summary are: 

• CalcThick Thickness of the RMU interval, that is the difference as calculated by LogCheck, 

between the base depths of this interval and the previous one. 

• Depth Base depth of each RMU. The interval top is assumed to be the base depth of the 

previous unit. Interval base depth must be greater than the base depth of the 

previous unit. Blank Depth values are used in LogCheck to indicate that the row 

in the table is a continuation of the data for the lithological unit on the previous 

row. 

• RT RMU Type – broken zone (B), defects (D), core loss (L), etc. RT is used by 

LogCheck to guide it on how to calculate summary information such as Rock 

Quality Designator (RQD), Fracture Frequency or Average Stick Length for units 

not containing any defects. 

• We Weathering – fresh (F), distinctly weathered (D), etc. 

• Al Alteration – fresh (F), distinctly altered (D), etc. 

• ES  Estimated strength – firm (C3), loose (S1), medium strength rock (R4), etc. 

• BS Bed spacing – irregular spaced bedding (IR), thinly bedded (TB), etc. 

• BD Bedding dip angle 

• MS Moisture Sensitivity – low sensitivity (L), high sensitivity (H), etc. 

• Pl Plasticity – brittle (B), high plasticity (H), etc. 

• RQD Rock Quality Designator calculated as percentage of unbroken lengths of core 

greater than or equal to 10cms in the RMU  

• FracSpac Average distance between defects in the RMU 

• FracFreq Frequency of fractures (fracts/m) in the RMU 

• DiIndex Average Diametral Point Load Index in the RMU 

• AxIndex Average Axial Point Load Index in the RMU 

• UCSAxial UCS for RMU calculated from AxIndex 

• UCSSonic UCS for RMU calculated from Sonic log using a Las Formula Definition 

• UCSTest UCS for RMU calculated from average laboratory test UCS value for the RMU 

• US Source of UCS used in calculating the Unit Rating. LogCheck preferably uses 

UCSTest (US set to L). If there is no value for UCSTest then it uses UCSSonic 
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(US set to S). Finally if there is no value for UCSTest or UCSSonic then it uses 

UCSAxial (US set to A) 

• UCS UCS used in calculating the unit rating 

• MSD Moisture Sensitivity Deduction. This is given one of the following values: 

- 0 if MS is N for Not Sensitive 
- -3 if MS is L for Low Sensitivity 
- -7 if MS is M for Medium Sensitivity 
- -15 if MS is H for High Sensitivity 

• UnitRat Unit Rating calculated from RQD, FracSpac, DiIndex, UCS and MSD 

 

A number of intermediate values are calculated in order to calculate UnitRat. These are also 

incorporated in the RMU Summary but are Hidden. To see these select View > Display/Hide Fields. 

These fields are: 

• UCSRat UCS rating calculated form UCS 

• RQDRat RQD rating calculated from RQD 

• FSRat Fracture Spacing Rating calculated from FracSpac 

• SpacRat Discontinuity Spacing Rating, the minimum of RQDRat and FSRat 

• DPLTRat Diametral Point Load Testing Rating calculated from DiIndex 

• DiscRat Discontinuity Rating, the minimum of SpacRat and DPLTRat 

 

Finally, UnitRat is calculated by adding together UCSRat, DiscRat and MSD 

 

An example of RMU Summary Data: 

  

13.3.2 Drill Run RQD 

Even though many geotechnical engineers calculate Rock Quality Designator (RQD), many prefer to 

stick to the original definition for RQD which is based on Drill Core Runs. One caution is that 

statistically calculating RQD’s based on core run lengths only makes sense if all ones core runs are 

approximately equal in length. 

By selecting File > Open > Summary > Drill Run RQD from the LogCheck menu then LogCheck will 

calculate the RQD. Clearly though in order to use this facility one needs to have for a hole not only 

Defect data but also Drilling data including Core Runs. 

The variables in the Drill Run RQD Summary are: 

• CalcThick Thickness of each Core Run 

• Depth Base depth of each Core Run 

• RunNo The Run Number 

• RQD Rock Quality Designator calculated as percentage of unbroken lengths of core 

greater than or equal to 10cms in the core run  
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When calculating Drill Run RQD, LogCheck warns the user that: 

 

 
 

An example of Drill Run RQD generated by 

LogCheck: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.3.3 Defect Spacings Summary 

The Defect Spacings Summary calculates the spacing between defects occurring in each hole. This is a 

useful measure of the potential of the rock to break up. 

Select File > Open > Summary > Defect Spacings menu item to open the Defect Spacing Summary. 

Then select the required holes and intervals from the standard Hole Selection dialog.  

Next the popup window is displayed: 

Enabling the user to choose between: 

• All Defect Types 

• Particular Defect Types 

• Groups in Defect Type Category in the Defects 

Dictionary 

If   selecting from the list of Defect Types or Groups in 

the Defect Type Category, one can select more than one 

by using the Shift and Ctrl keys while selecting. 

Unless Include Intact Defects and/or Include Induced 

Defects are ticked these Defects are not included in the 

calculations. 
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The variables in the Defect Spacing Summary are: 

• Depth Depth of each defect 

• Spacing Defect Spacing calculated as the length from halfway to the previous defect to 

halfway to the next defect. For RMU’s of Broken (B) or Soil Properties (S), the 

Spacing is set to 0.02 for the entire RMU. For RMU’s of Open (O), Core Loss (L) 

or Not Recorded (N), the Spacing is set to blank for the entire RMU 

 

An example of a Defect Spacing Summary: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.3.4 Fracture Frequency Summary 

The Fracture Frequency Summary calculates the number of fractures per metre from the Defect Data.  

This is another useful measure of the potential of the rock to break up. 

Select File > Open > Summary > Fracture Frequency menu item to open the Fracture Frequency 

Summary. Then select the required holes and intervals from the standard Hole Selection dialog.  

When calculating Fracture Frequency Summary, LogCheck warns the user that: 

 

 
 

The variables in the Fracture Frequency Summary are: 

• Depth Depth of halfway between each defect 

• Freq Fracture Frequency calculated as 1.0 divided by the length from the previous 

value of Depth to this value of Depth. For RMU’s of Broken (B) or Soil 

Properties (S), the Fracture Frequency is set to 50.0 for the entire RMU. For 

RMU’s of Open (O), Core Loss (L) or Not Recorded (N), the Fracture Frequency 

is set to blank for the entire RMU 
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An example of a Fracture Frequency Summary: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

13.3.5 Point Load Indices Summary 

The Point Load Index as calculated in LogCheck, is a size-corrected value that is the equivalent Point 

Load Index for a sample that would have been measured by a diametral test for a core diameter of 50 mm.  

The uncorrected point load index1  is calculated as follows: 

  I = P / D2 

  Where: 

  I:  Uncorrected point load strength; 

  P:  The load at failure; 

  D: The equivalent core diameter. 

The equivalent core diameter depends on whether the test was: 

(a) Diametral, where D is the core diameter. 

 

(b) Axial, where D is given by the following formula: 

  D = 4 * A / PI 

 Where A is the minimum cross-sectional area of a plane through the platen contact points: 

 A = Core length * Width (perpendicular to the loading direction) 

 

1  Journal of Geomechanics, Vol. 22, No.2, pp51-60, 1985. “Suggested method for Determining Point Load 

Strength” 

For a diametral test, if the sample length 

is less than the diameter, a value for the 

point load index is not calculated. 

For an axial test, if the sample length is 

greater than the diameter or the length is 

less than 0.3 of the diameter, a value for 

the point load index is not calculated. 
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The size-corrected Point Load Strength Index of a sample uses the following Size Correction Factor, 

F: 

 F = (D / 50)0.45 

The size-corrected Point Load Index used by LogCheck is given by the following formula: 

 Is(50) = F * 1000 * I           that is: 

 Is(50) = F * 1000 * (P / D
2) 

Select File > Open > Summary > Point Load Indices menu item to open the Point Load Indices 

Summary. Then select the required holes and intervals from the standard Hole Selection dialog.  

The variables in the Point Load Indices Summary are: 

• Depth Depth of base of Point Load Sample 

• Thickness  Thickness of Point Load sample 

• SampState Either wet (W) or dry (D) 

• DiIndex Diametral Point Load Index 

• AxIndex Axial Point Load Index 

 

An example of a Point Load Indices Summary: 
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Chapter 14  
 Coal Quality Extension 

 

By the end of this chapter, you will be able to understand: 

 

▪ The LogCheck Coal Quality data formats. 

▪ Importing Coal Quality data into LogCheck. 

▪ Opening, viewing and editing Coal Quality data in LogCheck. 

▪ Using LogCheck to generate Seam and Ply composite values. 

▪ Auditing the LogCheck database to determine what Coal Quality data it 

contains 
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14.1 Introduction  

Standard LogCheck includes a Basic Coal Quality system that will suffice for most coal exploration but 

once a project reaches a full feasibility study and it is necessary to model the coal preparation that will be 

required and markets that may purchase the coal then a far more sophisticated coal quality database 

system such as the LogCheck Coal Quality Extension is required. 

LogCheck’s Basic Coal Quality System LogCheck enables the entry, validation, storage, plotting and 

export of: 

• mass 

• relative density 

• total moisture 

• proximate analysis (moisture, ash, volatile matter and fixed carbon) 

• energy 

• impurities (total sulphur, phosphorus, chlorine, fluorine) 

• Crucible Swell Number (CSN) 

• Gieseler maximum fluidity 

 

on an air-dried basis for raw ply samples.  

Whereas the extended system covers the full CoalLog coal quality suite. That is, it covers various 

sample preparations such as: 

• crushing 

• drop shattering 

• wet or dry tumbling 

• wet or dry sizing 

• compositing of ply samples 

• clean coal compositing 

 

and allows results to be recorded for various: 

• size fractions including cumulative size fractions 

• float fractions including cumulative float fractions 

• froth fractions 

 

Data can be entered, reported and exported on different bases. However, all data is stored in the 

system on the bases that CoalLog specifies for the particular variable. 

The system handles all 207 coal quality variables that are specified in the CoalLog standard. 

Like the Basic Coal Quality system numeric variables can not only be pure numeric values but as per 

the CoalLog standard can also be: 

• a numeric value preceded with a < to indicate that it is below the lower detection limit that 

follows the < sign 

• a numeric value preceded with a > to indicate that it is above the upper detection limit that 

follows the > sign 

• IS for insufficient sample 

• NS for not sampled 

• NR for not reported 

• TBA for to be advised 

• CO for contraction only (only used for Dilatometer Maximum Dilatation and Maximum 

Dilatation Temperature) 

• NF for no fluidity (only used for Gieseler measurements) 
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14.2 Coal Quality Data Types  

LogCheck supports all five of the CoalLog Coal Quality data types: 

1) Coal Quality Results for reporting all analyses except Reflectance. It can be used for reporting 

ply and composite results, and for particular float and sizing fractions.  

2) Reflectance Results. 

3) Composite Constituents, for listing the sample number of all the individual ply or composite 

samples that have been included in each composite. 

4) Clean Coal Composite Definitions, for listing the parameters such as size fractions and density 

cut-points that have been included in a Clean Coal Composite (CCC). 

5) Test Specifications, for each test as identified by its Report Number and Variable Name and 

listing:  

• the standard to which it was tested 

• the lower detection limit of the testing 

• the upper detection limit of the testing 
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14.2.1 Coal Quality Results 

This includes the following key fields that are used for storing and finding results in the database: 

• SampType  

− PLY  individual samples 

− COMP  analysed composited samples 

− CALC  calculated composited samples 

• SampNumb a valid individual/ply sample number or a composite sample number 

• CCCType a name the user or the laboratory has assigned to a Clean Coal Composite to 

identify its composition 

• LabName where the test was performed 

• ReportNo the laboratory report number for the report providing the result  

• PreTreat 

− CRSH  crushed 

− DROP  drop shatter 

− DPHK  drop shatter followed by hand knapping 

− DPHD  drop shatter, hand knapped, dry tumbled 

− DPHW  drop shatter, hand knapped, wet tumbled 

− CLPV  coal pulverisation sieve analysis 

− CKPP  coke properties sieve analysis 

− GSUN  uncrushed gas sample 

− GSCR  crushed gas sample 

• DropCount the number of drops before sizing 

• SizeType 

− W  wet 

− D  dry 

• MinusSz the upper sizing cut-off in millimetres 

• PlusSz the lower sizing cut-off in millimetres 

• Sink the sink density in g/cm3 for the fraction 

• Float the float density in g/cm3 for the fraction 

• Froth the froth fraction name 

 

Every result must have non-blank values for SampType, SampNumb, LabName and ReportNo. 

Before a result for a SampNumb can be entered, the SampNumb must be defined by the user. Ply 

SampNumb’s are defined in the SampNumb column of the Geology data for the borehole and 

Composite SampNumb’s are defined in the Composite Constituents data for the borehole (see Section 

below). Similarly, before entering a result for a CCCType, the CCCType must be defined by the user 

as Clean Coal Composite Definition (see Section below). 

 

Other data describing the samples and results that can be entered along with the actual results are: 

• VR volume recovery 

• SampLith 

− CO coal 

− SN  stone 

− PA  parting 

− RF  roof 

− FL  floor 

• DispNumb dispatch number 

• PrevTest previous test 

− GD gas desorption 

− GT geotech  

• ReportDate date of laboratory report 

• LabSampleNo the laboratory’s sample identifier 
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In addition to these fields, whenever LogCheck opens Coal Quality Results, it uses the supplied 

SampType and SampNumb to determine from the Composite Constituent, Geology and Drilling data 

the following current values for each sample and then display them: 

• From the depth at the top of the sample 

• To the depth at the bottom of the sample 

• Thickness the sample thickness 

• FromSeam the seam at the top of the sample 

• ToSeam the seam at the bottom of the sample 

• FromPly the ply at the top of the sample 

• ToPly the ply at the bottom of the sample 

• LR the linear recovery 

• DrillDate the date the sample was drilled 

 

Where the FromSeam, ToSeam, FromPly or ToPly are not actually in seam or ply but in the roof or 

floor of a seam or ply, they are given the name of the seam or ply plus _RF for roof or _FLR for floor. 

 

The full list of results that can be recorded are listed in Appendix G. 
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14.2.2 Coal Reflectance Results 

This includes the following key fields that are used for storing and finding results in the database: 

• SampType  

− PLY  individual samples 

− COMP  analysed composited samples 

− CALC  calculated composited samples 

• SampNumb a valid individual/ply sample number or a composite sample number 

• CCCType a name the user or the laboratory has assigned to a Clean Coal Composite to 

identify its composition 

• LabName where the test was performed 

• ReportNo the laboratory report number for the report providing the result  

• VitType 

− TELO Vitrinite Reflectance A (Telovitrinite) 

− DETRO Vitrinite Reflectance B (Detrovitrinite) 

− ALL Vitrinite Reflectance (A & B) 

• StepMin the minimum reflectance value for the step  

• StepMax the maximum reflectance value for the step 

 

Every result must have non-blank values for SampType, SampNumb, LabName, ReportNo. and 

VitType. 

 

Before a result for a SampNumb can be entered, the SampNumb must be defined by the user. Ply 

SampNumb’s are defined in the SampNumb column of the Geology data for the borehole and 

Composite SampNumb’s are defined in the Composite Constituents data for the borehole (see Section 

below). Similarly, before entering a result for a CCCType, the CCCType must be defined by the user 

as Clean Coal Composite Definition (see Section below). 

 

Other data describing the samples and results that can be entered along with the reflectance results are: 

• DispNumb dispatch number 

• ReportDate date of laboratory report 

• LabSampleNo the laboratory’s sample identifier 

 

In addition to these fields, whenever LogCheck opens Reflectance Results, it uses the supplied 

SampType and SampNumb to determine from the Composite Constituent, Geology and Drilling data 

the following current values for each sample and then display them: 

• From the depth at the top of the sample 

• To the depth at the bottom of the sample 

• Thickness the sample thickness 

• FromSeam the seam at the top of the sample 

• ToSeam the seam at the bottom of the sample 

• FromPly the ply at the top of the sample 

• ToPly the ply at the bottom of the sample 

• DrillDate the date the sample was drilled 

 

Where the FromSeam, ToSeam, FromPly or ToPly are not actually in seam or ply but in the roof or 

floor of a seam or ply, they are given the name of the seam or ply plus _RF for roof or _FLR for floor. 

 

The results that can be recorded for reflectance are: 

• RoMax Mean Maximum Vitrinite Reflectance 

• No Number of Readings 

• Freq Frequency 

• RvMin Minimum Vitrinite Reflectance 

• RvMax Maximum Vitrinite Reflectance 



CHAPTER 14. COAL QUALITY EXTENSION 

LogCheck Manual 355 

• SD Standard Deviation of Mean determining Reflectance 

• StepMin Step Minimum Reflectance 

• StepMax Step Maximum Reflectance 

• StepFreq Frequency of Reflectance Results for Step 

 

For each sample number, only one line for each VitType can have results for RoMax, No, Freq, RvMin, 

RvMax and SD.  

 

All other lines for the sample number and VitType, must have values for StepMin, StepMax and 

StepFreq.   

An example of Reflectance data in LogCheck is: 
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14.2.3 Composite Constituents 

Each Composite Number referred to in Coal Quality Results or Reflectance Results needs to have its 

Constituent Samples defined in the Composite Constituents data for the hole. Constituent Samples 

may be Individual Ply Samples, other Composite Samples or a mixture of both. An example of 

Composite Constituents in LogCheck is shown in the following figures. Normally for Composite 

Constituents, there would only be Composite Numbers in the first Composite Number column 

(CompNumb1) but the other three Composite Number columns are used where different Composite 

Samples overlap. The window in the top right of each screen displays the composite constituents of 

the currently selected composite and enables the creation and editing of composites and their 

constituents. The following figures demonstrate a slightly artificial situation where: 

- CompNumb1 contains a series of Composites, each created from two or three individual ply 

samples. 

- CompNumb2 contains a single composite made up of just Individual Ply Samples. 

- CompNumb3 contains a single composite made up from the Composites in CompNumb1. 

- CompNumb4 contains a single composite made up from both Individual Ply Samples and 

Composites in CompNumb1. 
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Example of a Composite made up of Individual Ply Samples: 
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Another Example of a Composite made up of Individual Ply Samples: 
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An Example of a Composite made up of other Composite Samples: 
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An Example of a Composite made up of both Induvial Ply Samples and other Composite Samples: 
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14.2.4 Clean Coal Composite Type Definitions 

Each Clean Coal Composite Type referred to in Coal Quality Results or Reflectance Results needs to 

be defined by a Clean Coal Composite Type Definition. The user can create as many Clean Coal Type 

Definitions for a project as they like and each must have a unique name as supplied by the user. There 

is considerable flexibility how the user defines each Clean Coal Composite Type. The possible 

variables they can define are: 

• Hole: hole name 

• SampType:   

− PLY  individual samples 

− COMP  analysed composited samples 

• SampNumb: a valid individual/ply sample number or a composite sample number 

• SizeType: 

− W  wet 

− D  dry 

• MinusSz: the upper sizing cut-off in millimetres 

• PlusSz: the lower sizing cut-off in millimetres 

• Sink: the sink density in g/cm3 for the fraction 

• Float: the float density in g/cm3 for the fraction 

• Froth: the froth fraction name 

• Comment: any other comments. This field is particularly useful where the other variables don’t 

adequately define the Clean Coal Composite Type 

 

For a particular Clean Coal Composite Type, the user may like to define a common definition for their 

entire project: 

 

 
 

Or they may like to define a different definition for each hole: 
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14.2.5 Test Specification Definitions 

For each report provided by the laboratory, the specifications for each test that was performed can be 

recorded in the Test Specifications for the Report. The information that can be recorded is: 

• LabName: where the test was performed 

• ReportDate: date of laboratory report 

• Variable: the CoalLog variable name for the test (see Appendix A) 

• Standard: the standard to which the test was performed 

• LowerLimit: the lower detection limit 

• UpperLimit: the upper detection limit 

 

The mandatory fields for each record are: LabName, Variable and LowerLimit. 

 

An example of a Test Specification Definition: 
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14.3 Importing Coal Quality Data  

As with importing all CoalLog data types into LogCheck, there are two possible Data Layouts for 

importing data into LogCheck: 

 

• LogCheck 

• CoalLog Data Transfer 

 

The advantage of LogCheck layout is that the user can have whatever column headings they like on 

their data and can specify the basis of the data being imported. The disadvantage is that the user must 

include a Basis column in their data and they must set up a mapping between the columns in their 

imported data and the names of the appropriate LogCheck variable for each column. LogCheck, though 

does save the mappings to be the default mapping when the same type of data is being imported. 

The advantage of CoalLog Data Transfer is that there is no setup required by the user before importing 

the data as the program already contains the mappings between the CoalLog variables and a CoalLog 

Data Transfer file. With a CoalLog Data Transfer format, there is also no need to specify the basis of 

the results as they will be recorded on the basis as specified in the CoalLog standard (see Appendix 

A). 

14.3.1 Importing Coal Quality Results in LogCheck Layout 

To import Coal Quality Results into 

LogCheck, select: 
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Then for LogCheck layout, select Data 

Layout of LogCheck and Data Type of 

Coal Quality: 

 

 

 

 

 

 

 

 

Then select whether importing data including All 

Properties or a particular Property Group. See Appendix 

A to see the results in each Property Group. 

 

 

 

 

Then enter the location and 

name of the import file: 
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If All Properties was selected, the following table will be displayed. Enter the mappings between the 

LogCheck Coal Quality Results columns and the Column Names in the import file into this table: 

 

When selecting the Import File Column Name, pressing the drop down arrow will display the list of 

column names in the import file: 
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If a particular Property Group was selected, a window similar to the following will be displayed. Enter 

the mappings between the LogCheck Coal Quality Results columns and the Column Names in the 

import file: 

 

Similar to the All Properties, pressing the drop down arrow will display the list of column names in 

the import file: 

 

Whether using All Properties or a Property Group, it is necessary to specify columns for SampType, 

SampNumb, LabName, ReportNo and Basis. If the various variables are to the Basis specified in the 

CoalLog standard then each line in the file should have a Basis of ARP for As Reported. Each variable 

will be stored in LogCheck with the Basis that is defined by CoalLog for that Basis (see Appendix A). 

Any results that are not on that Basis will be converted to that Basis on import into LogCheck.  
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If Coal Quality results already exist for the 

borehole, the warning on the right will be 

displayed: 

 

 

 

If Selected Fields is pressed and if any results for a 

particular already exist in LogCheck for their 

particular SampType, SampNumb, CCCType, 

LabName, ReportNo, PreTreat, DropCount, 

SizeType, MinusSz, PlusSz, Sink, Float and 

Froth then a message such as the following will 

be displayed: 

 

 

 

 

 

14.3.2 Importing Reflectance Results in LogCheck Layout 

To import Reflectance Results in LogCheck 

Layout into LogCheck, select: 
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Then for LogCheck layout, select Data 

Layout of LogCheck and Data Type of 

Reflectance: 

 

 

 

 

 

 

 

Then enter the location and name of 

the import file: 
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Enter the mappings between the LogCheck Reflectance columns and the Column Names in the import 

file into the following window: 

 

 

It is necessary to specify columns for SampType, SampNumb, LabName, ReportNo and VitType.  

 

If reflectance results already exist for 

the borehole, the warning on the right 

will be displayed: 

 

 

 

 

Unlike Coal Quality results the user can not add further results to those for a borehole that already has 

Reflectance data. It is only possible to overwrite the results for the entire hole. 
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14.3.3 Importing Composite Constituents Data 

To import Composite Constituants Data 

select : 

 

 

 

 

 

 

 

 

Note that CoalLog Data Transfer is the only option for Data Layout for importing Composite 

Constituents. 

 

14.3.4 Importing Clean Coal Composite Type Definitions in 
LogCheck Layout 

To import Clean Coal Composite Definitions in LogCheck Layout into LogCheck, select: 

 

 

 

 

 



CHAPTER 14. COAL QUALITY EXTENSION 

LogCheck Manual 371 

Next select LogCheck Data Layout: 

 

 

 

 

 

 

 

 

 

Then enter the location and 

name of the import file: 
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Then enter the mappings between the LogCheck Clean Coal 

Composite Type columns and the Column Names in the 

import file into the window: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

If any Clean Coal Composites Types in 

the import file already exist in 

LogCheck, the warning to the right will 

be displayed: 
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14.3.5 Importing Test Specifications in LogCheck Layout 

To import Test Specifications in LogCheck Layout into LogCheck, select: 

 

 

Next select LogCheck Data Layout: 
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Then enter the location and 

name of the import file: 

 

 

 

 

 

 

 

 

 

 

 

Enter the mappings between the LogCheck Test Specification 

columns and the Column Names in the import file into the window: 

 

 

 

 

 

 

 

 

 

 

 

If any Reports in the import file already 

exist in LogCheck, the following warning 

will be displayed: 
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14.4 Opening, Viewing and Editing Coal Quality Data 

14.4.1 Opening, Viewing and Editing Coal Quality Results 

To open Coal Quality Data select: 

 

 

 

 

 

 

 

 

 

Next, select the hole 

or holes whose Coal 

Quality data are 

required: 

 

 

 

 

 

 

If All Holes or Hole Set are selected, only the list of Holes with Coal Quality results will be displayed 

rather than the actual data. The data from these holes though can now be exported or plotted. 
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Finally, select the required Coal Quality results for the selected holes: 

 

 

The only options that will be available for selection in the above window will be those for which that 

type of data exists within the selected holes. For example, if there is only Ply data for the selected 

holes, the only available options in the Sampling box will be Ply Sample Results and Both Ply and 

Composite Sample Results. For Sample Preparation, Raw will only be available if the selected holes 

contain Raw data, Clean Coal Composites will only be available if the selected holes contain Clean 

Coal Composite data and Specific Preparation will only be available if the selected holes contain 

Sized or Washed data. 

Similarly, in the Coal Quality Properties box, the drop-down list for Property Groups will contain only 

Property Groups that exist in the data.  

All the data is stored on an As Reported basis, that is on the basis specified in CoalLog for each 

specific variable but if another basis is selected then any data that are basis dependent are first 

converted to the required basis before being displayed, exported or plotted. 

LogCheck does not store samples’ from and to depths nor samples’ seam and ply names with the Coal 

Quality results. It does, however, display this information whenever displaying Coal Quality results 

but obtains it at the time from the current Geology data. This ensures that the from and to depths and 

seam and ply names always match those currently used for export of the Geology data to modelling 

packages. 

Coal Quality data can always be entered or updated directly from imported .csv files. To ensure data 

integrity though, results in the database can only be manually edited provided the following all apply: 

• only the data for a single hole has been selected 

• all the Coal Quality data for the hole has been selected, that is the options Both Ply and 

Composite Sample Results, All Properties and All Results have been selected 

• moisture basis of As Reported has been selected 

• the user has Manager status. To turn on Manager status select Manager from the Settings 

drop-down menu and then enter the Manager password 
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14.4.2 Opening, Viewing and Editing Reflectance Results 

To open Coal Quality Data select: 

 

 

 

 

 

 

 

 

 

Next, select the hole or 

holes whose Reflectance 

data are required: 

 

 

 

 

 

 

Finally, select the required Reflectance results for the selected holes: 
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With Sampling, only those options that are available in the Reflectance data for the selected holes can 

be selected. For example, if there is only Reflectance data on Composites then Composite Sample 

Results will be the only available option in the Sampling box. 

Coal Quality data can be always be entered or updated directly from imported.csv files. To ensure data 

integrity though, results in the database can only be manually edited provided the following all apply: 

• only the data for a single hole has been selected 

• All Results has been selected 

• the user has Manager status. To turn on Manager status select Manager from the Settings 

drop-down menu and then enter the Manager password 

 

14.4.3 Opening, Viewing and Editing Composite Constituents 

To open Composite Constituents 

select: 

 

 

 

 

 

 

 

 

Next, select the 

hole or holes 

whose Composite 

Constituents are 

required: 

 

 

 

 

 

 

If All Holes or Hole Set are selected, only the list of Holes with Composite Constituents will be 

displayed rather than the actual data. However, the Composite Constituents from these holes can now 

be exported. 
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When viewing and editing Composite Constituents, the main table displays the Depths, Seams and/or 

Plies, Lithologies and Sample Numbers from the Geology data, basic Coal Quality results for the 

individual Ply samples and any composites that have been entered for the displayed data. The data in 

the main table are all in grey as they cannot be directly modified, however, there is also a separate 

window entitled Edit Composite Constituents where composite numbers can be entered, modified or 

deleted: 

 

Before entering any composite numbers, the interval displayed above will appear as: 
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To enter a Composite named 789_90 consisting of the individual plies 789 and 790, click on the 

Composite Number box in the editing window and enter the new composite number 789_90 and then 

press Tab: 

 

 

Next click on the Top Sample field and enter the Sample Number 789 for the top sample. This can be 

either entered by directly typing or by clicking on the sample number in the main table: 
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Next click on the Bottom Sample field and enter the Sample Number 790 for the bottom sample. This 

can be either entered by directly typing or by clicking on the sample number in the main table: 

 

 

Then lastly, click on the Update button in the editing window and the main table will then display the 

new Composite: 
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A Composite can consist of individual plies and/or other composites. To create a composite named 

788_90 consisting of the individual ply 788 and the composite 789_90, click on the Composite 

Number box in the editing window and enter the new composite number 788_90 and then press Tab: 

 

Next click on the Top Sample field and enter the Sample Number 788 for the top sample and then 

click on the Bottom Sample field and enter 788 again for the bottom sample and then press Tab. 

Again, these can be either entered by directly typing or by clicking on the individual ply sample 

numbers in the main table. 
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Next choose Comp for Composite Sample in the Sample Type column: 

 

Next click on the Top Sample field and enter the Composite Sample Number 789_90 for the top 

sample and then click on the Bottom Sample field and enter 789_90 again for the bottom sample and 

then press Tab. Again, these can be either entered by directly typing or by clicking on the composite 

sample number in the main table. 
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Then lastly, click on the Update button in the editing window and the main table will then display the 

new Composite: 

 

 

At any time, to go to a particular Composite and see its constituents, enter the number for the required 

composite in the Composite Number box, either by typing or picking it on the main screen. 

 

To rename a Composite go to the Composite by either entering its number or picking it on the main 

screen and then press the Rename button in the edit window. For example, to rename composite 

number 788_90 to 788_90PC, go to 788_790 and then click on Rename and the following window 

will appear where the new number can be entered: 
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Following renaming, the main table will show the new name: 

 

 

To delete a Composite, goto it by either entering it the Composite Number box or picking it on the 

screen and then clicking the Delete button. Following clicking on the Delete button in the edit window 

on the above screen, and the result is: 
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14.4.4 Opening, Viewing and Editing Clean Coal Composite 
Type Definitions 
 

As a particular Clean Coal Composite Definition may be the same for all holes or slightly different for 

each hole, it is considered to be a Definition rather than Hole Data and so to open a Clean Coal 

Composite Definition select: 

 

 

Next select the required Clean Coal Composite Type: 
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The selected Clean Coal Composite Definition will then be displayed and can be edited: 

 

 

14.4.5 Opening, Viewing and Editing Laboratory Test 
Specifications 

A particular set of Laboratory Test Specifications will apply to a particular Laboratory Report rather 

than to a particular hole and so it is considered a Definition. To open a particular set of Laboratory 

Specifications select: 

it is necessary it is referred to as a Definition rather than Hole Data and so to open a Laboratory Test 

Specification select: 
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Next select the Report No whose Laboratory Test Specifications are required: 

 

 

The selected Laboratory Test Specifications will then be displayed and can be edited: 
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14.5 Coal Quality Audits and Summaries 

14.5.1 Coal Quality Audit 

The Coal Quality Audit displays a list of the Coal Quality Results that are currently stored in 

LogCheck. 

An audit of the data currently stored in the LogCheck Coal Quality database can be displayed by 

selecting: 

 

 

Next select the holes 

or holes for which 

the audit is required: 
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An example of the resulting audit:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In this audit, SampType will be PLY for Individual Ply samples and COMP for Composite samples 

and for Prep will be Raw, SizeWash or CCC (for Clean Coal Composites).  

From this example audit, it can be seen that Hole DEMO044 has Mass, Proximate and CSN results on 

13 Individual Ply samples that have been Sized and/or Washed, however, it does not show what actual 

size or float/sink fractions have been included for these 13 samples. It can also be seen that this same 

hole has Mass, Proximate, Energy, Impurities, CSN, Ash Analysis, Ash Fusibility, Gieseler, 

Dilatometer, Gray-King and Petrography results on 11 Clean Coal Composite samples and 

Carbonization and Reflectance results on 9 Clean Coal Composites.   



CHAPTER 14. COAL QUALITY EXTENSION 

LogCheck Manual 391 

14.5.2 Clean Coal Composite Audit 

The previous Coal Quality audit showed that results had been stored in LogCheck for 11 Clean Coal 

Composites samples for DEMO034. How many of the results for these 11 samples are for each of the 

user defined Clean Coal Composites Types can be displayed by selecting: 

 

 

 

Next select the holes 

whose Clean Coal 

Composite results 

should be included:  
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The resulting audit shows that the 

hole had results on ten Clean Coal 

Composites samples of types 

PRIMARY and results on one Clean 

Coal Composite of type SECOND: 

 

14.5.3 Seam and Ply Composite Summary 

LogCheck can generate composite values for Seams and Plies as defined in the Geology data. It can 

also generate them for concatenated Seam plus Ply names. Composite values are only generated where 

Individual Ply and/or Composite results exist for the entire Seam or Ply and the top and bottom 

samples do not extend past the boundaries of the Seam or Ply. 

To generate Seam or Ply composite values select: 
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After selecting 

whether composites 

are required for 

Seams, Plies or 

Seams + Plies, select 

the hole or holes for 

which they are 

required: 

 

 

 

 

 

Next select the results (Individual Ply and/or Composite) to be used, the properties to be displayed, the 

required Moisture Basis, whether to use results are for Raw Coal, a specific Cumulative Float or a 

specific Clean Coal Composite and whether to use Apparent Relative Density or Relative Density 

when weighting results to composite together: 

 

 

If Ply Sample Results is chosen, then Seam/Ply composites will be generated for each Seam/Ply by 

calculating a composite from the results for Individual Ply samples. If a single Individual Ply sample 

covers the entire Seam/Ply the results for this sample are displayed rather than a calculated value. 

If Composite Sample Results is chosen, then Seam/Ply composites will be generated for each 

Seam/Ply by calculating a composite from the results for Composites samples. If a single Composite 

sample covers the entire Seam/Ply the results for this sample are displayed rather than a calculated 

value. 

If Composite Sample Results when available otherwise use Ply Sample Results is chosen, then 

Seam/Ply composites will be generated for each Seam and/or Ply by calculating a composite from the 

results for Composite samples and it these do not exist, do not cover the entire Seam/Ply or cover an 

interval that extends past the boundaries of the Seam/Ply, then Individual Ply sample results are 

included with any Composite sample results and if the combination of Composites and Individual 

sample results covers the entire Seam/Ply exactly this is used.  
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In the above example, those results derived entirely from Composite sample results are shown in grey.  

Those that include results from Individual Ply samples are shown in red.  

The column Cored displays the length of the interval that has been cored as derived from the Bit Type 

in the Drilling data. The column Core_Loss displays the total length of units with LithoTypes that 

have a code whose entry in the Group column of the Geology Dictionary is set to CORE LOSS. For 

CoalLog data, this would be KL – Core Loss, NR – Nor Recovery, OW – Old Workings or VD – 

Void. 

The Recovery is the percentage of the interval that was cored and was not core loss. 

The sample numbers for the top and bottom Individual Ply samples used in generating composite 

values are shown in the columns SampNumb and SampNumb2 and the sample numbers for the top 

and bottom Composite samples used in generating the composite values are shown in the columns 

CompNumb and CompNumb2. 
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Appendix A - LogCheck Folders and Files 

A1 Introduction  

This appendix describes the directory (ie. folder) structure used by LogCheck. It describes the 

LogCheck program and its support files and the location and purpose of the different subfolders that 

are used by LogCheck to store dictionaries, drill hole data and definitions.  

LogCheck uses various folders for storing the: 

• its program and support files 

• its working and temporary files 

• its user data 

 

If any of these folders do not exist, the LogCheck program automatically creates them. 

 

 

 

A2 LogCheck Program Folders 

The user is able to specify the folder where the LogCheck program is stored but generally they select 

the default of c:\Program Files (x86)\LogCheck. Do not delete or alter any of the files in this folder. 

Some users such as consultants may have multiple versions of LogCheck installed on their computer, 

each running a different data format. In this case, they will have provided different folder names for 

each of the different copies. 

The program folder contains four subfolders: 

• Bin containing the LogCheck program plus support files that define the installation’s 

data formats 

• Dictionaries containing the system dictionaries. For CoalLog versions of LogCheck these are 

the standard CoalLog dictionaries 

• Docs containing the User Manual, plus other useful documents such as: 

- A summary of LogCheck’s features (LogCheck Promo with CQ.pdf), 

- How to change LAS variable and vertical scale in Plot Definition, 

- Procedure for creating a simple section to review geology with LAS 

- Using TrueView to View and Plot LogCheck dxf files 

• PlotPara containing system Plot Definitions 

LogCheck uses another piece of software named the Borland Database Engine to handle its databases. 

This software is automatically installed whenever LogCheck is installed or reinstalled. It sits in a 

folder named C:\Program Files (x86)\Common Files\Borland\BDE  
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A3 LogCheck Work Folders 

LogCheck creates two working folders to store working and temporary files. These are named: 

  C:\Users\username\AppData\Local\LogCheck\Work 

  C:\Users\username\AppData\Local\LogCheck\Temp 
 

where username is the name the user is logged not the computer with. 

The folder AppData is a hidden folder and so can only be seen in Windows Explorer if Hidden files is 

turned on in the View tab: 

 

Temporary files are those that will be deleted once LogCheck terminates. Working files are those that 

persist between LogCheck sessions. The user must have write access to these folders.  

If there are more than one user using LogCheck on a computer, they will have their own set of Work 

files and therefore will have their own settings for LogCheck. 

To return LogCheck to its originally shipped settings, delete the folder: 

C:\Users\username\AppData\Local\LogCheck 

and LogCheck will recreate the folder and containing files reflecting the original shipped settings. 
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A4 LogCheck Data Folders 

On running LogCheck for the first time the user is prompted for the name of folder where the data will 

be stored. This can be a folder on your hard drive or anywhere on your connected network. The default 

is C:\LogData. If the specified folder does not exist, the program creates it. 

The user can even have a number of LogCheck data folders but the program will only access data in 

the one that is current. For example, one could locate working data on the local hard drive and 

finalised data on a server. 

The user can change the folder from where LogCheck accesses its data by selecting Settings > Options 

from the LogCheck menu and then entering another folder name: 

 

The name of the new data folder can either be typed or select the Browse button to choose from a list. 

A typical LogCheck data folder structure: 

 

This shows three project folders (AVOCA, BOGGABRI and DEMO) and two folders (Definitions and 

Dictionaries) that are always automatically created by LogCheck. They are used to store the user’s 

default dictionaries and definitions, such as Interval, Las Formula or Plot Definitions. 
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A4.1 Dictionaries Folder 

Each dictionary consists of two files with names of the form: 

• Data Type Dictionary.dbf  

• Data Type Dictionary.mdx 

 

For example, the dictionary for the geology data consists of two files named Geology Dictionary.dbf and 

Geology Dictionary.mdx. The .dbf file contains the actual dictionary and the .mdx file an index to speed 

lookups in the dictionary. These files can be copied or deleted, but not renamed. Note that if you copy, 

delete or overwrite these files, you must do it for both of them 

When LogCheck searches for a dictionary for a particular data type it searches the following folders in 

the following order: 

1. the folder for the particular data type within the current project. 

2. the folder called Dictionaries sitting in the LogCheck data folder 

3. the folder called Dictionaries sitting in the LogCheck program folder  

For example, when looking for the geology dictionary for the project AVOCA it would look for: 

  C:\LogData\AVOCA\Geology\Geology Dictionary.dbf 
 

and if this file does not exist it would look for: 

  C:\LogData\Dictionaries\Geology Dictionary.dbf. 

 
 

and if this file does not exist it would look for: 

  C:\Program Files (x86)\LogCheck\Dictionaries\Geology Dictionary.dbf. 

 

Users working for a single mining company with a number of projects will generally have a single 

dictionary for all their projects sitting in the Dictionaries folder whereas a consultant will often have 

different dictionaries for different clients and these will be stored in each client’s projects. 

Unlike other data types, Geology data actually uses two dictionaries a Geology Dictionary and Seams 

Dictionary. This is because users will generally have only a single Geology Dictionary across all their 

projects but a specific Seams Dictionary for each of their projects. 

A4.2 Definitions Folder 

The Definitions folder contains a series of subfolders, one for each of the LogCheck Definition types: 

• CCCType Clean Coal Composite Type Definitions  

• ColourScale Colour Scale Definitions  

• GraphEditPara Graphic Editor Parameters  

• HistoPara Histogram Parameters  

• HoleSet Hole Set Definitions  

• Interval Interval Definitions  

• LasFormulae Las Formulae Definitions 

• PlanPara Hole Plan Parameters  

• PlotLegendPara Plot Legend Parameters  

• PlotPara Plot Parameters 

• TestSpecs Specifications for each Laboratory Coal Quality Test  
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Definition names can be of any length and may contain upper and lower case characters, however, 

they cannot contain blanks. It is recommended to use an underscore (_) character instead of a blank.  

All Definitions may be deleted, copied or renamed by deleting, copying or renaming their files. Note 

though that where the Definition consists of more than one file (see below), that whatever you do to 

one file you must also do the other files with the same definition name otherwise they will not work.  

A4.2.1 Clean Coal Composite Type Definition Files 

A Clean Coal Composite Definition contains a list of the components such as particular mesh sizes 

and float fractions for each defined Clean Coal Composite. See Section 14.4.4 – Opening, Viewing 

and Editing Clean Coal Composite Type Definitions in this manual. 

For each Clean Coal Composite Type Definition there are two files: 

• DefinitionName.DBF 

• DefinitionName.DBT 

A4.2.2 Colour Scale Definition Files 

A Colour Scale Definition lists colours to be used for particular ranges of values when plotting. See 

Section 12.9.4 – Display Options Panel in this manual. 

For each Colour Scale Definition there are two files: 

• DefinitionName.MEM 

• DefinitionName.DBF 

A4.2.3 Graphic Editor Definition Files 

A Graphic Editor Definition contains the LAS variable names, and values of the left edge, right edge 

and colour to be plotted in the Graphical Editor. See Section 8.28 – Graphic Editor Definitions. 

For each Graphic Editor Definition there is a single file: 

• DefinitionName.DBF 

A4.2.4 Histogram Definition Files 

A Histogram Definition specifies what categories to plot in histograms from coded data frequencies 

results. See Section 9.4.1 – Coded Data Frequencies in this manual. 

For each Histogram Definition there is a single file: 

• DefinitionName.MEM 

A4.2.5 Hole Set Definition Files 

A Hole Set Definition contains hole list, section definition and/or a query for selecting holes to open. 

See Section 6.5 – Creating/Editing a Hole Set Definition. 

For each Hole Set Definition there are two files: 

• DefinitionName.MEM 

• DefinitionName.DBF 

A4.2.6 Interval Definition Files 

An Interval Definition specifies a query for selecting an interval to open within holes. See Section 6.6 

– Creating/Editing Interval Definitions. 
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For each Interval Definition there is a single file: 

• DefinitionName.MEM 

A4.2.7 Las Formula Definition Files 

A Las formula definition specifies a formula for using to calculate an additional new variable when 

opening LAS data. See Section 6.4.5 – Opening LAS Data. 

For each Las Formula Definition there is a single file: 

• DefinitionName.MEM 

A4.2.8 Hole Plan Definition Files 

A Hole Plan Definition contains the parameters for drawing hole plans. See Section 11.2 – Creating 

and Editing a Hole Plan Definition. 

For each Hole Plan Definition there is a single file: 

• DefinitionName.MEM 

A4.2.9 Plot Legend Definition Files 

A Plot Legend Definition specifies the layout for plotting a legend of patterns to accompany hole 

plots. See Section 12.10.1 – Creating a Plot Legend Definition. 

For each Plot Legend Definition there are two files: 

• DefinitionName.MEM 

• DefinitionName.DBF 

A4.2.10 Plot Definition Files 

A Plot Definitions specifies for a plot items such as scale and variables to be plotted. See Section 12.4 

to 12.9 – Plot Definitions. 

For each Plot Definition there are four files: 

• PlotDefinitionName.MEM the scale and sheet definitions 

• PlotDefinitionName_Bars.DBF the depth and RL bar definitions 

• PlotDefinitionName_Titles.DBF the definition of text to be added to the plot in the title block or for 

each hole 

• PlotDefinitionName_Tracks.DBF the definitions for each of the vertical tracks, including the 

names of the variables to be plotted and how they are to be 

plotted 

A4.2.11 Laboratory Coal Quality Test Specification Files 

A Laboratory Coal Quality Test Specification File contains for a particular laboratory report, the 

standard each test was performed to and detection limits for each test. See Section 14.2.5 – Test 

Specification Definitions. 

For each Laboratory Coal Quality Test Specification Definition there is a single file: 

• DefinitionName.DBF 
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A4.3 Project Folders 

Each LogCheck project has its own folder in the LogCheck data folder. The folder has the name that 

was specified for the project when it was created. A project can be deleted, copied or renamed by 

deleting, copying or renaming this folder. Project names can only be a maximum of eight characters 

and must not contain blanks.  

Each project folder contains a file named:  

project.mem Containing Project Details for the project. Do not delete or rename this file. If 

this file is present, LogCheck recognizes the folder as one of its project folders. If 

it is deleted, it will no longer be recognized as a LogCheck project folder. You 

can create other folders in the LogCheck data folder, however, LogCheck will 

ignore them without this file. 

If project.mem is deleted, it can be restored by creating a new project, copying across the data, 

deleting the old project and renaming the new project.  

After a new project is created, LogCheck creates the following subfolders: 

Definitions Containing the project specific definitions. The composition of this subfolder is 

the same as the Definitions subfolder of the LogCheck data folder. See Section 

A.4 – Definitions Subfolder above.  

Exports The default folder for text and reports produced by LogCheck, the user though 

can export these to other folders. 

Imports The default folder for dictionaries or data from other systems to be imported into 

LogCheck, the user though can import these from other folders. 

LAS For downhole geophysical data 

Plots The default folder for plots created by LogCheck, the user though can send these 

to other folders. 

Work Containing working files created by LogCheck.  

 

Depending on what data is present for the project it may also contain the following subfolders for data:  

Activities containing daily activity data such as safety and other comments and planned 

operations for the following day. See Section 5.13 – Daily Activity Data. 

Casing containing hole casing data. See Section 5.6 – Casing Data. 

Cementing containing details for each hole of any cementing. See Section 5.7 – 

Cementing Data. 

Coal Quality containing coal quality laboratory results. See Section 14.2.1 – Coal Quality 

Results. 

Composites containing a list of constituent samples for each composite sample. See 

Section 14.2.3 – Composite Constituents. 

Defects Containing Rock Mass Unit (RMU) and individual defect data. See Section 

13.2.1 – Defect Data. 

Drilling containing drilling data such as drilling company and core size. See Section 

5.5 – Drilling Data. 

Geologists containing what intervals were logged by which geologist. See Section 5.4 – 

Geologists Data. 

Geology containing geological data such as lithology, colour, seam name. See Section 

5.8 – Geology Data. 

GeotechLabTests containing results from Geotech laboratory tests such as UCS and ITS. See 

Section 13.2.4 – Geotechnical Laboratory Test Data. 

Headers containing header data such as survey coordinates. See Section 5.3 – 

Headers Data. 

PointLoads containing point load data. See Section 13.2.3 – Point Load Test Data. 
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Reflectance containing coal quality reflectance laboratory results. See Section 14.2.2 – 

Coal Reflectance Results. 

Rehab containing the rehabilitation that has been performed. See Section 5.14 – 

Rehabilitation Data. 

SampDispatch containing sample information such as laboratory name where sent, dispatch 

mass, date and number. See Section 5.11 – Sample Dispatch Data. 

Scanner containing acoustic scanner analyses data. See Section 13.2.2 – Acoustic 

Scanner Analysis Data. 

Sites containing drill hole site data. See Section 5.2 – Drill Hole Site Planning 

Data. 

WaterFlows containing water flow data. See Section 5.9 – Water Flow Data. 

A project may also have the following folders generated by LogCheck when required: 

Archived containing copies of files that were moved using the Move Displayed Files 

command. See Section 10.5 – Moving and Copying LogCheck Data Files. 

LasWork containing copies of the user’s Las files in dBASE format. See Section 6.4.5 

– Opening LAS Data. 

LogEdits contains a text file for each hole that has been modified in the Graphical 

listing the changes that were made to the data by the Graphical Editor. See 

Section 8.18 View the Log of Edits. 

Raw_Defects containing copies of any Defect files that have been modified in the 

Graphical Editor but before any changes have been made to them. 

Raw_Geology containing copies of any Geology files that have been modified in the 

Graphical Editor but before any changes have been made to them. 

 
 

An example of the folders in a project subfolder is shown below in the left pane and the contents of the 

Geology folder in the right pane: 
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A4.3.1 LAS Subfolder 

Downhole geophysical data used by the program must be in LAS format. The folder where these files 

are stored for a project is specified by the user in the Project Details of the project. If the user does not 

specify a LAS folder then the program uses the LAS subfolder in the project folder.  

When looking for LAS data the program not only searches the specified folder but all levels of 

subfolders below it. There is a limitation though that the name of the combined subfolders below this 

folder plus the filename must be less than or equal to 100 characters and must not contain any blanks.   

After the user has accessed any LAS data, the project’s LasWork subfolder will also contain the files: 

• LAS Dictionary.DBF a dictionary of the variable names used in any of the LAS files; 

• LAS Dictionary.MDX an index into the dictionary of variable names. 

• LasFileName.DBF the dBase binary version of the Las file named LasFileName 

• LasFileName.DEF a dBase binary file describing the variables in the Las file named 

LasFileName 

• LasFileName.MEM a dBase binary file recording the last modified date and time for the Las 

file named LasFileName at the time LasFileName.DBF was created. This 

is used whenever the user accesses LasFileName to check if the Las file 

has been modified since LasFileName.DBF was created to determine if it 

needs to be recreated. 

 

The last three of these files are used by LogCheck to speed up opening of LAS data.  

 

A4.3.2 Work Subfolder 

The work subfolder contains working files that are created and maintained by LogCheck. For example, 

the files SEAMS.DBF and SEAMS.MDX contain a summary of the top and bottom of each seam in 

each hole as well as the file modification time and date for the geology file from which the 

information was obtained. When the user requests a seam summary the program only updates those 

holes in these files where the geology data has been modified since the last seam summary. Where 

there are a large number of holes such as a couple of thousand this can reduce the time taken to 

generate a seam summary from minutes to seconds. 

The user can delete these files if for example they become corrupted. When deleting a file the user 

should also delete all other files in the folder with the same filename but differing extensions. If these 

files are not there, LogCheck will first need to recreate them, which can be a little time consuming if 

there are many files in the project. 

A4.3.3 Data Subfolders 

The activities subfolder contains the following files for each date named: 

• Date.DBF the coded data for the date Date where the date is in the format yyyy-mm-dd, 

for example 2004-02-27. 

• Date.DBT the comments for the date Date 

 

The sites subfolder contains the following files for each site named: 

• SiteName.DBF the coded data for the site named SiteName 

• SiteName.DBT the comments for the site named SiteName 

Each hole data subfolder contains the following files for each hole named: 

• HoleName.DBF the coded data for the hole named HoleName 
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• HoleName.DBT the comments for the hole named HoleName. The only exception being 

Composites as these do not have comments. 

Data subfolders may also contain the appropriate lookup dictionary files. 

Data can be deleted, copied between projects or machines or its date, site or hole name changed by 

deleting, copying or renaming these files. It is important though that whatever action the user the user 

performs on the .DBF file they also perform on the corresponding .DBT file. 

Depending on version of LogCheck, the maximum size for a hole name is between 8 and 16 

characters. It also must not contain blanks. This restriction though, means that the user can take 

backup copies of the files and give them names such as HoleName - copy.DBF and leave them in this 

subfolder and LogCheck will ignore them. 

The filenames of all data types for a hole are the same therefore care must be taken when moving files 

ensuring that they are placed in the folder for that data type in the destination project. For example, for 

each hole, there can be a file in the Headers, Drilling and Geology folders, each with the same name – 

their contents being defined by the folder they occur in: 
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Appendix B – dBASE Query Language 

B1 Introduction 

Data in LogCheck can be selected by using query selection statements. The syntax or rules used to 

specify a query are those of the DBL (dBASE language) and can be used for selecting records from a 

database table. 

The query selection syntax is used in the following places in LogCheck: 

• Hole Set Definitions, when selecting the holes by query. 

• Interval Definitions. 

• Filtering data in LogCheck summaries. 

• Plot Definitions for specifying a level for aligning the vertical position of holes in a section. 

 

 

An example of using a query to select a group of holes is shown below (see Section 6.5 

Creating/Editing Hole Set Definitions). In this example, Seam is the variable name at the heading of 

the Seam column when editing Geology data. This query will include all holes where seam WK2 has 

been logged. Note that character strings such as WK2 require the double quotes in queries otherwise 

dBASE assumes that they are a data column name. 

 

 

An example of using a query to select the top of an interval is shown below (see Section 6.6 

Creating/Editing Interval Definitions). This example selects intervals whose top is 1.0m above a unit that 

is a seam (Seam <> " "). 
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An example of using a filter to display only specific rows in a summary is shown below (see Section 

7.6.5 Tools Menu – Filter). This example selects just those rows whose seam name starts with WK2. 

 

 

An example of using a query to specify in a Plot Definition the vertical alignment of each hole on a 

section is shown below (see Section 12.5.7 – Vertical Layout for Sections). This example is from the 

Sheet Layout tab of a Plot Definition, aligns the holes on a section so that the top of the WK2 seam is 

at the same level for each hole on the section. 
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B2 Writing Selection Queries 

Selection queries involve some kind of restriction on the data that is selected. This is done by 

specifying some kind of restriction on a variable – a variable is one of the columns on a database table, 

for example the column named Seam in Geology data. 

Example 1. In a Hole Set Definition, to select only holes that have a seam that starts with "GU0": 

 SEAM = "GU0" 

 

The column names and text values are not case sensitive, for example, both Seam and seam would also 

work. Also, when specifying values in a comparison: 

• Character strings as in Seam = “GU0” must have double quotes around them otherwise 

dBASE assumes string is a data column name 

• Numeric values such as in CalcThick > 1.0 do not have delimiters around them 

• Date values such as in Date = ctod(“01/01/2020”) must be entered as strings surrounded by 

double quotes and then transformed to a date with the character to date function ctod(). 

• Logical values, that is true or false, for example, Ph (Photographed) in Header data  

 

Operators that can be used to select data include: 

• Comparison operators, 

• Logical operators, 

• dBASE functions. 

 

B2.1 Comparison Operators 

The comparison operators consist of equality and relational operators as follows: 

Equality Operators Relational Operators 

== Exactly equals < Less than 

= Equal to, or begins with > Greater than 

<> or # Not equal <= Less than or equal 

  >= Greater than or equal 

 

The following examples use the thickness or seam columns in hole seam summaries.  

Example 1. Select seam intervals where the thickness equals 0.20: 

 Thickness = 0.20  

 

Example 2. Select seam intervals that are exactly the GU0 seam (uses two equal signs): 

 Seam == "GU0" 

 

Example 3. Select seam intervals that match anything starting with "GU0" (note that there is only one 

equal sign here): 

 Seam = "GU0" 
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Example 4. Select seam intervals where the thickness is less than 0.20 (does not include intervals that 

are 0.20):  

 Thickness < 0.20  

 

Example 5. Select seam intervals where the thickness is greater than 0.20 (does not include intervals 

that are 0.20): 

 Thickness > 0.20  

 

Example 6. Select seam intervals where the thickness is less than or equal to 0.20 (also includes 

intervals that are 0.20): 

 Thickness <= 0.20  

 

Example 7. Select seam intervals where the thickness is greater than or equal to 0.20 (also includes 

intervals that are 0.20):  

 Thickness >= 0.20  

 

Example 8. Select seam intervals where the thickness does not equal 0.20.  

 Thickness <> 0.20  
 

B2.2 Logical Operators 

The logical operators are AND, OR and NOT. Compound conditions are formed by connecting two or 

more conditions using the logical operators. The rules of precedence for operators, from highest to 

lowest are as follows: 

1. All comparison operators 

2. NOT 

3. AND 

4. OR 

 

Parentheses not only document your logic but can also create significant differences in a selection. 

Example 9. Select all holes with seam GU0, and where this seam is at a depth of greater than 100m: 

 Seam == "GU0" and Depth > 100 

 

Example 10. Select all holes with seam GU0 or GU1, and this seam is at a depth of 

greater than 100m: 

 (Seam == "GU0" or Seam == "GU1") and Depth > 100  

 

Example 11. Select all holes with seam GU0 (no matter the depth), or the seam is 

GU1 at a depth of greater than 100m: 

 Seam == "GU0" or Seam == "GU1" and Depth > 100  

 

Example 12. Select all holes with seam GU0, and this seam is at a depth of greater than 100m and less 

than 120m: 

 Seam = "GU0" and Depth > 100 and Depth < 120 

 

 

Note the difference in 

what will be selected  

between queries with 

parentheses and those 

without. 
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Example 13. When defining a Hole Set Definition named CORED, select all holes whose drilling has 

a Bit Type of DW, PC, PW or TC: 

 
 

B2.3 dBASE Functions 

There are many dBASE functions can also be used in a query to select data. Some of those that are 

useful in queries are: 

• at(string1, string2) returns a numerical value being the position of string1 in 

string2. If not found it returns 0  

• ctod(string1) returns the date value recorded in string1 

• day(date1) returns the numerical value of the day for date1 

• isblank(variable) returns a logical value of whether the variable’s value is 

blank 

• left(string1, number1) returns a string being the leftmost number1 of characters 

in string1 

• len(string1) returns a numerical value the number of characters in 

string1 

• ltrim(string1) returns a string with any leading blanks trimmed from 

string1 

• lower(string1) returns a string with all characters in string1 converted to 

lower case 

• month(date1) returns the numerical value of the month for date1 

• right(string1, number1) returns a string being the rightmost number1 of 

characters 

• rtrim(string1) trims the trailing blanks from string1 

• substr(string1, number1, number2) returns the substring within string1 starting at position 

number1 and of length number2 

• upper(string1) converts all characters in the variable to upper case 

• year(date1) returns the numerical value of the year for date1 

 

Example 13. When defining the Hole Set Definition named CORED, select headers for all holes 

where the hole name ends in a "C": 

 

In this case, the RTrim function firstly removes any trailing blanks from the hole name to achieve the 

match, then the Right function only returns those holes whose last character is "C". 
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Example 14. When viewing a sample summary, use a filter to only display sample numbers whose 

length is less than 8 characters. This maybe useful to determine where leading blanks have been left 

off the sample numbers. 

 

 

Example 15. Expressions where columns have a date data type, one can only enter the date as a string 

which needs to be converted to a date using the Ctod() function. For example, the Headers data has 

columns named Start and Complete that are date data types. The following expression filters holes 

whose start date is on or after 1/1/2003 and were completed on or before the 31/12/2003: 
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Appendix C – Standard Plot Definitions  

C1 Introduction  

LogCheck comes with a standard set of plot files. These include: 

• A seams only plot at 1:20 
• Entire hole with Geophysics (Density Gamma and Calliper) 

• Stacked plots of individual holes in A4 and A3, at scales of 1:20, 1:100, 1:200. 

• Section plots without horizontal scale (ie sit 10mm apart for a fence diagram) on A4 and A3 at 

1:100 and 1:200. 

 

The plot definitions for these are: 

What Description Plot Definition Vertical 

Scale 

Paper 

Size 

Seams Only Seams-only plot in 

one plot file. 

LC_SEAM 1:20  –   

Geology + LAS Tracks: Lithology + 

LAS in one bar and 

one plot file. 

Orientation: portrait 

LC_GEOLAS - - 

LC_GEOLAS_A3_20 1:20 A3 

LC_GEOLAS_A4_200 !:200 A4   

Stacked Plot Single hole, lithology 

in multiple bars; 

multiple plot files. 

Tracks: Lithology, 

Seam, SampNumb. 

Orientation: portrait 

LC_STACK_A4_20 (5m/col) 1:20 A4 

LC_STACK_A3_20 (7m/col) 1:20 A3 

LC_STACK_A4_100 (25m/col) 1:100 A4 

LC_STACK_A3_100 (35m/col) 1:100 A3 

LC_STACK_A4_200 (50m/col) 1:200 A4 

LC_STACK_A3_200 (70m/col) 1:200 A3 

Section Plot 

 

Stratigraphic fence 

plot of seams. 

Requires hole set and 

interval definitions. 

Orientation: 

landscape. 

LC_SECTN_A4_100 

(25m/col) 
1:100 A4 

LC_SECTN_A3_100 

(35m/col) 
1:100 A3 

LC_SECTN_A4_200 

(50m/col) 
1:200 A4 

LC_SECTN_A3_200 

(70m/col) 
1:200 A3 
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C2 Seams-Only Plot 

The Seams Plot Definition (LC_SEAMS) plots the defined seams in a single hole with the top of each 

interval all displayed at the one level. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To generate this plot: 

1. Set up a Seams Interval Definition (File > New > Interval Definition) as explained in Section 

6.6.2.2 - Selecting Multiple Intervals in a Single Hole. 

2. Open the data for the required hole (File > Open > Hole Data) with the Interval Definition 

Seams set up in step 1. 

3. Generate the plot (File > Plot) and select the LC_SEAM plot definition.  
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C3 Geology with Geophysics 

There are three standard Plot Definitions for plotting the Geology with Geophysics: 

• LC_GEOLAS  plots the entire hole in a single one bar plot, useful for displaying the 

data on the screen  

• LC_GEOLAS_A4_200  plots the hole over a number of A4 pages at 1:200, useful for 

generating an overview of the hole for reports 

• LC_GEOLAS_A3_20  plots the hole over a number of A3 pages at 1:20, useful for 

generating hole for fine analysis 
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LC_GEOLAS plots the entire hole as one bar with the LAS data plotted in tracks (DENB, GRDE, 

CADE). An excerpt from a plot generated using LC_GEOLAS: 

 

The 

Sheet  

 

 

Layout page of this Plot Definition includes: 

 

 

Tracks page of this Plot Definition includes: 
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LC_GEOLAS_A4_200  plots the geology, seam, plies and sample numbers over a number of A4 pages 

at 1:200: 
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The Sheet Layout page of this Plot Definition includes: 

 

The crucial difference in the Sheet Layout compared to the previous is that Vertical Layout - 

Maximum Track Length is 45 metres instead of 9999 metres. 

 

The Tracks page of this Plot Definition includes: 
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LC_GEOLAS_A3_20 plots the geology, seam, plies and sample numbers over a number of A3 pages 

at 1:20: 
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The Sheet Layout page of this Plot Definition includes: 

 

The crucial differences between this Sheet Layout and the previous one are: 

• Horizontal Layout – Maximum No. of Repititions across Sheet is now 2 instead of 1 

• Vertical Layout - Vertical Scale of 1 metres = 50mm’s instead of 5mm’s 

• Vertical Layout – Maximum Track Length of 7m instead of 45m 

The Tracks page of this Plot Definition includes: 

 

This is the same as the previous Plot Definition’s Tracks page except for the values of XOrig and 

Width. 

 

All the system Geology - Geophysics Plot Definitions assume that the geophysical traces have the 

names CADE, DENB, DENL and CADE. If this is not so, it is first necessary to edit the Plot 

Definition with the required geophysical trace names and then use File > Save As to save the modified 

defintion to the User Default or Project Plot Defintions. One needs to use Save As instead of Save as it 

is not possible to modify the system Plot Definitions. Note also that the saved copies cannot begin 

with LC_ as this prefix is preserved for LogCheck system Plot Definitions. 

The steps to generate any of these geology and geophysics plots are: 

1. Open the Geology data for the required hole (File > Open > Hole Data) and select the required 

drill hole. 

2. Generate the plot (File > Plot), select the LC_SEAM plot definition and save the plot file.  

3. Open the LAS data (File > Open > Hole Data and select LAS data from the Data Type drop 

down box) 

4. Select File > Plot, choosing the same plot file name as used in Step 2 and respond Append not 

Overwrite when prompted. 
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C4 Stacked Plots 

The stacked plot definitions plot hole data at scales of 1:20, 1:100 and 1:200 in multiple bars, to as 

many plot files as are required, on A4 or A3 sheets. The following example using hole DDH001 was 

produced using LC_STACK_A4_20, plotted on an A4 sheet: 
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Details from a plot generated using the LC_STACK_200 Plot Definition, with the sample number on 

the left of the column, and seam on the right: 

 

The Tracks page of the stacked Plot Definitions: 

 
 

The steps required to generate this plot are: 

1. Open the data for the required hole (File > Open > Hole Data), using if required a Hole Set 

and/or Interval Definition. 

2. Generate the plot (File > Plot) and select one of the LC_STACK plot definitions.  
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C5 Section Plots 

A LogCheck section plot draws a stratigraphic section displaying the holes specified in a Hole Set 

Definition and possibly also using an Interval Definition. They also display correlation lines for seams 

between holes.  

There are four standard section plots as detailed in the table in the introduction to this appendix:  

• LC_SECTN_A4_100 (max. 25m/col) 

• LC_SECTN_A3_100 (max. 35m/col) 

• LC_SECTN_A4_200 (max. 50m/col) 

• LC_SECTN_A3_200 (max. 70m/col) 

Each of these plot to either an A3 or A4 sheet and use either a vertical scale of 1:100 or 1:200. and 

plots to an A3 sheet.  

On the Sheet Layout page of these Plot Definitions: 

• Horizontal Layout is set to Fixed Interval 

• Section - Vertical Alignment is set to Hole Elevation.  

• Horizontal Offset to First Hole on the Left and Vertical Offset to Shallowest Hole Top may 

need to be adjusted for all holes to appear within the plot border.  

This plot used a Horizontal  Offset of 70 mm and Vertical Offset of -70 mm:  

 

The steps required to generate this plot are: 

1. Open the data for the required holes (File > Open > Hole Data) using the required Hole Set 

Definition and possibly an Interval Definition. 

2. Generate the plot (File > Plot) and select one of the LC_SECTION plot definitions.  
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Appendix D - AutoCAD Colours 
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Appendix E - LogCheck Patterns 
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Appendix F - LogCheck Fills 
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Appendix G - Coal Quality Property Groups 

G1 Sample Descriptions in All Property Groups 

 

Description Basis 
LogCheck 

Field Name 
CoalLog Variable 

Name 

Sample Base Depth   Depth To_Depth 

Sample Type (Ply/Comp)   SampType Sample_Type 

Sample Number   SampNumb Sample_No 

From Depth   From From_Depth 

To Depth   To To_Depth 

Sample Thickness   Thickness Thickness 

From Seam   FromSeam NC_FromSeam 

To Seam   ToSeam NC_ToSeam 

From Ply   FromPly NC_FromPly 

To Ply   ToPly NC_ToPly 

Linear Recovery   LR Linear_Recovery 

Volume Recovery   VR Volume_Recovery 

Sample Drilling Date   DrillDate NC_DrillDate 

Litho Category   SampLith Sample_Lith 

Dispatch Number   DispNumb Dispatch_No 

Previous Test   PrevTest Previous_Test 

Comments   Comments Comments 

Laboratory   LabName Lab_Name 

Laboratory Report No.   ReportNo Report_No 

Laboratory Report Date   ReportDate Report_Date 

Laboratory Sample No.   LabSampNo Lab_Sample_No 

Clean Coal Composite Type   CCCType CCC_Type 

Treatment before Testing   PreTreat Pre_Treatment 

No of Drops   DropCount Drop_Count 

Size Type (Dry/Wet)   SizeType Size_Type 

Upper Sizing   MinusSz Minus_Size 

Lower Sizing   PlusSz Plus_Size 

Sink Density   Sink Sink 

Float Density   Float Float 

Froth Fraction   Froth Froth 

Mass Percent aka Yield (ad, %) Air Dried MassPct Mass_ar_kg 

Mass (ar, kg) As Received MassAR Mass_ad_kg 

Mass (ad, kg) Air Dried MassAD Mass_pct 
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G2 General Properties 

 

Description Basis 

LogCheck 
Field 

Name 
CoalLog Variable 

Name 

Apparent Relative Density (g/cm^3)   ARD ARD_gpcm3 

Relative Density (ad, g/cm^3) Air Dried RD RD_ad_gpcm3 

Free Moisture (ar, %) As Received FM Free_Moist_ar_pct 

Residual Moisture (ad, %) Air Dried RM Resid_Moist_ad_pct 

Total Moisture (ar, %) As Received TM Total_Moist_ar_pct 

Moisture Holding Capacity (%)   MHC MHC_pct 

Calculated In-situ Moisture (%)   ISM NC_ISM 

Moisture in Analysis Sample (ad, %) Air Dried MIAS MIAS_ad_pct 

Ash (ad, %) Air Dried Ash Ash_ad_pct 

Volatile Matter (ad, %) Air Dried VM VM_ad_pct 

Fixed Carbon (ad, %) Air Dried FC FC_ad_pct 

Specific Energy (ad, MJ/kg) Air Dried SE NC_SE_ad_MJpKg 

Gross Calorific Value (ad, kcal/kg) Air Dried CV CV_ad_kcalpKg 

Total Sulphur (ad, %) Air Dried TS TS_ad_pct 

Chlorine (ad, %) Air Dried Cl Cl_ad_pct 

Phosphorus (ad, %) Air Dried P P_ad_pct 

Fluorine (ad, ppm) Air Dried F F_ad_ppm 

Crucible Swell No   CSN CSN 

Hardgrove Grindability Index   HGI HGI 

Carbon (daf, %) Dry Ash Free C C_daf_pct 

Hydrogen (daf, %) Dry Ash Free H H_daf_pct 

Nitrogen (daf, %) Dry Ash Free N N_daf_pct 

Sulphur (daf, %) Dry Ash Free S S_daf_pct 

Oxygen (daf, %) Dry Ash Free O O_daf_pct 

Carbonate (ad, %) Air Dried CO3 CO3_ad_pct 

Carbon Dioxide (ad, %) Air Dried CO2 CO2_ad_pct 

Pyritic Sulphur (ad, %) Air Dried PS PS_ad_pct 

Sulphates (ad, %) Air Dried SO4 SO4_ad_pct 

Organic Sulphur (ad, %) Air Dried OS OS_ad_pct 
 

  



APPENDIX G. COAL QUALITY PROPERTY GROUPS 

LogCheck Manual 437 

G3 Thermal Properties 

 

Description Basis 

LogCheck 
Field 

Name 
CoalLog Variable 

Name 

Silica Dioxide (domf, %) Dry Organic Matter Free SiO2 SiO2_domf_pct 

Aluminium Oxide (domf, %) Dry Organic Matter Free Al2O3 Al2O3_domf_pct 

Ferric Oxide (domf, %) Dry Organic Matter Free Fe2O3 Fe2O3_domf_pct 

Calcium Oxide (domf, %) Dry Organic Matter Free CaO CaO_domf_pct 

Magnesium Oxide (domf, %) Dry Organic Matter Free MgO MgO_domf_pct 

Sodium Oxide (domf, %) Dry Organic Matter Free Na2O Na2O_domf_pct 

Potassium Oxide (domf, %) Dry Organic Matter Free K2O K2O_domf_pct 

Titanium Dioxide (domf, %) Dry Organic Matter Free TiO2 TiO2_domf_pct 

Manganese Oxide (domf, %) Dry Organic Matter Free Mn3O4 Mn3O4_domf_pct 

Phosphorus Oxide (domf, %) Dry Organic Matter Free P2O5 P2O5_domf_pct 

Sulfur Trioxide (domf, %) Dry Organic Matter Free SO3 SO3_domf_pct 

Barium Oxide (domf, %) Dry Organic Matter Free BaO BaO_domf_pct 

Strontium Oxide (domf, %) Dry Organic Matter Free SrO SrO_domf_pct 

Zinc Oxide (domf, %) Dry Organic Matter Free ZnO ZnO_domf_pct 

Vanadium Pentoxide (domf, %) Dry Organic Matter Free V2O5 V2O5_domf_pct 

Chromium Oxide (domf, %) Dry Organic Matter Free Cr2O3 Cr2O3_domf_pct 

Nickel Oxide (domf, %) Dry Organic Matter Free NiO NiO_domf_pct 

Loss On Fusion (domf, %) Dry Organic Matter Free Loss Loss_domf_pct 

Undetermined (domf, %) Dry Organic Matter Free AAUnd AA_Und_domf_pct 

Total oxides (domf, %) Dry Organic Matter Free TotOx Tot_Ox_domf_pct 

Base - Acid Ratio   BAR NC_BAR 

        

Reducing Atmosphere (°C)       

Deformation Temperature   DefRed Def_Red_degC 

Sphere Temperature   SphRed Sph_Red_degC 

Hemisphere Temperature   HemiRed Hemi_Red_degC 

Flow Temperature   FlowRed Flow_Red_degC 

        

Oxidising Atmosphere (°C)       

Deformation Temperature   DefOx Def_Ox_degC 

Sphere Temperature   SphOx Sph_Ox_degC 

Hemisphere Temperature   HemiOx Hemi_Ox_degC 

Flow Temperature   FlowOx Flow_Ox_degC 

        

Abrasion Index (mgFe/kg)   Aindex Abr_Index_mgFepKg 

Hardgrove Grindability Index   HGI HGI 

Durham Cone handleability (s/kg)   DCH DCH_spkg 
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G4 Coking Properties 

 

Description Basis 
Logcheck 

Field Name 
CoalLog Variable 

Name 

Gieseler       

Test Date   GiesDate Gies_Date 

Maximum Fluidity (dd/min)   GiesMF Gies_MF_ddpm 

Log10 Maximum Fluidity   GiesLog Gies_Log 

Initial Softening Temp (°C)   GiesIST Gies_IST_degC 

Maximum Fluidity Temp (°C)   GiesMFT Gies_MFT_degC 

Resolidification Temp (°C)   GiesRST Gies_RST_degC 

Plastic Range (°C)   GiesPR Gies_PR_degC 

Fusion Temp (°C)   GiesFusTmp Gies_Fusion_degC 

Temp Fluidity 5ddpm (°C)   GiesFldTmp Gies_5F_degC 

Prop Final Fluid 1ddpm (dd/min)   GiesFF Gies_FF_ddpm 

        

Dilatometer       

Test Date   DilaDate Dila_Date 

Initial Softening Temp (°C)   DilaIST Dila_IST_degC 

Maximum Contraction Temp (°C)   DilaMCT Dila_MCT_degC 

Maximum Dilatation Temp (°C)   DilaMDT Dila_MDT_degC 

Maximum Contraction (%)   DilaMC Dila_MC_pct 

Maximum Dilatation (%)   DilaMD Dila_MD_pct 

        

Crucible Swell No   CSN CSN 

        

Gray-King: Test Date   GKTypeDate GK_Type_Date 

Gray-King: Coke Type   GKType GK_Type 

        

Sapozhnikov Plastometer       

Test Date   SapozDate Sapoz_Date 

X (%)   SapozX Sapoz_X_pct 

Y (mm)   SapozY Sapoz_Y_mm 

        

Rheology       

Roga Index - Test Date   RogaDate Roga_Date 

Roga Index - Test Value   Roga Roga 

Caking (G) Index Test Date   GindexDate G_Index_Date 

Caking (G) Index   Gindex G_Index 

Dilatation - Coking Capacity (G-factor)   DilataCC Dila_Coke_Capacity 

Dilatation - Pencil weight (wet)   DilataPW Dila_Pencil_Wgt_w_g 

Dilatation - SD 2.5 (%)   DilataSD25 Dila_SD2_5 

Sole Heated Oven - Expansion/Contraction (%)   SHOExpCon SHO_Exp_Con_pct 
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G5 Trace Element Properties 

 

Description Basis 

LogCheck 
Field 

Name 
CoalLog Variable 

Name 

Arsenic (ad, ppm) Air Dried As As_ad_ppm 

Silver (ad, ppm) Air Dried Ag Ag_ad_ppm 

Boron (ad, ppm) Air Dried B B_ad_ppm 

Barium (ad, ppm) Air Dried Ba Ba_ad_ppm 

Beryllium (ad, ppm) Air Dried Be Be_ad_ppm 

Bismuth (ad, ppm) Air Dried Bi Bi_ad_ppm 

Bromine (ad, ppm) Air Dried Br Br_ad_ppm 

Cadmium (ad, ppm) Air Dried Cd Cd_ad_ppm 

Cobalt (ad, ppm) Air Dried Co Co_ad_ppm 

Chromium (ad, ppm) Air Dried Cr Cr_ad_ppm 

Copper (ad, ppm) Air Dried Cu Cu_ad_ppm 

Gallium (ad, ppm) Air Dried Ga Ga_ad_ppm 

Germanium (ad, ppm) Air Dried Ge Ge_ad_ppm 

Mercury (ad, ppm) Air Dried Hg Hg_ad_ppm 

Potassium (ad, ppm) Air Dried K K_ad_ppm 

Lithium (ad, ppm) Air Dried Li Li_ad_ppm 

Manganese (ad, ppm) Air Dried Mn Mn_ad_ppm 

Molybdenum (ad, ppm) Air Dried Mo Mo_ad_ppm 

Sodium (ad, ppm) Air Dried Na Na_ad_ppm 

Nickel (ad, ppm) Air Dried Ni Ni_ad_ppm 

Lead (ad, ppm) Air Dried Pb Pb_ad_ppm 

Rubidium (ad, ppm) Air Dried Rb Rb_ad_ppm 

Antimony (ad, ppm) Air Dried Sb Sb_ad_ppm 

Selenium (ad, ppm) Air Dried Selen Se_ad_ppm 

Tin (ad, ppm) Air Dried Sn Sn_ad_ppm 

Strontium (ad, ppm) Air Dried Sr Sr_ad_ppm 

Tellurium (ad, ppm) Air Dried Te Te_ad_ppm 

Thorium (ad, ppm) Air Dried Th Th_ad_ppm 

Titanium (ad, ppm) Air Dried Ti Ti_ad_ppm 

Thallium (ad, ppm) Air Dried Tl Tl_ad_ppm 

Uranium (ad, ppm) Air Dried U U_ad_ppm 

Vanadium (ad, ppm) Air Dried V V_ad_ppm 

Zinc (ad, ppm) Air Dried Zn Zn_ad_ppm 

Zirconium (ad, ppm) Air Dried Zr Zr_ad_ppm 

Total Minerals (ad, %) Air Dried TrElMin TrEl_Minerals_ad_pct 
 

  



APPENDIX G. COAL QUALITY PROPERTY GROUPS 

 440  LogCheck Manual 

G6 Petrography Properties 

 

Description Basis 
LogCheck 

Field Name 
CoalLog Variable 

Name 

Petrography Test Date   PetroDate Petro_Date 

Light Transmittance (%)   LightTrans Light_Trans_pct 

Coke (%)   Coke Coke_pct 

Minerals (%)   PetroMin Petro_Minerals_pct 

Oxidized Coal (%)   CoalOx Coal_Ox_pct 

Contaminants (%)   Contam Contam_pct 

Mesophase (%)   Mesophase Mesophase_pct 

Counted Points   Count Maceral_No 

        

Vitrinite Group (%)   Vitr Vitrinite_pct 

        

Telovitrinite SubGroup (%)   Telovitr Telovitrinite_pct 

Textinite (%)   Text Textinite_pct 

Texto-ulminite (%)   TextoUlm Texto_Ulminite_pct 

Eu-ulminite (%)   EuUlm Eu_Ulminite_pct 

Telocollinite (%)   Telocoll Telocollinite_pct 

        

Detrovitrinite SubGroup (%)   Detrovitr Detrovitrinite_pct 

Attrinite (%)   Attr Attrinite_pct 

Densinite (%)   Dens Densinite_pct 

Desmocollinite (%)   Desmocoll Desmocollinite_pct 

        

Gelovitrinite SubGroup (%)   Gelovitr Gelovitrinite_pct 

Corpogelinite (%)   Corpogel Corpogelinite_pct 

Porigelinite (%)   Porigel Porigelinite_pct 

Eugelinite (%)   Eugel Eugelinite_pct 

        

Liptinite Group (%)   Lipt Liptinite_pct 

Sporinite (%)   Spor Sporinite_pct 

Cutinite (%)   Cut Cutinite_pct 

Resinite (%)   Res Resinite_pct 

Liptodetrinite (%)   Liptodetr Liptodetrinite_pct 

Alginite (%)   Alg Alginite_pct 

Suberinite (%)   Suber Suberinite_pct 

Fluorinite (%)   Fluor Fluorinite_pct 

Exsudatinite (%)   Exsudat Exsudatinite_pct 

Bituminite (%)   Bitum Bituminite_pct 

        

Inertinite Group (%)   Inert Inertinite_pct 

        

Telo-inertinite SubGroup (%)   Teloinert Teloinertinite_pct 

Fusinite (%)   Fus Fusinite_pct 

Semifusinite (%)   Semifus Semifusinite_pct 
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Description Basis 
LogCheck 

Field Name 
CoalLog Variable 

Name 

Semifusinite Reactive (%)   Semifus_Re Semifusinite_Re_pct 

Funginite (%)   Fung Funginite_pct 

        

Detro-inertinite SubGroup (%)   Detroinert Detroinertinite_pct 

Inertodetrinite (%)   Inertodetr Inertodetrinite_pct 

Micrinite (%)   Micr Micrinite_pct 

        

Gelo-inertinite SubGroup (%)   Geloinert Geloinertinite_pct 

Macrinite (%)   Macr Macrinite_pct 
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G7 Carbonisation Testing Properties 

 

Description Basis 
LogCheck 

Field Name CoalLog Variable Name 

Coke Strength after Reaction       

Test Date   CSRDate CSR_Date 

Test Value   CSR CSR 

        

Coke Reactivity Index       

Test Date   CRIDate CRI_Date 

Test Value   CRI CRI 

        

Small Scale Coke Oven Test       

Coke Yield Test Date   SSCOYldDt SSCO_Yld_Date 

Coke Yield (%) DRY SSCOYld SSCO_Yld_d_pct 

Coke Yield 7kg (%) DRY SSCOYld7kg SSCO_Yld_7kg_d_pct 

Coke Final Temp (°C)   SSCOFnlTmp SSCO_Final_Temp_degC 

        

ASTM Tumbler Test       

Hardness - +6.3mm square-hole - 1400 revs (%)   CokeHard Coke_Hardness_pct 

Stability - +25mm square-hole - 1400 revs (%)   CokeStb Coke_Stability_pct 

        

Drum Test       

IRSID Index 10 - +20mm round-hole - 500 revs (%)   IRSID20 IRSID_20_pct 

IRSID Index 10 - +40mm round-hole - 500 revs (%)   IRSID40 IRSID_40_pct 

Micum Index 10 - +10mm round-hole - 100 revs (%)   Micum10 Micum_10mm_pct 

Micum Index 30 - +30mm round-hole - 100 revs (%)   Micum30 Micum_30mm_pct 

Micum Index 40 - +40mm round-hole - 100 revs (%)   Micum40 Micum_40mm_pct 

        

JIS       

Index 150 - +15mm square-hole - 150 revs (%)   JISDrum150 JIS_Drum_150r_pct 

Index 30 - +15mm square-hole - 30 revs (%)   JISDrum30 JIS_Drum_30r_pct 

        

JIS Coke Tumbler Test       

+15mm - 150 revs (%)   JIS150r15 JIS_CTT_150r15mm_pct 

+25mm - 150 revs (%)   JIS150r25 JIS_CTT_150r25mm_pct 

+50mm - 150 revs (%)   JIS150r50 JIS_CTT_150r50mm_pct 

+15mm - 30 revs (%)   JIS30r15 JIS_CTT_30r15mm_pct 

+25mm - 30 revs (%)   JIS30r25 JIS_CTT_30r25mm_pct 

+50mm - 30 revs (%)   JIS30r50 JIS_CTT_30r50mm_pct 

        

Shatter Index 10mm       

+10mm square-hole (%)   SI10 Shatter_10mm_pct 

+40mm square-hole (%)   SI40 Shatter_40mm_pct 

        

Carbonization       

Test Date   CbDate Carb_Date 

Conditions - Moisture in Charge (%)   CbMoist Carb_Moist_pct 
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Description Basis 
LogCheck 

Field Name CoalLog Variable Name 

Conditions - < 3.35 mm (%)   Cb335 Carb_3_35mm_pct 

Conditions - ASTM Bulk Density  (kg/m^3) DRY CbBD Carb_ASTM_BD_kgpm3 

Conditions - Charge Width (mm)   CbCW Carb_Chg_Wdth_mm 

Results - Coke Yield (%)   CbCkYld Carb_Coke_Yield_pct 

Results - Coking rate to 900°C (mm/h)   CbRate900 Carb_Rate_900_mmph 

Results - Coking rate to Push (mm/h)   CbRatePush Carb_Rate_Push_mmph 

Results - Final Centre Temp (°C)   CbFCT Carb_FC_Temp_degC 

Conditions - Initial Wall Temp (°C)   CbIWT Carb_IW_Temp_degC 

Results - Max wall pressure (kPa)   CbMWP Carb_MW_Press_kPa 

Results - Shoulder Pressure (kPa)   CbSP Carb_Shldr_Press_kPa 

Results - Max gas pressure (kPa)   CbMGP Carb_MG_Press_kPa 

Conditions - Net Wet Charge Density (g/cm^3)   CbNWCD Carb_NWC_Dens_gpcm3 

Conditions - Oven Dry Bulk Density (g/cm^3)   CbODBD Carb_ODB_Dens_gpcm3 

        

Coke Apparent Relative Density (g/cm^3)   ARDCoke ARD_Coke_gpcm3 
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